aboutsummaryrefslogtreecommitdiff
path: root/databases/qt-sqlite-plugin/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-04-29 08:57:12 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-04-29 08:57:12 +0000
commit5271da855f0c5946ff1f3aa58fbe806871df2f87 (patch)
tree526d65e6697f1e03c06ab0d0f901688aa2c4e18d /databases/qt-sqlite-plugin/Makefile
parent8730c99d5ea1ba861dbab3e0dbc07e16826b1a7a (diff)
downloadports-5271da855f0c5946ff1f3aa58fbe806871df2f87.tar.gz
ports-5271da855f0c5946ff1f3aa58fbe806871df2f87.zip
Rely on bsdtar to autodetermine the format of the distfiles when possible
For a while now bsdtar is able to autotermine compression and archive format. Let's then use tar directly instead of piping to tar. Now USE_BZIP2 and USE_XZ only set EXTRACT_SUFX to the right format
Notes
Notes: svn path=/head/; revision=316786
Diffstat (limited to 'databases/qt-sqlite-plugin/Makefile')
-rw-r--r--databases/qt-sqlite-plugin/Makefile11
1 files changed, 3 insertions, 8 deletions
diff --git a/databases/qt-sqlite-plugin/Makefile b/databases/qt-sqlite-plugin/Makefile
index 996a59db38d3..e757b31cb788 100644
--- a/databases/qt-sqlite-plugin/Makefile
+++ b/databases/qt-sqlite-plugin/Makefile
@@ -1,10 +1,5 @@
-# -*-mode: makefile-*-
-# New ports collection makefile for: qt-sqlite-plugin
-# Date created: 27 February 2004
-# Whom: Michael Nottebrock <lofi@freebsd.org>
-#
+# Created by: Michael Nottebrock <lofi@freebsd.org>
# $FreeBSD$
-#
PORTNAME= qt-${DB}-plugin
PORTVERSION= 3.3.8
@@ -28,8 +23,8 @@ EXPIRATION_DATE= 2013-07-01
USE_BZIP2= yes
PLUGIN= plugins/src/sqldrivers/${DB}
DRIVER= src/sql/drivers/${DB}
-EXTRACT_AFTER_ARGS?=| ${TAR} -xf - ${DISTNAME}/${PLUGIN} \
- ${DISTNAME}/${DRIVER} ${DISTNAME}/src/sql/drivers/cache
+EXTRACT_AFTER_ARGS?= ${DISTNAME}/${PLUGIN} \
+ ${DISTNAME}/${DRIVER} ${DISTNAME}/src/sql/drivers/cache
MAKEFILE= ${FILESDIR}/Makefile.bsd
MAKE_ENV+= DB="${DB}" DRIVER="${DRIVER}" PLUGIN="${PLUGIN}" \
PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \