aboutsummaryrefslogtreecommitdiff
path: root/databases/qt-sqlite-plugin/Makefile
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2013-07-26 19:19:20 +0000
committerRene Ladan <rene@FreeBSD.org>2013-07-26 19:19:20 +0000
commit66fee909266a1dedf3dfc1f03bb0841380d78805 (patch)
tree4c98d494bc4532b5dd5b19f4e47bcb3babf104c2 /databases/qt-sqlite-plugin/Makefile
parenteec2cb8d7407c5628cc8016e7349abbee6c98e3f (diff)
downloadports-66fee909266a1dedf3dfc1f03bb0841380d78805.tar.gz
ports-66fee909266a1dedf3dfc1f03bb0841380d78805.zip
KDE3 and QT3 expired on 2013-07-01, remove these ports.
Unfortunately, this also affects some ports using QT3 as a GUI toolkit. Changes to infrastructure files: - bsd.kde.mk : obsolete, remove - bsd.qt.mk : note that a CONFLICTS_BUILD line can probably go after a while - CHANGES : document the removals from bsd.port.mk - KNOBS : remove KDE and QT (KDE4 and QT4 should be used instead) - MOVED : add the removed ports PR: ports/180745 Submitted by: rene Approved by: portmgr (bapt) Exp-run by: bapt
Notes
Notes: svn path=/head/; revision=323748
Diffstat (limited to 'databases/qt-sqlite-plugin/Makefile')
-rw-r--r--databases/qt-sqlite-plugin/Makefile35
1 files changed, 0 insertions, 35 deletions
diff --git a/databases/qt-sqlite-plugin/Makefile b/databases/qt-sqlite-plugin/Makefile
deleted file mode 100644
index faaa04b3da81..000000000000
--- a/databases/qt-sqlite-plugin/Makefile
+++ /dev/null
@@ -1,35 +0,0 @@
-# Created by: Michael Nottebrock <lofi@freebsd.org>
-# $FreeBSD$
-
-PORTNAME= qt-${DB}-plugin
-PORTVERSION= 3.3.8
-PORTREVISION= 9
-CATEGORIES= databases
-MASTER_SITES= ${MASTER_SITE_QT}
-MASTER_SITE_SUBDIR= archive/qt/${PORTVERSION:R:R}
-DISTNAME= qt-x11-free-${PORTVERSION}
-DIST_SUBDIR= KDE
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= A plugin for QT to connect to SQLite-Databases
-
-DB= sqlite
-
-LIB_DEPENDS+= qt-mt:${PORTSDIR}/x11-toolkits/qt33 \
- sqlite.2:${PORTSDIR}/databases/sqlite2
-
-DEPRECATED= Depends on QT3; unmaintained
-EXPIRATION_DATE= 2013-07-01
-
-USE_BZIP2= yes
-PLUGIN= plugins/src/sqldrivers/${DB}
-DRIVER= src/sql/drivers/${DB}
-EXTRACT_AFTER_ARGS?= ${DISTNAME}/${PLUGIN} \
- ${DISTNAME}/${DRIVER} ${DISTNAME}/src/sql/drivers/cache
-MAKEFILE= ${FILESDIR}/Makefile.bsd
-MAKE_ENV+= DB="${DB}" DRIVER="${DRIVER}" PLUGIN="${PLUGIN}" \
- PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
- PTHREAD_LIBS="${PTHREAD_LIBS}"
-PLIST_SUB= DB=${DB}
-
-.include <bsd.port.mk>