aboutsummaryrefslogtreecommitdiff
path: root/databases/qt4-odbc-plugin
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2007-07-13 00:04:21 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2007-07-13 00:04:21 +0000
commitee279d859feb6202deabda725cb8c0a4ec94f21f (patch)
treee2474571fc19a9826f4556e85411a5a38b27ca41 /databases/qt4-odbc-plugin
parent0c0668d340ea6e82704a5585b6095e7d01a19ee8 (diff)
downloadports-ee279d859feb6202deabda725cb8c0a4ec94f21f.tar.gz
ports-ee279d859feb6202deabda725cb8c0a4ec94f21f.zip
During regression testing the WIP Qt 4.3.0 ports, I found that the sql
driver plugins were all broken - even in the current ports! :( I am quite astonished nobody complained about this yet. Is there nobody developing applications with database backends using Qt4 on FreeBSD? The ports let you use the QtSql library and the database plugins without any X11 dependencies! Using Qt for database frontends has never been so attractive! Anyway, this should fix the plugins.
Notes
Notes: svn path=/head/; revision=195506
Diffstat (limited to 'databases/qt4-odbc-plugin')
-rw-r--r--databases/qt4-odbc-plugin/Makefile5
-rw-r--r--databases/qt4-odbc-plugin/files/Makefile.bsd12
2 files changed, 13 insertions, 4 deletions
diff --git a/databases/qt4-odbc-plugin/Makefile b/databases/qt4-odbc-plugin/Makefile
index 64e6e73c1bef..a832483b6d15 100644
--- a/databases/qt4-odbc-plugin/Makefile
+++ b/databases/qt4-odbc-plugin/Makefile
@@ -8,6 +8,7 @@
PORTNAME= qt4-${DB}-plugin
PORTVERSION= 4.2.3
+PORTREVISION= 1
CATEGORIES= databases
MASTER_SITES= ${MASTER_SITE_QT}
DISTNAME= qt-x11-opensource-src-${PORTVERSION}
@@ -23,10 +24,12 @@ LIB_DEPENDS+= odbc:${PORTSDIR}/databases/unixODBC \
#USE_BZIP2= yes
DRIVER= src/sql/drivers/${DB}
+PLUGIN= src/plugins/sqldrivers/${DB}
EXTRACT_AFTER_ARGS?=| ${TAR} -xf - \
- ${DISTNAME}/${DRIVER}
+ ${DISTNAME}/${DRIVER} ${DISTNAME}/${PLUGIN}
MAKEFILE= ${FILESDIR}/Makefile.bsd
MAKE_ENV+= DB="${DB}" DRIVER="${DRIVER}" \
+ PLUGIN="${PLUGIN}" \
PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
PLIST_SUB= DB=${DB}
diff --git a/databases/qt4-odbc-plugin/files/Makefile.bsd b/databases/qt4-odbc-plugin/files/Makefile.bsd
index 920b6a8d73e4..178007369e45 100644
--- a/databases/qt4-odbc-plugin/files/Makefile.bsd
+++ b/databases/qt4-odbc-plugin/files/Makefile.bsd
@@ -1,18 +1,24 @@
SHLIB_NAME= libqsql${DB}.so
-VPATH= ${DRIVER}
+VPATH= ${PLUGIN}:${DRIVER}
CXXFLAGS+= -I${DRIVER} \
-I${LOCALBASE}/include/Qt \
-I${LOCALBASE}/include \
- ${PTHREAD_CFLAGS} -DQT_THREAD_SUPPORT
+ ${PTHREAD_CFLAGS} -DQT_NO_CAST_TO_ASCII -DQT_NO_CAST_FROM_ASCII \
+ -DQT_PLUGIN -DQT_SQL_LIB -DQT_CORE_LIB -D_LARGEFILE64_SOURCE \
+ -D_LARGEFILE_SOURCE -DQT_SHARED
LDADD= -L${LOCALBASE}/lib ${PTHREAD_LIBS} -lQtSql -lodbc
-SRCS= qsql_${DB}.cpp
+MOC?= ${LOCALBASE}/bin/moc-qt4
+SRCS= main.cpp qsql_${DB}.cpp moc_qsql_${DB}.cpp
LIBDIR= ${PREFIX}/lib/plugins/sqldrivers
${LIBDIR}:
mkdir -p ${LIBDIR}
+moc_qsql_${DB}.cpp: qsql_${DB}.h
+ $(MOC) $(.ALLSRC) -o $(.TARGET)
+
beforeinstall: ${LIBDIR}
.include <bsd.lib.mk>