aboutsummaryrefslogtreecommitdiff
path: root/databases/qt5-sqldrivers-sqlite3
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2014-11-05 09:39:21 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2014-11-05 09:39:21 +0000
commita9662ed9499601956169af13ac47f255b10f83e1 (patch)
treede667d296e818eb8d5953ab35ea2c695f47825db /databases/qt5-sqldrivers-sqlite3
parentf7d704569d02ab6d3da84ce41f3b418688b9baf8 (diff)
downloadports-a9662ed9499601956169af13ac47f255b10f83e1.tar.gz
ports-a9662ed9499601956169af13ac47f255b10f83e1.zip
Update Qt5 ports to 5.3.2.
Proudly presented by the KDE on FreeBSD team, with several guest stars. This update took way longer than initially expected due to us previously accumulating assumptions and changes to Qt's build system that finally bit us back with the 5.3 release series, so we had to do a fair amount of cleanup. New ports: - comms/qt5-serialport: Qt functions to access serial ports, originally based on work by Fernando Apesteguia. [1] - devel/qt5-qdoc: Qt documentation generator, the Qt5 equivalent of devel/qt4-qdoc3. Originally worked on by Tobias Berner. It had already been half-split from devel/qt5-buildtools, we just needed to finish the work. Dead ports: - devel/qt5-qmldevtools: Merged into lang/qt5-qml. Minor changes: - devel/qt5: Add x11/qt5-x11extras and the new ports to the dependency list. - graphics/qt5-imageformats: The port now supports the JPEG2000, WEBP, Direct Draw Surface and ICNS formats. - multimedia/qt5-multimedia: The ALSA and PULSEAUDIO options are now mutually exclusive due to changes introduced in Qt 5.3.0 (the ALSA code is now a proper plugin that is only built if PulseAudio is not used). - x11/qt5-x11extras: Add USE_LDCONFIG since the port installs a shared library. The big changes: - bsd.qt.mk: Set QMAKESPEC instead of QMAKEPATH. [3] QMAKEPATH does much more than we want now that we call qmake from the top of ${WRKSRC}. qmake uses QMAKEPATH when evaluating the QMAKE_MKSPECS property, which is in turn used by qt_config.pri to load the .pri files in mkspecs/modules. In practice, this means that if people have an older Qt installation those files will be used and QT_CONFIG will have values such as "gui" even if one is building a port like textproc/qt5-xml, which passes -no-gui to the configure script. Consequently, unintended code paths may be enabled or the configuration step can just fail if the .pro files expect values that are not present in the system-wide, older .pri files. We avoid all those problems if we use QMAKESPEC, as qmake does not take its value into account when evaluating the QMAKE_MKSPECS property and will only parse the files in the mkspec's directory (mkspecs/freebsd-clang, for example, instead of all the files in mkspecs). - Stop explicitly passing ${LOCALBASE} to the compiler. [3] qmake's behavior has changed in Qt 5, and the paths set in QMAKE_INCDIR and QMAKE_LIBDIR in the mkspecs are passed before any others, such as the ones in the build directory themselves. In practice, this means that we end up with linker calls like this: c++ -o libfoo.so foo.o bar.o -L/usr/local/lib -L/wrkdir/build/lib -lQt5Gui -lQt5Core So if one already has Qt installed in the system, the older, already present version of the libraries in /usr/local/lib will be used instead of the newly-built ones in /wrkdir/build/lib. QTBUG-40825 discusses this behavior upstream, but there has been no agreement on a solution yet. For now, the solution adopted is to make the compiler and the linker aware of those paths but only try them last after all others, and this is achieved by setting the CPATH and LIBRARY_PATH environment variables when qmake is being used. In addition to setting them in CONFIGURE_ENV and MAKE_ENV, we also need to stop changing QMAKE_INCDIR and QMAKE_LIBDIR as well as filter those paths from the pkg-config calls qtbase's configure script makes. - Call qmake from the root of the ${WRKSRC}. In Qt 5.3, Qt's build infrastructure has undergone some changes that make our previous approach of calling qmake from the directories we want to build stop working. Things would break even more in Qt 5.4, in which qtbase's configure script does not accept the -process, -fully-process and -dont-process arguments anymore (it always behaves as if -process had been used). Bite the bullet and start calling qmake from ${WRKSRC}. The largest part of this change involves changing lines in Makefiles from WRKSRC_SUBDIR= foo/bar to BUILD_WRKSRC= ${WRKSRC}/foo/bar INSTALL_WRKSRC= ${WRKSRC}/foo/bar as well as adding patches to .pro files to avoid entering other subdirectories and removing post-configure targets that are not necessary anymore. Since qmake needs to be called from the top of ${WRKSRC} anyway, we can also simplify the configuration process for the qtbase ports a little. Looking at r10019 it is not clear why we started calling qmake in the pre-configure target in addition to the post-configure one (while also skipping it in do-configure), but we can now drop this call since letting configure behave as if -process had been passed means it will call qmake on its own and overwrite the files generated by the pre-configure call. We still need to call qmake in post-configure though, as the configure script does not pass -recursive when calling qmake and we need to be able to call make from any subdirectory when building. PR: 194762 [1] PR: 194566 # exp-run with base GCC and clang PR: 194088 [3]
Notes
Notes: svn path=/head/; revision=372179
Diffstat (limited to 'databases/qt5-sqldrivers-sqlite3')
-rw-r--r--databases/qt5-sqldrivers-sqlite3/Makefile1
1 files changed, 0 insertions, 1 deletions
diff --git a/databases/qt5-sqldrivers-sqlite3/Makefile b/databases/qt5-sqldrivers-sqlite3/Makefile
index 636906fbac50..3af4eb38e930 100644
--- a/databases/qt5-sqldrivers-sqlite3/Makefile
+++ b/databases/qt5-sqldrivers-sqlite3/Makefile
@@ -1,7 +1,6 @@
# $FreeBSD$
PORTNAME= sqlite3
-PORTREVISION= 1
DB= SQLite
DB_DESC= SQLite 3