aboutsummaryrefslogtreecommitdiff
path: root/databases/redis
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2010-01-17 13:57:21 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2010-01-17 13:57:21 +0000
commitbca3d31f58e4e23e690da24b4c6586063f4ea0cf (patch)
tree289c46d0fcd40453b0da1b5ee8ac9dc34d3c1358 /databases/redis
parent4aca24576436b469d9264be9882d5c5da5804ddf (diff)
downloadports-bca3d31f58e4e23e690da24b4c6586063f4ea0cf.tar.gz
ports-bca3d31f58e4e23e690da24b4c6586063f4ea0cf.zip
Update from 1.02 to 1.2.0.
Adopt patch for redis.conf. Previously and by default redis was compiled with debugging information, that didn't respect CFLAGS. So, now its possible to compile with debugging information by use WITH_DEBUG knob. Take maintainership. Approved by: maintainer (skv@)
Notes
Notes: svn path=/head/; revision=248012
Diffstat (limited to 'databases/redis')
-rw-r--r--databases/redis/Makefile15
-rw-r--r--databases/redis/distinfo6
-rw-r--r--databases/redis/files/patch-redis.conf24
3 files changed, 26 insertions, 19 deletions
diff --git a/databases/redis/Makefile b/databases/redis/Makefile
index 3d0f18a82900..849fc7075d2c 100644
--- a/databases/redis/Makefile
+++ b/databases/redis/Makefile
@@ -6,19 +6,18 @@
#
PORTNAME= redis
-PORTVERSION= 1.02
+PORTVERSION= 1.2.0
CATEGORIES= databases
MASTER_SITES= GOOGLE_CODE
-MAINTAINER= skv@FreeBSD.org
+MAINTAINER= osa@FreeBSD.org
COMMENT= A persistent key-value database with built-in net interface
LIB_DEPENDS= execinfo.1:${PORTSDIR}/devel/libexecinfo
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-
CFLAGS+= -I${LOCALBASE}/include
+USE_GMAKE= yes
USE_RC_SUBR= redis.sh
BIN_FILES= redis-server redis-benchmark redis-cli
@@ -45,6 +44,14 @@ SUB_LIST+= PORTNAME="${PORTNAME}" \
REDIS_DBDIR="${REDIS_DBDIR}" \
REDIS_RUNDIR="${REDIS_RUNDIR}"
+PATTERN= '10d;13s|$$$$(ARCH) ||'
+.if !defined(WITH_DEBUG)
+PATTERN:= ${PATTERN:S/'$/;14s|^|\#|'/}
+.endif
+
+post-patch:
+ ${REINPLACE_CMD} ${PATTERN} ${WRKSRC}/Makefile
+
post-build:
${SED} ${SUB_LIST:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
${WRKSRC}/redis.conf > ${WRKDIR}/redis.conf
diff --git a/databases/redis/distinfo b/databases/redis/distinfo
index 93fede6b6b18..b552cb5ddc81 100644
--- a/databases/redis/distinfo
+++ b/databases/redis/distinfo
@@ -1,3 +1,3 @@
-MD5 (redis-1.02.tar.gz) = 5396e2d8b67f451ab4702ce7655533ae
-SHA256 (redis-1.02.tar.gz) = aa1fe425568e19bcf89db9a48df68a42732134c29978e27c6e9c05008a73321e
-SIZE (redis-1.02.tar.gz) = 202973
+MD5 (redis-1.2.0.tar.gz) = e33cb95cfa5c4f7086eea57e1e490d28
+SHA256 (redis-1.2.0.tar.gz) = 88fdc5433de3a0c77895b6b5f86d69b7a8a8575d042af68ba1cb24c996faa9bf
+SIZE (redis-1.2.0.tar.gz) = 202685
diff --git a/databases/redis/files/patch-redis.conf b/databases/redis/files/patch-redis.conf
index f68bd795ad4a..4aab6fedaf65 100644
--- a/databases/redis/files/patch-redis.conf
+++ b/databases/redis/files/patch-redis.conf
@@ -1,5 +1,5 @@
---- redis.conf
-+++ redis.conf
+--- redis.conf.orig 2009-12-27 11:54:09.000000000 +0300
++++ redis.conf 2009-12-27 11:56:16.000000000 +0300
@@ -2,11 +2,11 @@
# By default Redis does not run as a daemon. Use 'yes' if you need it.
@@ -14,16 +14,7 @@
# Accept connections on the specified port, default is 6379
port 6379
-@@ -39,7 +39,7 @@
-
- # For default save/load DB in/from the working directory
- # Note that you must specify a directory not a file name.
--dir ./
-+dir %%REDIS_DBDIR%%/
-
- # Set server verbosity to 'debug'
- # it can be one of:
-@@ -51,7 +51,7 @@
+@@ -29,7 +29,7 @@
# Specify the log file name. Also 'stdout' can be used to force
# the demon to log on the standard output. Note that if you use standard
# output for logging but daemonize, logs will be sent to /dev/null
@@ -32,3 +23,12 @@
# Set the number of databases. The default database is DB 0, you can select
# a different one on a per-connection basis using SELECT <dbid> where
+@@ -64,7 +64,7 @@
+
+ # For default save/load DB in/from the working directory
+ # Note that you must specify a directory not a file name.
+-dir ./
++dir %%REDIS_DBDIR%%/
+
+ ################################# REPLICATION #################################
+