aboutsummaryrefslogtreecommitdiff
path: root/databases/riak
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2013-09-28 13:34:21 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2013-09-28 13:34:21 +0000
commitb1bd6a3da6693c687803af94b7f8270a916fd5b5 (patch)
treecd03387e9351810540c56922efba15b5d965314f /databases/riak
parent92b50712e9575b172c4a3656af5cfde944138c86 (diff)
downloadports-b1bd6a3da6693c687803af94b7f8270a916fd5b5.tar.gz
ports-b1bd6a3da6693c687803af94b7f8270a916fd5b5.zip
- Fix install due to PREFIX not being defined by including bsd.port.pre.mk
This was not caught because 'poudriere testport' (in 3.0.8) was setting PREFIX in the environment which removes the need to include bsd.port.pre.mk. bulk -t was showing this problem though because it does not set PREFIX in the environment. PR: ports/182453 Reported by: Kenji Rikitake <kenji.rikitake@acm.org> Approved by: maintainer (implicit via original submission) Pointyhat to: bdrewery
Notes
Notes: svn path=/head/; revision=328568
Diffstat (limited to 'databases/riak')
-rw-r--r--databases/riak/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/databases/riak/Makefile b/databases/riak/Makefile
index 4e477f7c2984..bb7f05349aa0 100644
--- a/databases/riak/Makefile
+++ b/databases/riak/Makefile
@@ -37,6 +37,8 @@ MAKE_JOBS_UNSAFE=yes
MAKE_ENV= PATH=${LOCALBASE}/lib/erlang15/bin:${PATH}
NO_STAGE= yes
+.include <bsd.port.pre.mk>
+
pre-install:
${RM} -f ${PLIST}
${CAT} ${PKGDIR}/pkg-plist >> ${PLIST}
@@ -96,4 +98,4 @@ post-install:
${CP} -p ${RIAK_CONFDIR}/key.pem.sample ${RIAK_CONFDIR}/key.pem; \
fi
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>