aboutsummaryrefslogtreecommitdiff
path: root/databases/rrdtool/files
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2007-05-23 14:15:19 +0000
committerPav Lucistnik <pav@FreeBSD.org>2007-05-23 14:15:19 +0000
commit2f78a0380bff0708b4c31cc84bd51d00d3916bdd (patch)
tree69ef07d0461d9865e775ea0c7354efcc83bd3cf4 /databases/rrdtool/files
parentc9a04380685a3c7eec86456f94e2f184bb8f2649 (diff)
downloadports-2f78a0380bff0708b4c31cc84bd51d00d3916bdd.tar.gz
ports-2f78a0380bff0708b4c31cc84bd51d00d3916bdd.zip
- Add option for Ruby bindings
- Fix build for people with Ruby installed, who don't want the bindings PR: ports/112513, also ports/112412, ports/112483, ports/112663, ports/112679, ports/112883 Submitted by: clive Approved by: portmgr (implicit), maintainer timeout (demon; 15 days)
Notes
Notes: svn path=/head/; revision=191617
Diffstat (limited to 'databases/rrdtool/files')
-rw-r--r--databases/rrdtool/files/patch-bindings-Makefile.in16
1 files changed, 12 insertions, 4 deletions
diff --git a/databases/rrdtool/files/patch-bindings-Makefile.in b/databases/rrdtool/files/patch-bindings-Makefile.in
index 06a4d13c68c5..cdbc0427e04d 100644
--- a/databases/rrdtool/files/patch-bindings-Makefile.in
+++ b/databases/rrdtool/files/patch-bindings-Makefile.in
@@ -1,13 +1,21 @@
---- bindings/Makefile.in.orig Thu May 3 12:28:34 2007
-+++ bindings/Makefile.in Thu May 3 12:29:17 2007
-@@ -539,8 +539,8 @@
+--- bindings/Makefile.in.orig Thu May 3 02:06:59 2007
++++ bindings/Makefile.in Tue May 8 13:20:37 2007
+@@ -539,14 +539,14 @@
all-local: @COMP_PERL@ @COMP_RUBY@ @COMP_PYTHON@
install-data-local:
- test -f perl-piped/Makefile && cd perl-piped && $(MAKE) install || true
- test -f perl-shared/Makefile && cd perl-shared && $(MAKE) install || true
+- test -f ruby/Makefile && cd ruby && $(MAKE) EPREFIX=$(exec_prefix) $(RUBY_MAKE_OPTIONS) install || true
+ test -f perl-piped/Makefile && cd perl-piped && $(MAKE) pure_install || true
+ test -f perl-shared/Makefile && cd perl-shared && $(MAKE) pure_install || true
- test -f ruby/Makefile && cd ruby && $(MAKE) EPREFIX=$(exec_prefix) $(RUBY_MAKE_OPTIONS) install || true
++ test -f ruby/Makefile && cd ruby && $(MAKE) EPREFIX=$(exec_prefix) install || true
test -d python/build && cd python && env LIBDIR=$(libdir) $(PYTHON) setup.py install --skip-build --prefix=$(DESTDIR)$(prefix) --exec-prefix=$(DESTDIR)$(exec_prefix) || true
+ # rules for buildung the ruby module
+ ruby:
+- cd ruby && $(RUBY) extconf.rb && $(MAKE) EPREFIX=$(exec_prefix) $(RUBY_MAKE_OPTIONS)
++ cd ruby && $(RUBY) extconf.rb && $(MAKE) EPREFIX=$(exec_prefix)
+
+ # rules for buildung the pyton module
+ python: