aboutsummaryrefslogtreecommitdiff
path: root/databases/ruby-bdb1/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2002-01-15 22:16:30 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2002-01-15 22:16:30 +0000
commitf5ee20dc56c81ad887714e72d9dd551e843c889f (patch)
treed32e49d6ac68a4dcf9121a40f02d9640c629075e /databases/ruby-bdb1/Makefile
parentf84dff8ad85ae55187cc94dd725a77df74336cf8 (diff)
downloadports-f5ee20dc56c81ad887714e72d9dd551e843c889f.tar.gz
ports-f5ee20dc56c81ad887714e72d9dd551e843c889f.zip
Add ruby-bdb1, a Ruby interface to Berkeley DB revision 1.8x with full
feature support (unlike the standard "dbm" library).
Notes
Notes: svn path=/head/; revision=53134
Diffstat (limited to 'databases/ruby-bdb1/Makefile')
-rw-r--r--databases/ruby-bdb1/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/databases/ruby-bdb1/Makefile b/databases/ruby-bdb1/Makefile
new file mode 100644
index 000000000000..0ac878e1ea1e
--- /dev/null
+++ b/databases/ruby-bdb1/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: Ruby-BDB1
+# Date created: 16 January 2002
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bdb1
+PORTVERSION= 0.1.4
+CATEGORIES= databases ruby
+MASTER_SITES= ftp://moulon.inra.fr/pub/ruby/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
+
+INSTALL_TARGET= site-install
+
+DOCS= Changes README.en bdb1.html bdb1.rd docs/*
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/${PORTNAME}/
+ ${CP} -R ${WRKSRC}/examples/* ${RUBY_EXAMPLESDIR}/${PORTNAME}/
+ ${MKDIR} ${RUBY_DOCDIR}/${PORTNAME}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/${PORTNAME}/
+.endfor
+.endif
+
+.include <bsd.port.mk>