aboutsummaryrefslogtreecommitdiff
path: root/databases/rubygem-postgres/Makefile
diff options
context:
space:
mode:
authorSatoshi Taoka <taoka@FreeBSD.org>1999-09-06 14:02:24 +0000
committerSatoshi Taoka <taoka@FreeBSD.org>1999-09-06 14:02:24 +0000
commit40e564d11ce42146e043fe6c6daad228eb37ca96 (patch)
tree2ca71d433f07e556f77af3d0b5b826ebec58a8e6 /databases/rubygem-postgres/Makefile
parent85f629e9ef95cc3554c97ab1fd066c3ca687b3fd (diff)
downloadports-40e564d11ce42146e043fe6c6daad228eb37ca96.tar.gz
ports-40e564d11ce42146e043fe6c6daad228eb37ca96.zip
A Ruby interface to PostgreSQL library.
PR: ports/12123 Submitted by: Yasuhiro Fukuma <yasuf@big.or.jp>
Notes
Notes: svn path=/head/; revision=21304
Diffstat (limited to 'databases/rubygem-postgres/Makefile')
-rw-r--r--databases/rubygem-postgres/Makefile47
1 files changed, 47 insertions, 0 deletions
diff --git a/databases/rubygem-postgres/Makefile b/databases/rubygem-postgres/Makefile
new file mode 100644
index 000000000000..bed85b0259ec
--- /dev/null
+++ b/databases/rubygem-postgres/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: ruby-postgres
+# Version required: 0.5.3
+# Date created: 19 April 1999
+# Whom: Yasuhiro Fukuma <yasuf@big.or.jp>
+#
+# $Id$
+#
+
+DISTNAME= postgres-0.5.3
+PKGNAME= ruby-postgres-0.5.3
+CATEGORIES= databases
+MASTER_SITES= ftp://ftp.netlab.co.jp/pub/lang/ruby/contrib/ \
+ ftp://ftp.TokyoNet.AD.JP/pub/misc/ruby/contrib/ \
+ ftp://ftp.iij.ad.jp/pub/lang/ruby/contrib/ \
+ ftp://blade.nagaokaut.ac.jp/pub/lang/ruby/contrib/ \
+ ftp://ftp.krnet.ne.jp/pub/ruby/contrib/ \
+ ftp://mirror.nucba.ac.jp/mirror/ruby/contrib/
+
+MAINTAINER= yasuf@big.or.jp
+
+BUILD_DEPENDS= ruby:${PORTSDIR}/lang/ruby
+RUN_DEPENDS= ruby:${PORTSDIR}/lang/ruby
+LIB_DEPENDS= pq.2:${PORTSDIR}/databases/postgresql
+
+WRKSRC= ${WRKDIR}/postgres
+CONFIGURE_ARGS+= --with-pgsql-include-dir="${PGDIR}/include" \
+ --with-pgsql-lib-dir="${PGDIR}/lib"
+PLIST_SUB+= RUBY_VER="${RUBY_VER}" RUBY_ARCH="${RUBY_ARCH}"
+
+RUBY= ${PREFIX}/bin/ruby
+RUBY_VER= 1.4
+RUBY_ARCH= ${ARCH}-freebsd${OSREL}
+
+PGDIR?= ${PREFIX}/pgsql
+
+do-configure:
+ @cd ${WRKSRC}; ${SETENV} ${CONFIGURE_ENV} ${RUBY} extconf.rb ${CONFIGURE_ARGS}
+
+post-install:
+ ${MKDIR} ${PREFIX}/share/examples/ruby/postgres
+ ${INSTALL_DATA} ${WRKSRC}/psql*.rb ${PREFIX}/share/examples/ruby/postgres
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/ruby/postgres
+ ${INSTALL_DATA} ${WRKSRC}/README* ${WRKSRC}/*.html ${PREFIX}/share/doc/ruby/postgres
+.endif
+
+.include <bsd.port.mk>