aboutsummaryrefslogtreecommitdiff
path: root/databases/slony1v2/Makefile
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2004-07-01 10:55:03 +0000
committerVolker Stolz <vs@FreeBSD.org>2004-07-01 10:55:03 +0000
commit488dbe6dda90d60a9f161d096b1ade0efb3dbdce (patch)
tree85dc47b3f5a53d5c834142a0b13d23c03b783e18 /databases/slony1v2/Makefile
parent4bc33484eda1d1ba31f012cee87ec8df3c9af56d (diff)
downloadports-488dbe6dda90d60a9f161d096b1ade0efb3dbdce.tar.gz
ports-488dbe6dda90d60a9f161d096b1ade0efb3dbdce.zip
Update to 1.0.0.r1:
- install html documentation for slonik - this version is not compatible with beta3, you need to uninstall it from database. PR: ports/68519 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=112657
Diffstat (limited to 'databases/slony1v2/Makefile')
-rw-r--r--databases/slony1v2/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/databases/slony1v2/Makefile b/databases/slony1v2/Makefile
index b2598a9d4d48..db420628c2ac 100644
--- a/databases/slony1v2/Makefile
+++ b/databases/slony1v2/Makefile
@@ -6,15 +6,16 @@
#
PORTNAME= slony1
-PORTVERSION= 1.0.0.b3
+PORTVERSION= 1.0.0.r1
CATEGORIES= databases
MASTER_SITES= http://developer.postgresql.org/~wieck/slony1/download/
-DISTNAME= slony1-1.0.0.beta3
+DISTNAME= slony1-1.0.0.rc1
MAINTAINER= hsn@netmag.cz
COMMENT= PostgreSQL master to multiple slaves replication system
-BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/databases/postgresql7:configure
+PGSQL_PORT= ${PORTSDIR}/databases/postgresql7
+BUILD_DEPENDS= ${NONEXISTENT}:${PGSQL_PORT}:configure
.if ! defined(NOPORTDOCS)
BUILD_DEPENDS+= ${LOCALBASE}/bin/pnmtops:${PORTSDIR}/graphics/netpbm \
${LOCALBASE}/bin/djpeg:${PORTSDIR}/graphics/jpeg \
@@ -22,12 +23,12 @@ BUILD_DEPENDS+= ${LOCALBASE}/bin/pnmtops:${PORTSDIR}/graphics/netpbm \
.else
EXTRA_PATCHES= ${FILESDIR}/extra-GNUmakefile.in
.endif
-RUN_DEPENDS= ${LOCALBASE}/bin/postmaster:${PORTSDIR}/databases/postgresql7
+RUN_DEPENDS= ${LOCALBASE}/bin/postmaster:${PGSQL_PORT}
GNU_CONFIGURE= yes
USE_GETTEXT= yes
USE_GMAKE= yes
-PGSQL_SRC= `cd ${PORTSDIR}/databases/postgresql7; make -V WRKSRC`
+PGSQL_SRC= `cd ${PGSQL_PORT}; make -V WRKSRC`
CONFIGURE_ARGS= --with-pgsourcetree=${PGSQL_SRC}
PLIST_FILES= bin/slon bin/slonik bin/slony_setup.pl \
@@ -40,7 +41,7 @@ PLIST_FILES= bin/slon bin/slonik bin/slony_setup.pl \
share/postgresql/slony1_funcs.v74.sql \
share/postgresql/xxid.v73.sql \
share/postgresql/xxid.v74.sql
-PORTDOCS= *.pdf howto/*.txt COPYRIGHT README
+PORTDOCS= *.pdf howto/*.txt COPYRIGHT README slonik_commands.html
pre-configure:
cd ${PGSQL_SRC}/src/interfaces/libpq && ${GMAKE} all
@@ -56,6 +57,7 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/doc/implementation/Slony-I-implementation.pdf ${DOCSDIR}
${MKDIR} ${DOCSDIR}/howto
${INSTALL_DATA} ${WRKSRC}/doc/howto/*.txt ${DOCSDIR}/howto
+ ${INSTALL_DATA} ${WRKSRC}/src/slonik/slonik_commands.html ${DOCSDIR}
.endif
${CAT} ${PKGMESSAGE}