aboutsummaryrefslogtreecommitdiff
path: root/databases/slony1v2/Makefile
diff options
context:
space:
mode:
authorPalle Girgensohn <girgen@FreeBSD.org>2006-12-08 10:59:53 +0000
committerPalle Girgensohn <girgen@FreeBSD.org>2006-12-08 10:59:53 +0000
commit924cdc8b1f197ae45978d87f838a86997e5e6cd5 (patch)
treedff3b72bfb96d7ed4db12fb2b21b639de422d811 /databases/slony1v2/Makefile
parent71381fc9b28134dfc11f71b39a984e5da3c34a03 (diff)
downloadports-924cdc8b1f197ae45978d87f838a86997e5e6cd5.tar.gz
ports-924cdc8b1f197ae45978d87f838a86997e5e6cd5.zip
More rubust regex to determine which version of postgresql that is
already installed. Reported by: Kostik Belousov
Notes
Notes: svn path=/head/; revision=179173
Diffstat (limited to 'databases/slony1v2/Makefile')
-rw-r--r--databases/slony1v2/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/databases/slony1v2/Makefile b/databases/slony1v2/Makefile
index 12aa6c55971f..ceede4ac2e61 100644
--- a/databases/slony1v2/Makefile
+++ b/databases/slony1v2/Makefile
@@ -59,7 +59,7 @@ DEFAULT_PGSQL_VER?=80
# Setting/finding PostgreSQL version we want.
.if exists(${LOCALBASE}/bin/postmaster)
PGSQL_VER!= ${LOCALBASE}/bin/postmaster -V | \
- ${SED} -En 's/postmaster.*PostgreSQL[^0-9]*([0-9]+)\.([0-9]+)\..*/\1\2/p'
+ ${SED} -En 's/.*PostgreSQL[^0-9]*([0-9]+)\.([0-9]+)\..*/\1\2/p'
.elif exists(${LOCALBASE}/bin/pg_config)
PGSQL_VER!= ${LOCALBASE}/bin/pg_config --version | \
${SED} -En 's/PostgreSQL[^0-9]*([0-9]*)\.([0-9]+)\..*/\1\2/p'