aboutsummaryrefslogtreecommitdiff
path: root/databases/sqlite2/files/patch-makefile
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2003-06-11 16:26:07 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2003-06-11 16:26:07 +0000
commit9c922cdda142d9a8a66ed8b59615d8b181de30f3 (patch)
tree4279e82aaf009235d9ce3641527a2049ff5fd4b7 /databases/sqlite2/files/patch-makefile
parentc50de3feaeac004fde71097edc6e69f30238be4c (diff)
downloadports-9c922cdda142d9a8a66ed8b59615d8b181de30f3.tar.gz
ports-9c922cdda142d9a8a66ed8b59615d8b181de30f3.zip
o Update to 2.8.3.
o The TCL wrapper is now optional and off by default. Use SQLITE_WITH_TCL83/SQLITE_WITH_TCL84 to enable it. TCL is still needed for building the docs, unless you specify NOPORTDOCS. o The TCL example is now installed in $LOCALBASE/share/examples/sqlite. This patch is quite hackish in that it replaces the libtool stuff from SQLite with the libtool port. It also uses plain 'install' instead of 'libtool install' to install shared libraries. This might not look nice, but it's the only way I got the desired effects to work (i. e. SQLite's libtool refused to install the TCL wrapper in $LOCALBASE/lib/sqlite - it insisted on only installing it into $LOCALBASE/lib. PR: ports/53182 Submitted by: Gerhard Haering <gh@ghaering.de> (maintainer)
Notes
Notes: svn path=/head/; revision=82792
Diffstat (limited to 'databases/sqlite2/files/patch-makefile')
-rw-r--r--databases/sqlite2/files/patch-makefile210
1 files changed, 191 insertions, 19 deletions
diff --git a/databases/sqlite2/files/patch-makefile b/databases/sqlite2/files/patch-makefile
index e6eb78ae096c..1097d4d24b13 100644
--- a/databases/sqlite2/files/patch-makefile
+++ b/databases/sqlite2/files/patch-makefile
@@ -1,34 +1,206 @@
-diff -r -C 3 ../sqlite.orig/Makefile.in ./Makefile.in
-*** ../sqlite.orig/Makefile.in Sat Aug 31 18:29:58 2002
---- ./Makefile.in Mon Sep 2 00:51:27 2002
+*** ../../tmp/sqlite/Makefile.in Sat May 17 04:26:29 2003
+--- Makefile.in Sun Jun 8 18:54:50 2003
***************
-*** 310,322 ****
- mkdir -p doc
- mv $(DOC) doc
+*** 33,39 ****
+ prefix = @prefix@
+ exec_prefix = @exec_prefix@
+ INSTALL = @INSTALL@
+! LIBTOOL = ./libtool
-! install: sqlite libsqlite.la sqlite.h
+ # Compiler options needed for programs that use the TCL library.
+ #
+--- 33,39 ----
+ prefix = @prefix@
+ exec_prefix = @exec_prefix@
+ INSTALL = @INSTALL@
+! LIBTOOL = @prefix@/bin/libtool
+
+ # Compiler options needed for programs that use the TCL library.
+ #
+***************
+*** 166,172 ****
+ | awk '{print $$5,$$6}' >last_change
+
+ libsqlite.la: $(LIBOBJ)
+! $(LIBTOOL) $(TCC) -o libsqlite.la $(LIBOBJ) -rpath $(exec_prefix)/lib
+
+ libtclsqlite.la: tclsqlite.lo libsqlite.la
+ $(LIBTOOL) $(TCC) -o libtclsqlite.la tclsqlite.lo \
+--- 166,172 ----
+ | awk '{print $$5,$$6}' >last_change
+
+ libsqlite.la: $(LIBOBJ)
+! $(LIBTOOL) $(TCC) -o libsqlite.la $(LIBOBJ) -rpath $(exec_prefix)/lib -version-info 2:0:0
+
+ libtclsqlite.la: tclsqlite.lo libsqlite.la
+ $(LIBTOOL) $(TCC) -o libtclsqlite.la tclsqlite.lo \
+***************
+*** 338,404 ****
+ ./testfixture $(TOP)/test/quick.test
+
+ index.html: $(TOP)/www/index.tcl last_change
+! tclsh $(TOP)/www/index.tcl `cat $(TOP)/VERSION` >index.html
+
+ sqlite.html: $(TOP)/www/sqlite.tcl
+! tclsh $(TOP)/www/sqlite.tcl >sqlite.html
+
+ c_interface.html: $(TOP)/www/c_interface.tcl
+! tclsh $(TOP)/www/c_interface.tcl >c_interface.html
+
+ changes.html: $(TOP)/www/changes.tcl
+! tclsh $(TOP)/www/changes.tcl >changes.html
+
+ lang.html: $(TOP)/www/lang.tcl
+! tclsh $(TOP)/www/lang.tcl >lang.html
+
+ vdbe.html: $(TOP)/www/vdbe.tcl
+! tclsh $(TOP)/www/vdbe.tcl >vdbe.html
+
+ arch.html: $(TOP)/www/arch.tcl
+! tclsh $(TOP)/www/arch.tcl >arch.html
+
+ arch.png: $(TOP)/www/arch.png
+ cp $(TOP)/www/arch.png .
+
+ opcode.html: $(TOP)/www/opcode.tcl $(TOP)/src/vdbe.c
+! tclsh $(TOP)/www/opcode.tcl $(TOP)/src/vdbe.c >opcode.html
+
+ mingw.html: $(TOP)/www/mingw.tcl
+! tclsh $(TOP)/www/mingw.tcl >mingw.html
+
+ tclsqlite.html: $(TOP)/www/tclsqlite.tcl
+! tclsh $(TOP)/www/tclsqlite.tcl >tclsqlite.html
+
+ speed.html: $(TOP)/www/speed.tcl
+! tclsh $(TOP)/www/speed.tcl >speed.html
+
+ faq.html: $(TOP)/www/faq.tcl
+! tclsh $(TOP)/www/faq.tcl >faq.html
+
+ formatchng.html: $(TOP)/www/formatchng.tcl
+! tclsh $(TOP)/www/formatchng.tcl >formatchng.html
+
+ conflict.html: $(TOP)/www/conflict.tcl
+! tclsh $(TOP)/www/conflict.tcl >conflict.html
+
+ download.html: $(TOP)/www/download.tcl
+! tclsh $(TOP)/www/download.tcl >download.html
+
+ omitted.html: $(TOP)/www/omitted.tcl
+! tclsh $(TOP)/www/omitted.tcl >omitted.html
+
+ datatypes.html: $(TOP)/www/datatypes.tcl
+! tclsh $(TOP)/www/datatypes.tcl >datatypes.html
+
+ quickstart.html: $(TOP)/www/quickstart.tcl
+! tclsh $(TOP)/www/quickstart.tcl >quickstart.html
+
+ fileformat.html: $(TOP)/www/fileformat.tcl
+! tclsh $(TOP)/www/fileformat.tcl >fileformat.html
+
+ nulls.html: $(TOP)/www/nulls.tcl
+! tclsh $(TOP)/www/nulls.tcl >nulls.html
+
+
+ # Files to be published on the website.
+--- 338,404 ----
+ ./testfixture $(TOP)/test/quick.test
+
+ index.html: $(TOP)/www/index.tcl last_change
+! $(TCLSH) $(TOP)/www/index.tcl `cat $(TOP)/VERSION` >index.html
+
+ sqlite.html: $(TOP)/www/sqlite.tcl
+! $(TCLSH) $(TOP)/www/sqlite.tcl >sqlite.html
+
+ c_interface.html: $(TOP)/www/c_interface.tcl
+! $(TCLSH) $(TOP)/www/c_interface.tcl >c_interface.html
+
+ changes.html: $(TOP)/www/changes.tcl
+! $(TCLSH) $(TOP)/www/changes.tcl >changes.html
+
+ lang.html: $(TOP)/www/lang.tcl
+! $(TCLSH) $(TOP)/www/lang.tcl >lang.html
+
+ vdbe.html: $(TOP)/www/vdbe.tcl
+! $(TCLSH) $(TOP)/www/vdbe.tcl >vdbe.html
+
+ arch.html: $(TOP)/www/arch.tcl
+! $(TCLSH) $(TOP)/www/arch.tcl >arch.html
+
+ arch.png: $(TOP)/www/arch.png
+ cp $(TOP)/www/arch.png .
+
+ opcode.html: $(TOP)/www/opcode.tcl $(TOP)/src/vdbe.c
+! $(TCLSH) $(TOP)/www/opcode.tcl $(TOP)/src/vdbe.c >opcode.html
+
+ mingw.html: $(TOP)/www/mingw.tcl
+! $(TCLSH) $(TOP)/www/mingw.tcl >mingw.html
+
+ tclsqlite.html: $(TOP)/www/tclsqlite.tcl
+! $(TCLSH) $(TOP)/www/tclsqlite.tcl >tclsqlite.html
+
+ speed.html: $(TOP)/www/speed.tcl
+! $(TCLSH) $(TOP)/www/speed.tcl >speed.html
+
+ faq.html: $(TOP)/www/faq.tcl
+! $(TCLSH) $(TOP)/www/faq.tcl >faq.html
+
+ formatchng.html: $(TOP)/www/formatchng.tcl
+! $(TCLSH) $(TOP)/www/formatchng.tcl >formatchng.html
+
+ conflict.html: $(TOP)/www/conflict.tcl
+! $(TCLSH) $(TOP)/www/conflict.tcl >conflict.html
+
+ download.html: $(TOP)/www/download.tcl
+! $(TCLSH) $(TOP)/www/download.tcl >download.html
+
+ omitted.html: $(TOP)/www/omitted.tcl
+! $(TCLSH) $(TOP)/www/omitted.tcl >omitted.html
+
+ datatypes.html: $(TOP)/www/datatypes.tcl
+! $(TCLSH) $(TOP)/www/datatypes.tcl >datatypes.html
+
+ quickstart.html: $(TOP)/www/quickstart.tcl
+! $(TCLSH) $(TOP)/www/quickstart.tcl >quickstart.html
+
+ fileformat.html: $(TOP)/www/fileformat.tcl
+! $(TCLSH) $(TOP)/www/fileformat.tcl >fileformat.html
+
+ nulls.html: $(TOP)/www/nulls.tcl
+! $(TCLSH) $(TOP)/www/nulls.tcl >nulls.html
+
+
+ # Files to be published on the website.
+***************
+*** 432,444 ****
+
+ install: sqlite libsqlite.la sqlite.h
$(INSTALL) -d $(exec_prefix)/lib
- $(LIBTOOL) $(INSTALL) libsqlite.la $(exec_prefix)/lib
+! $(LIBTOOL) $(INSTALL) libsqlite.la $(exec_prefix)/lib
$(INSTALL) -d $(exec_prefix)/bin
- $(LIBTOOL) $(INSTALL) sqlite $(exec_prefix)/bin
+! $(LIBTOOL) $(INSTALL) sqlite $(exec_prefix)/bin
$(INSTALL) -d $(prefix)/include
$(INSTALL) -m 0644 sqlite.h $(prefix)/include
+! $(INSTALL) -d $(exec_prefix)/lib/pkgconfig; \
+! $(INSTALL) -m 0644 sqlite.pc $(exec_prefix)/lib/pkgconfig; \
clean:
- rm -f *.lo *.la *.o sqlite libsqlite.la sqlite.h
---- 310,324 ----
- mkdir -p doc
- mv $(DOC) doc
+ rm -f *.lo *.la *.o sqlite libsqlite.la sqlite.h opcodes.*
+--- 432,448 ----
-! install: sqlite libsqlite.la sqlite.h libtclsqlite.la
+ install: sqlite libsqlite.la sqlite.h
$(INSTALL) -d $(exec_prefix)/lib
- $(LIBTOOL) $(INSTALL) libsqlite.la $(exec_prefix)/lib
+! $(INSTALL) .libs/libsqlite.a $(prefix)/lib
+! $(INSTALL) .libs/libsqlite.so $(prefix)/lib
+! $(INSTALL) .libs/libsqlite.so.2 $(prefix)/lib
$(INSTALL) -d $(exec_prefix)/bin
- $(LIBTOOL) $(INSTALL) sqlite $(exec_prefix)/bin
+! $(INSTALL) .libs/sqlite $(exec_prefix)/bin
$(INSTALL) -d $(prefix)/include
$(INSTALL) -m 0644 sqlite.h $(prefix)/include
-+ mkdir -p $(prefix)/lib/sqlite
-+ $(LIBTOOL) $(INSTALL) libtclsqlite.la $(prefix)/lib/sqlite
+!
+! install-tcl: libtclsqlite.la
+! $(INSTALL) -d $(prefix)/lib/sqlite
+! $(INSTALL) .libs/libtclsqlite.so $(prefix)/lib/sqlite
clean:
- rm -f *.lo *.la *.o sqlite libsqlite.la sqlite.h
+ rm -f *.lo *.la *.o sqlite libsqlite.la sqlite.h opcodes.*