aboutsummaryrefslogtreecommitdiff
path: root/databases/sqlite2
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2003-06-11 16:26:07 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2003-06-11 16:26:07 +0000
commit9c922cdda142d9a8a66ed8b59615d8b181de30f3 (patch)
tree4279e82aaf009235d9ce3641527a2049ff5fd4b7 /databases/sqlite2
parentc50de3feaeac004fde71097edc6e69f30238be4c (diff)
downloadports-9c922cdda142d9a8a66ed8b59615d8b181de30f3.tar.gz
ports-9c922cdda142d9a8a66ed8b59615d8b181de30f3.zip
o Update to 2.8.3.
o The TCL wrapper is now optional and off by default. Use SQLITE_WITH_TCL83/SQLITE_WITH_TCL84 to enable it. TCL is still needed for building the docs, unless you specify NOPORTDOCS. o The TCL example is now installed in $LOCALBASE/share/examples/sqlite. This patch is quite hackish in that it replaces the libtool stuff from SQLite with the libtool port. It also uses plain 'install' instead of 'libtool install' to install shared libraries. This might not look nice, but it's the only way I got the desired effects to work (i. e. SQLite's libtool refused to install the TCL wrapper in $LOCALBASE/lib/sqlite - it insisted on only installing it into $LOCALBASE/lib. PR: ports/53182 Submitted by: Gerhard Haering <gh@ghaering.de> (maintainer)
Notes
Notes: svn path=/head/; revision=82792
Diffstat (limited to 'databases/sqlite2')
-rw-r--r--databases/sqlite2/Makefile73
-rw-r--r--databases/sqlite2/distinfo2
-rw-r--r--databases/sqlite2/files/patch-ltmain.sh11
-rw-r--r--databases/sqlite2/files/patch-makefile210
-rw-r--r--databases/sqlite2/files/pkgIndex.tcl2
-rw-r--r--databases/sqlite2/pkg-plist21
6 files changed, 264 insertions, 55 deletions
diff --git a/databases/sqlite2/Makefile b/databases/sqlite2/Makefile
index ba7cdd3733f5..0b6b90021081 100644
--- a/databases/sqlite2/Makefile
+++ b/databases/sqlite2/Makefile
@@ -6,55 +6,100 @@
# $FreeBSD$
#
+# By default, this port depends on TCL for building docs. If you want to build
+# without TCL (and thus get no docs), define NOPORTDOCS.
+# If you want to build the TCL wrapper, you have to choose between
+# SQLITE_WITH_TCL83 and SQLITE_WITH_TCL84.
+
PORTNAME= sqlite
-PORTVERSION= 2.8.0
+PORTVERSION= 2.8.3
PORTREVISION= 0
CATEGORIES= databases
MASTER_SITES= http://www.hwaci.com/sw/sqlite/
DISTNAME= ${PORTNAME}-${PORTVERSION}
-MAINTAINER= gerhard.haering@gmx.de
+MAINTAINER= gh@ghaering.de
COMMENT= An SQL database engine in a C library, including a Tcl wrapper
-LIB_DEPENDS= tcl${TCL_VER:S/.//}:${PORTSDIR}/lang/tcl${TCL_VER:S/.//}
+# Defaults, for building the docs:
+TCL_V= 8.3
+TCL_SHORT_V= 83
+
+.if defined(SQLITE_WITH_TCL83)
+CATEGORIES+= tcl83
+TCL_V= 8.3
+TCL_SHORT_V= 83
+WITH_TCL= YES
+.endif
+
+.if defined(SQLITE_WITH_TCL84)
+TCL_V= 8.4
+TCL_SHORT_V= 84
+WITH_TCL= YES
+.endif
+
+.if defined(WITH_TCL)
+LIB_DEPENDS= tcl${TCL_SHORT_V}:${PORTSDIR}/lang/tcl${TCL_SHORT_V}
+PLIST_SUB+= WITH_TCL=""
+.else
+PLIST_SUB+= WITH_TCL="@comment "
+.endif
+
+.if !defined(NOPORTDOCS)
+BUILD_DEPENDS= tclsh${TCL_V}:${PORTSDIR}/lang/tcl${TCL_SHORT_V}
+MAKE_ARGS+= TCLSH=tclsh${TCL_V}
+MAKE_ENV+= TCL_VER=${TCL_V}
+.endif
USE_GMAKE= YES
+USE_LIBTOOL= YES
GNU_CONFIGURE= YES
USE_REINPLACE= YES
CONFIGURE_ARGS= --prefix=${PREFIX} --with-hints=freebsd.hints
-ALL_TARGET= all libtclsqlite.la
+ALL_TARGET= all
+.if defined(WITH_TCL)
+ALL_TARGET+= libtclsqlite.la
+.endif
+
INSTALLS_SHLIB= YES
WRKSRC= ${WRKDIR}/${PORTNAME}
-MAKE_ARGS+= TCLSH=tclsh${TCL_VER}
-MAKE_ENV+= TCL_VER=${TCL_VER}
-TCL_VER?= 8.3
DOCFILES= arch.html arch.png c_interface.html changes.html \
- crosscompile.html download.html faq.html index.html \
- lang.html lemon.html mingw.html opcode.html report1.txt \
- speed.html sqlite.html tclsqlite.html vdbe.html
+ conflict.html datatypes.html download.html faq.html \
+ fileformat.html formatchng.html index.html lang.html \
+ lemon.html mingw.html nulls.html omitted.html \
+ opcode.html quickstart.html report1.txt speed.html \
+ sqlite.html tclsqlite.html vdbe.html
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}
+EXAMPLESDIR= ${PREFIX}/share/examples/${PORTNAME}
post-patch:
${REINPLACE_CMD} -e "s/tclsh \$$(TOP)/\$$(TCLSH) \$$(TOP)/g" ${WRKSRC}/Makefile.in
- ${ECHO} "config_TARGET_TCL_INC=\"-I${PREFIX}/include/tcl${TCL_VER}\"" >${WRKSRC}/freebsd.hints
- ${ECHO} "config_TARGET_TCL_LIBS=\"-L${PREFIX}/lib -ltcl${TCL_VER:S/.//}\"" >>${WRKSRC}/freebsd.hints
+ ${ECHO} "config_TARGET_TCL_INC=\"-I${PREFIX}/include/tcl${TCL_V}\"" >${WRKSRC}/freebsd.hints
+ ${ECHO} "config_TARGET_TCL_LIBS=\"-L${PREFIX}/lib -ltcl${TCL_SHORT_V}\"" >>${WRKSRC}/freebsd.hints
#${ECHO} "config_TARGET_CFLAGS=\"-DTHREADSAFE=1 -pthread\"" >>${WRKSRC}/freebsd.hints
post-build:
# Build the docs
- cd ${WRKSRC} && ${MAKE} ${MAKE_ARGS} doc
+.if !defined(NOPORTDOCS)
+ cd ${WRKSRC} && ${GMAKE} ${MAKE_ARGS} doc
+.endif
post-install:
+.if defined(WITH_TCL)
+ cd ${WRKSRC} && ${GMAKE} install-tcl
${INSTALL_DATA} ${FILESDIR}/pkgIndex.tcl ${PREFIX}/lib/sqlite/
+.endif
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${FILESDIR}/example.tcl ${DOCSDIR}
.for file in ${DOCFILES}
@${INSTALL_DATA} ${WRKSRC}/doc/${file} ${DOCSDIR}
.endfor
+ @${MKDIR} ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${FILESDIR}/example.tcl ${EXAMPLESDIR}
+
.endif
.include <bsd.port.mk>
diff --git a/databases/sqlite2/distinfo b/databases/sqlite2/distinfo
index fc1ed78e07a6..2041e11bdad7 100644
--- a/databases/sqlite2/distinfo
+++ b/databases/sqlite2/distinfo
@@ -1 +1 @@
-MD5 (sqlite-2.8.0.tar.gz) = 56d5c7d1efde7f239b29ee151712c0b2
+MD5 (sqlite-2.8.3.tar.gz) = b038f5812157359c8e87487a017fa3d8
diff --git a/databases/sqlite2/files/patch-ltmain.sh b/databases/sqlite2/files/patch-ltmain.sh
deleted file mode 100644
index a36adacb710c..000000000000
--- a/databases/sqlite2/files/patch-ltmain.sh
+++ /dev/null
@@ -1,11 +0,0 @@
---- ltmain.sh.orig Fri Sep 28 10:34:45 2001
-+++ ltmain.sh Fri Sep 20 15:00:05 2002
-@@ -852,7 +852,7 @@
- perm_rpath=
- temp_rpath=
- thread_safe=no
-- vinfo=
-+ vinfo=2:0:0
-
- # We need to know -static, to get the right output filenames.
- for arg
diff --git a/databases/sqlite2/files/patch-makefile b/databases/sqlite2/files/patch-makefile
index e6eb78ae096c..1097d4d24b13 100644
--- a/databases/sqlite2/files/patch-makefile
+++ b/databases/sqlite2/files/patch-makefile
@@ -1,34 +1,206 @@
-diff -r -C 3 ../sqlite.orig/Makefile.in ./Makefile.in
-*** ../sqlite.orig/Makefile.in Sat Aug 31 18:29:58 2002
---- ./Makefile.in Mon Sep 2 00:51:27 2002
+*** ../../tmp/sqlite/Makefile.in Sat May 17 04:26:29 2003
+--- Makefile.in Sun Jun 8 18:54:50 2003
***************
-*** 310,322 ****
- mkdir -p doc
- mv $(DOC) doc
+*** 33,39 ****
+ prefix = @prefix@
+ exec_prefix = @exec_prefix@
+ INSTALL = @INSTALL@
+! LIBTOOL = ./libtool
-! install: sqlite libsqlite.la sqlite.h
+ # Compiler options needed for programs that use the TCL library.
+ #
+--- 33,39 ----
+ prefix = @prefix@
+ exec_prefix = @exec_prefix@
+ INSTALL = @INSTALL@
+! LIBTOOL = @prefix@/bin/libtool
+
+ # Compiler options needed for programs that use the TCL library.
+ #
+***************
+*** 166,172 ****
+ | awk '{print $$5,$$6}' >last_change
+
+ libsqlite.la: $(LIBOBJ)
+! $(LIBTOOL) $(TCC) -o libsqlite.la $(LIBOBJ) -rpath $(exec_prefix)/lib
+
+ libtclsqlite.la: tclsqlite.lo libsqlite.la
+ $(LIBTOOL) $(TCC) -o libtclsqlite.la tclsqlite.lo \
+--- 166,172 ----
+ | awk '{print $$5,$$6}' >last_change
+
+ libsqlite.la: $(LIBOBJ)
+! $(LIBTOOL) $(TCC) -o libsqlite.la $(LIBOBJ) -rpath $(exec_prefix)/lib -version-info 2:0:0
+
+ libtclsqlite.la: tclsqlite.lo libsqlite.la
+ $(LIBTOOL) $(TCC) -o libtclsqlite.la tclsqlite.lo \
+***************
+*** 338,404 ****
+ ./testfixture $(TOP)/test/quick.test
+
+ index.html: $(TOP)/www/index.tcl last_change
+! tclsh $(TOP)/www/index.tcl `cat $(TOP)/VERSION` >index.html
+
+ sqlite.html: $(TOP)/www/sqlite.tcl
+! tclsh $(TOP)/www/sqlite.tcl >sqlite.html
+
+ c_interface.html: $(TOP)/www/c_interface.tcl
+! tclsh $(TOP)/www/c_interface.tcl >c_interface.html
+
+ changes.html: $(TOP)/www/changes.tcl
+! tclsh $(TOP)/www/changes.tcl >changes.html
+
+ lang.html: $(TOP)/www/lang.tcl
+! tclsh $(TOP)/www/lang.tcl >lang.html
+
+ vdbe.html: $(TOP)/www/vdbe.tcl
+! tclsh $(TOP)/www/vdbe.tcl >vdbe.html
+
+ arch.html: $(TOP)/www/arch.tcl
+! tclsh $(TOP)/www/arch.tcl >arch.html
+
+ arch.png: $(TOP)/www/arch.png
+ cp $(TOP)/www/arch.png .
+
+ opcode.html: $(TOP)/www/opcode.tcl $(TOP)/src/vdbe.c
+! tclsh $(TOP)/www/opcode.tcl $(TOP)/src/vdbe.c >opcode.html
+
+ mingw.html: $(TOP)/www/mingw.tcl
+! tclsh $(TOP)/www/mingw.tcl >mingw.html
+
+ tclsqlite.html: $(TOP)/www/tclsqlite.tcl
+! tclsh $(TOP)/www/tclsqlite.tcl >tclsqlite.html
+
+ speed.html: $(TOP)/www/speed.tcl
+! tclsh $(TOP)/www/speed.tcl >speed.html
+
+ faq.html: $(TOP)/www/faq.tcl
+! tclsh $(TOP)/www/faq.tcl >faq.html
+
+ formatchng.html: $(TOP)/www/formatchng.tcl
+! tclsh $(TOP)/www/formatchng.tcl >formatchng.html
+
+ conflict.html: $(TOP)/www/conflict.tcl
+! tclsh $(TOP)/www/conflict.tcl >conflict.html
+
+ download.html: $(TOP)/www/download.tcl
+! tclsh $(TOP)/www/download.tcl >download.html
+
+ omitted.html: $(TOP)/www/omitted.tcl
+! tclsh $(TOP)/www/omitted.tcl >omitted.html
+
+ datatypes.html: $(TOP)/www/datatypes.tcl
+! tclsh $(TOP)/www/datatypes.tcl >datatypes.html
+
+ quickstart.html: $(TOP)/www/quickstart.tcl
+! tclsh $(TOP)/www/quickstart.tcl >quickstart.html
+
+ fileformat.html: $(TOP)/www/fileformat.tcl
+! tclsh $(TOP)/www/fileformat.tcl >fileformat.html
+
+ nulls.html: $(TOP)/www/nulls.tcl
+! tclsh $(TOP)/www/nulls.tcl >nulls.html
+
+
+ # Files to be published on the website.
+--- 338,404 ----
+ ./testfixture $(TOP)/test/quick.test
+
+ index.html: $(TOP)/www/index.tcl last_change
+! $(TCLSH) $(TOP)/www/index.tcl `cat $(TOP)/VERSION` >index.html
+
+ sqlite.html: $(TOP)/www/sqlite.tcl
+! $(TCLSH) $(TOP)/www/sqlite.tcl >sqlite.html
+
+ c_interface.html: $(TOP)/www/c_interface.tcl
+! $(TCLSH) $(TOP)/www/c_interface.tcl >c_interface.html
+
+ changes.html: $(TOP)/www/changes.tcl
+! $(TCLSH) $(TOP)/www/changes.tcl >changes.html
+
+ lang.html: $(TOP)/www/lang.tcl
+! $(TCLSH) $(TOP)/www/lang.tcl >lang.html
+
+ vdbe.html: $(TOP)/www/vdbe.tcl
+! $(TCLSH) $(TOP)/www/vdbe.tcl >vdbe.html
+
+ arch.html: $(TOP)/www/arch.tcl
+! $(TCLSH) $(TOP)/www/arch.tcl >arch.html
+
+ arch.png: $(TOP)/www/arch.png
+ cp $(TOP)/www/arch.png .
+
+ opcode.html: $(TOP)/www/opcode.tcl $(TOP)/src/vdbe.c
+! $(TCLSH) $(TOP)/www/opcode.tcl $(TOP)/src/vdbe.c >opcode.html
+
+ mingw.html: $(TOP)/www/mingw.tcl
+! $(TCLSH) $(TOP)/www/mingw.tcl >mingw.html
+
+ tclsqlite.html: $(TOP)/www/tclsqlite.tcl
+! $(TCLSH) $(TOP)/www/tclsqlite.tcl >tclsqlite.html
+
+ speed.html: $(TOP)/www/speed.tcl
+! $(TCLSH) $(TOP)/www/speed.tcl >speed.html
+
+ faq.html: $(TOP)/www/faq.tcl
+! $(TCLSH) $(TOP)/www/faq.tcl >faq.html
+
+ formatchng.html: $(TOP)/www/formatchng.tcl
+! $(TCLSH) $(TOP)/www/formatchng.tcl >formatchng.html
+
+ conflict.html: $(TOP)/www/conflict.tcl
+! $(TCLSH) $(TOP)/www/conflict.tcl >conflict.html
+
+ download.html: $(TOP)/www/download.tcl
+! $(TCLSH) $(TOP)/www/download.tcl >download.html
+
+ omitted.html: $(TOP)/www/omitted.tcl
+! $(TCLSH) $(TOP)/www/omitted.tcl >omitted.html
+
+ datatypes.html: $(TOP)/www/datatypes.tcl
+! $(TCLSH) $(TOP)/www/datatypes.tcl >datatypes.html
+
+ quickstart.html: $(TOP)/www/quickstart.tcl
+! $(TCLSH) $(TOP)/www/quickstart.tcl >quickstart.html
+
+ fileformat.html: $(TOP)/www/fileformat.tcl
+! $(TCLSH) $(TOP)/www/fileformat.tcl >fileformat.html
+
+ nulls.html: $(TOP)/www/nulls.tcl
+! $(TCLSH) $(TOP)/www/nulls.tcl >nulls.html
+
+
+ # Files to be published on the website.
+***************
+*** 432,444 ****
+
+ install: sqlite libsqlite.la sqlite.h
$(INSTALL) -d $(exec_prefix)/lib
- $(LIBTOOL) $(INSTALL) libsqlite.la $(exec_prefix)/lib
+! $(LIBTOOL) $(INSTALL) libsqlite.la $(exec_prefix)/lib
$(INSTALL) -d $(exec_prefix)/bin
- $(LIBTOOL) $(INSTALL) sqlite $(exec_prefix)/bin
+! $(LIBTOOL) $(INSTALL) sqlite $(exec_prefix)/bin
$(INSTALL) -d $(prefix)/include
$(INSTALL) -m 0644 sqlite.h $(prefix)/include
+! $(INSTALL) -d $(exec_prefix)/lib/pkgconfig; \
+! $(INSTALL) -m 0644 sqlite.pc $(exec_prefix)/lib/pkgconfig; \
clean:
- rm -f *.lo *.la *.o sqlite libsqlite.la sqlite.h
---- 310,324 ----
- mkdir -p doc
- mv $(DOC) doc
+ rm -f *.lo *.la *.o sqlite libsqlite.la sqlite.h opcodes.*
+--- 432,448 ----
-! install: sqlite libsqlite.la sqlite.h libtclsqlite.la
+ install: sqlite libsqlite.la sqlite.h
$(INSTALL) -d $(exec_prefix)/lib
- $(LIBTOOL) $(INSTALL) libsqlite.la $(exec_prefix)/lib
+! $(INSTALL) .libs/libsqlite.a $(prefix)/lib
+! $(INSTALL) .libs/libsqlite.so $(prefix)/lib
+! $(INSTALL) .libs/libsqlite.so.2 $(prefix)/lib
$(INSTALL) -d $(exec_prefix)/bin
- $(LIBTOOL) $(INSTALL) sqlite $(exec_prefix)/bin
+! $(INSTALL) .libs/sqlite $(exec_prefix)/bin
$(INSTALL) -d $(prefix)/include
$(INSTALL) -m 0644 sqlite.h $(prefix)/include
-+ mkdir -p $(prefix)/lib/sqlite
-+ $(LIBTOOL) $(INSTALL) libtclsqlite.la $(prefix)/lib/sqlite
+!
+! install-tcl: libtclsqlite.la
+! $(INSTALL) -d $(prefix)/lib/sqlite
+! $(INSTALL) .libs/libtclsqlite.so $(prefix)/lib/sqlite
clean:
- rm -f *.lo *.la *.o sqlite libsqlite.la sqlite.h
+ rm -f *.lo *.la *.o sqlite libsqlite.la sqlite.h opcodes.*
diff --git a/databases/sqlite2/files/pkgIndex.tcl b/databases/sqlite2/files/pkgIndex.tcl
index dba694a3bc8b..d96e27a1bc55 100644
--- a/databases/sqlite2/files/pkgIndex.tcl
+++ b/databases/sqlite2/files/pkgIndex.tcl
@@ -1 +1 @@
-package ifneeded sqlite 0.0 [list load [file join $dir libtclsqlite.so.0] sqlite]
+package ifneeded sqlite 0.0 [list load [file join $dir libtclsqlite.so] sqlite]
diff --git a/databases/sqlite2/pkg-plist b/databases/sqlite2/pkg-plist
index 1eb257c646eb..a94288e3aa17 100644
--- a/databases/sqlite2/pkg-plist
+++ b/databases/sqlite2/pkg-plist
@@ -1,31 +1,34 @@
bin/sqlite
include/sqlite.h
lib/libsqlite.a
-lib/libsqlite.la
lib/libsqlite.so
lib/libsqlite.so.2
-lib/sqlite/libtclsqlite.a
-lib/sqlite/libtclsqlite.la
-lib/sqlite/libtclsqlite.so
-lib/sqlite/libtclsqlite.so.2
-lib/sqlite/pkgIndex.tcl
-@dirrm lib/sqlite
+%%WITH_TCL%%lib/sqlite/libtclsqlite.so
+%%WITH_TCL%%lib/sqlite/pkgIndex.tcl
+%%WITH_TCL%%@dirrm lib/sqlite
%%PORTDOCS%%share/doc/sqlite/arch.html
%%PORTDOCS%%share/doc/sqlite/arch.png
%%PORTDOCS%%share/doc/sqlite/c_interface.html
%%PORTDOCS%%share/doc/sqlite/changes.html
-%%PORTDOCS%%share/doc/sqlite/crosscompile.html
+%%PORTDOCS%%share/doc/sqlite/conflict.html
+%%PORTDOCS%%share/doc/sqlite/datatypes.html
%%PORTDOCS%%share/doc/sqlite/download.html
-%%PORTDOCS%%share/doc/sqlite/example.tcl
%%PORTDOCS%%share/doc/sqlite/faq.html
+%%PORTDOCS%%share/doc/sqlite/fileformat.html
+%%PORTDOCS%%share/doc/sqlite/formatchng.html
%%PORTDOCS%%share/doc/sqlite/index.html
%%PORTDOCS%%share/doc/sqlite/lang.html
%%PORTDOCS%%share/doc/sqlite/lemon.html
%%PORTDOCS%%share/doc/sqlite/mingw.html
+%%PORTDOCS%%share/doc/sqlite/nulls.html
+%%PORTDOCS%%share/doc/sqlite/omitted.html
%%PORTDOCS%%share/doc/sqlite/opcode.html
+%%PORTDOCS%%share/doc/sqlite/quickstart.html
%%PORTDOCS%%share/doc/sqlite/report1.txt
%%PORTDOCS%%share/doc/sqlite/speed.html
%%PORTDOCS%%share/doc/sqlite/sqlite.html
%%PORTDOCS%%share/doc/sqlite/tclsqlite.html
%%PORTDOCS%%share/doc/sqlite/vdbe.html
%%PORTDOCS%%@dirrm share/doc/sqlite
+%%PORTDOCS%%share/examples/sqlite/example.tcl
+%%PORTDOCS%%@dirrm share/examples/sqlite