aboutsummaryrefslogtreecommitdiff
path: root/databases/sqlite2
diff options
context:
space:
mode:
authorDavid W. Chapman Jr. <dwcjr@FreeBSD.org>2002-09-02 02:58:53 +0000
committerDavid W. Chapman Jr. <dwcjr@FreeBSD.org>2002-09-02 02:58:53 +0000
commite5962c5b637227430d02c0b7501dd6e5b5aab748 (patch)
treeb9ced839a6c3ba40c878990134c5430301cd714b /databases/sqlite2
parentabc41b34b9bddf42c18ed63d2d8a511d4313c23a (diff)
downloadports-e5962c5b637227430d02c0b7501dd6e5b5aab748.tar.gz
ports-e5962c5b637227430d02c0b7501dd6e5b5aab748.zip
Update to 2.7.1
PR: 40816 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=65461
Diffstat (limited to 'databases/sqlite2')
-rw-r--r--databases/sqlite2/Makefile74
-rw-r--r--databases/sqlite2/distinfo2
-rw-r--r--databases/sqlite2/files/Makefile.bsd38
-rw-r--r--databases/sqlite2/files/Makefile.docs25
-rw-r--r--databases/sqlite2/files/patch-docs30
-rw-r--r--databases/sqlite2/files/patch-test12
-rw-r--r--databases/sqlite2/files/pkgIndex.tcl2
-rw-r--r--databases/sqlite2/pkg-comment2
-rw-r--r--databases/sqlite2/pkg-descr11
-rw-r--r--databases/sqlite2/pkg-plist24
10 files changed, 56 insertions, 164 deletions
diff --git a/databases/sqlite2/Makefile b/databases/sqlite2/Makefile
index a08f79690cde..132e4d543f16 100644
--- a/databases/sqlite2/Makefile
+++ b/databases/sqlite2/Makefile
@@ -7,59 +7,51 @@
#
PORTNAME= sqlite
-PORTVERSION= 1.0.32
+PORTVERSION= 2.7.1
CATEGORIES= databases
MASTER_SITES= http://www.hwaci.com/sw/sqlite/
+DISTNAME= ${PORTNAME}-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= gerhard.haering@gmx.de
-LIB_DEPENDS= gdbm.2:${PORTSDIR}/databases/gdbm \
- tcl${TCL_VER:S/.//}:${PORTSDIR}/lang/tcl${TCL_VER:S/.//}
-BUILD_DEPENDS= lemon:${PORTSDIR}/devel/lemon
+LIB_DEPENDS= tcl${TCL_VER:S/.//}:${PORTSDIR}/lang/tcl${TCL_VER:S/.//}
-MAKEFILE= ${FILESDIR}/Makefile.bsd
-MAKE_ARGS+= -j2
+USE_GMAKE= YES
+GNU_CONFIGURE= YES
+USE_REINPLACE= YES
+CONFIGURE_ARGS= --prefix=${PREFIX} --with-hints=freebsd.hints
+INSTALLS_SHLIB= YES
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+MAKE_ARGS+= TCLSH=tclsh${TCL_VER}
MAKE_ENV+= TCL_VER=${TCL_VER}
TCL_VER?= 8.3
-GDBM_TOOLS= gdbmdump gdbmstat
+DOCFILES= arch.html arch.png c_interface.html changes.html \
+ crosscompile.html download.html faq.html index.html \
+ lang.html lemon.html mingw.html opcode.html report1.txt \
+ speed.html sqlite.html tclsqlite.html vdbe.html
-post-build: test
-.for p in ${GDBM_TOOLS}
- cd ${WRKSRC}/tool && ${MAKE} CFLAGS="${CFLAGS} -I${PREFIX}/include" \
- LDADD="-L${PREFIX}/lib -lgdbm" PROG=$p NOMAN=1 \
- -f bsd.prog.mk
-.endfor
- cd ${WRKSRC} && ${MAKE} VPATH=${WRKSRC}/src \
- CFLAGS="${CFLAGS} -I${WRKSRC} -I${WRKSRC}/src" \
- LDADD="-L${WRKSRC} -lsqlite" PROG=sqlite SRCS=shell.c NOMAN=1 \
- -f bsd.prog.mk
-.ifndef NOPORTDOCS
- cd ${WRKSRC}/www && ${SETENV} ${MAKE_ENV} \
- ${MAKE} ${MAKE_ARGS} -f ${FILESDIR}/Makefile.docs
-.endif
+DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}
+
+post-patch:
+ ${REINPLACE_CMD} -e "s/tclsh \$$(TOP)/\$$(TCLSH) \$$(TOP)/g" ${WRKSRC}/Makefile.in
+ ${ECHO} "config_TARGET_TCL_INC=\"-I${PREFIX}/include/tcl${TCL_VER}\"" >${WRKSRC}/freebsd.hints
+ ${ECHO} "config_TARGET_TCL_LIBS=\"-L${PREFIX}/lib -ltcl${TCL_VER:S/.//}\"" >>${WRKSRC}/freebsd.hints
+ #${ECHO} "config_TARGET_CFLAGS=\"-DTHREADSAFE=1 -pthread\"" >>${WRKSRC}/freebsd.hints
+
+post-build:
+ # Build the docs
+ cd ${WRKSRC} && ${MAKE} ${MAKE_ARGS} doc
post-install:
-.for p in ${GDBM_TOOLS}
- cd ${WRKSRC}/tool && ${MAKE} BINDIR="${PREFIX}/bin" \
- PROG=$p NOMAN=1 -f bsd.prog.mk install
+ ${INSTALL_DATA} ${FILESDIR}/pkgIndex.tcl ${PREFIX}/lib/
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+# @${INSTALL_DATA} ${FILESDIR}/example.tcl ${DOCSDIR}
+.for file in ${DOCFILES}
+ @${INSTALL_DATA} ${WRKSRC}/doc//${file} ${DOCSDIR}
.endfor
- cd ${WRKSRC} && ${MAKE} PROG=sqlite NOMAN=1 BINDIR="${PREFIX}/bin" \
- -f bsd.prog.mk install
- ${MKDIR} ${PREFIX}/lib/sqlite
- ${INSTALL_DATA} ${FILESDIR}/pkgIndex.tcl ${PREFIX}/lib/sqlite/
-.ifndef NOPORTDOCS
- ${MKDIR} ${PREFIX}/share/doc/sqlite
- ${INSTALL_DATA} ${WRKSRC}/www/*.html ${WRKSRC}/www/*.png \
- ${PREFIX}/share/doc/sqlite
.endif
-test:
- # -------------------------------------------------------
- # Running the vendor's tests -- there should be 0 errors.
- # -------------------------------------------------------
- cd ${WRKSRC} && ${PREFIX}/bin/tclsh${TCL_VER} ${WRKSRC}/test/all.test \
- ${WRKSRC}/libsqlite.so
- # -------------------------------------------------------
-
.include <bsd.port.mk>
diff --git a/databases/sqlite2/distinfo b/databases/sqlite2/distinfo
index 311a0ded1b81..898ae5ffcc69 100644
--- a/databases/sqlite2/distinfo
+++ b/databases/sqlite2/distinfo
@@ -1 +1 @@
-MD5 (sqlite-1.0.32.tar.gz) = 308be6d8b9e9514150ef4f89902b2fbc
+MD5 (sqlite-2.7.1.tar.gz) = 4910d3603365ab042cf78a1ec6304bb6
diff --git a/databases/sqlite2/files/Makefile.bsd b/databases/sqlite2/files/Makefile.bsd
deleted file mode 100644
index 2b8d83f17612..000000000000
--- a/databases/sqlite2/files/Makefile.bsd
+++ /dev/null
@@ -1,38 +0,0 @@
-TCL_VER ?= 8.3
-TCL_DVER = ${TCL_VER:S/.//}
-PREFIX ?= /usr/local
-
-CFLAGS += -DHAVE_READLINE=1 -DOS_UNIX=1 -DOS_WIN=0
-CFLAGS += -I${PREFIX}/include/tcl${TCL_VER} -I${PREFIX}/include
-CFLAGS += -I${.CURDIR}/src -I${.CURDIR}
-
-LDADD += -lreadline -L${PREFIX}/lib -ltcl${TCL_DVER} -lm -lgdbm
-
-.PATH: ${.CURDIR}/src
-
-SRCS = btree.c build.c dbbe.c dbbegdbm.c dbbemem.c delete.c expr.c \
- insert.c main.c pager.c parse.y printf.c random.c select.c \
- shell.c table.c tokenize.c update.c util.c vdbe.c where.c \
- tclsqlite.c
-
-INCS = sqlite.h
-
-LIB = sqlite
-SHLIB_MAJOR= 1
-SHLIB_MINOR= 0
-
-sqlite.h: sqlite.h.in VERSION
- sed -e s/--VERS--/`cat ${.CURDIR}/VERSION`/ \
- -e s/--ENCODING--/ISO8859/ \
- ${.CURDIR}/src/sqlite.h.in > sqlite.h
-
-parse.h parse.c: parse.y
- lemon o=parse ${.ALLSRC}
-
-INCSDIR = ${PREFIX}/include
-INCDIR = ${INCSDIR} # for pre-bsd.incs.mk API
-LIBDIR = ${PREFIX}/lib
-
-.include <bsd.lib.mk>
-
-${OBJS} ${SOBJS}: parse.h sqlite.h
diff --git a/databases/sqlite2/files/Makefile.docs b/databases/sqlite2/files/Makefile.docs
deleted file mode 100644
index 77d95a57d548..000000000000
--- a/databases/sqlite2/files/Makefile.docs
+++ /dev/null
@@ -1,25 +0,0 @@
-TCL_VER ?= 8.3
-
-SRCS != echo ${.CURDIR}/*.tcl
-DOCS = ${SRCS:Nopcode.tcl:.tcl=.html}
-CODE != echo ${.CURDIR}/../src/*.[chy]
-
-all: ${DOCS} opcode.html
-
-opcode.html:: opcode.tcl vdbe.c
- tclsh${TCL_VER} ${.ALLSRC} > opcode.html
-
-.SUFFIXES: .tcl .html
-
-.tcl.html:
- tclsh${TCL_VER} $*.tcl > $*.html
-
-${DOCS}: last_change
-
-.PATH: ${.CURDIR}/../src
-
-last_change: ${CODE}
- awk '/\$$Id:/ && NF > 4 { \
- if ($$2 == "\$$Id:") print $$5 "," $$6; \
- else print $$6 "," $$7 \
- }' ${.ALLSRC} | sort -t, | tail -1 > lc && mv lc last_change
diff --git a/databases/sqlite2/files/patch-docs b/databases/sqlite2/files/patch-docs
deleted file mode 100644
index ce5498da4d16..000000000000
--- a/databases/sqlite2/files/patch-docs
+++ /dev/null
@@ -1,30 +0,0 @@
---- www/index.tcl Thu Apr 5 12:49:44 2001
-+++ www/index.tcl Fri Jun 8 17:46:08 2001
-@@ -117,12 +117,6 @@
-
--puts {<h2>Download</h2>
-+puts "<!-- h2>Download</h2 --><h3>This installation of Sqlite $vers was made"
-+puts {by the <A href="http://www.freebsd.org/cgi/ports.cgi?query=sqlite">FreeBSD
-+Port</A>.</h3>}
-
--<p>You can download a tarball containing all source
--code for SQLite
--}
--puts "version $vers"
--puts {
--(including the TCL scripts that generate the
--HTML files for this website) at <a href="sqlite.tar.gz">sqlite.tar.gz</a>.}
--puts "This is a [file size sqlite.tar.gz] byte download."
- puts {</p>
---- www/dynload.tcl Sun Feb 11 11:58:22 2001
-+++ www/dynload.tcl Mon Jun 11 19:09:47 2001
-@@ -15,3 +15,3 @@
- <i>This note was contributed by
--<a href="bsaunder@tampabay.rr.com.nospam">Bill Saunders</a>. Thanks, Bill!</i>
-+<a href="mailto:bsaunder@tampabay.rr.com.nospam">Bill Saunders</a>. Thanks, Bill!</i>
-
-@@ -67,3 +67,3 @@
- Have fun....</p></li>
--</ul>
-+</ol>
-
diff --git a/databases/sqlite2/files/patch-test b/databases/sqlite2/files/patch-test
deleted file mode 100644
index 3adee03362f9..000000000000
--- a/databases/sqlite2/files/patch-test
+++ /dev/null
@@ -1,12 +0,0 @@
---- test/all.test Tue Feb 6 08:29:31 2001
-+++ test/all.test Fri Jun 8 16:28:34 2001
-@@ -27,2 +27,3 @@
- set testdir [file dirname $argv0]
-+load [lindex $argv 0]
- source $testdir/tester.tcl
---- test/tableapi.test.orig Wed Apr 11 23:28:43 2001
-+++ test/tableapi.test Mon Sep 3 21:24:06 2001
-@@ -30,2 +30,3 @@
- source $testdir/tester.tcl
-+set ::big_str ""
-
diff --git a/databases/sqlite2/files/pkgIndex.tcl b/databases/sqlite2/files/pkgIndex.tcl
index df0b6bb0a82d..dba694a3bc8b 100644
--- a/databases/sqlite2/files/pkgIndex.tcl
+++ b/databases/sqlite2/files/pkgIndex.tcl
@@ -1 +1 @@
-package ifneeded sqlite 1.0 [list load $dir/../libsqlite.so]
+package ifneeded sqlite 0.0 [list load [file join $dir libtclsqlite.so.0] sqlite]
diff --git a/databases/sqlite2/pkg-comment b/databases/sqlite2/pkg-comment
index 750bd919d8c7..b10cb4bd83ea 100644
--- a/databases/sqlite2/pkg-comment
+++ b/databases/sqlite2/pkg-comment
@@ -1 +1 @@
-SQL library that uses GDBM as its underlying file storage mechanism
+An SQL database engine in a C library, including a Tcl wrapper
diff --git a/databases/sqlite2/pkg-descr b/databases/sqlite2/pkg-descr
index 9637e448f5bb..391d99ee6abf 100644
--- a/databases/sqlite2/pkg-descr
+++ b/databases/sqlite2/pkg-descr
@@ -1,8 +1,7 @@
-SQLite is an SQL database library that uses GDBM as its underlying
-file storage mechanism. Programs that link the SQLite library can
-have SQL database access without running a separate RDBMS process.
-The distribution comes with a standalone command-line access program
-(sqlite) that can be used to administer an SQLite database and which
-serves as an example of how to use the SQLite library.
+SQLite is an SQL database engine in a C library. Programs that link the SQLite
+library can have SQL database access without running a separate RDBMS process.
+The distribution comes with a standalone command-line access program (sqlite)
+that can be used to administer an SQLite database and which serves as an
+example of how to use the SQLite library.
WWW: http://www.hwaci.com/sw/sqlite/
diff --git a/databases/sqlite2/pkg-plist b/databases/sqlite2/pkg-plist
index 1004425fe405..9109d356510d 100644
--- a/databases/sqlite2/pkg-plist
+++ b/databases/sqlite2/pkg-plist
@@ -1,25 +1,31 @@
bin/sqlite
-bin/gdbmdump
-bin/gdbmstat
+include/sqlite.h
lib/libsqlite.a
-lib/libsqlite_p.a
+lib/libsqlite.la
lib/libsqlite.so
-lib/libsqlite.so.1.0
-lib/sqlite/pkgIndex.tcl
-@dirrm lib/sqlite
-include/sqlite.h
+lib/libsqlite.so.0
+@comment lib/sqlite/libtclsqlite.so.0
+@comment lib/sqlite/libtclsqlite.so
+@comment lib/sqlite/libtclsqlite.la
+@comment lib/sqlite/libtclsqlite.a
+@comment lib/sqlite/pkgIndex.tcl
+@comment @dirrm lib/sqlite
%%PORTDOCS%%share/doc/sqlite/arch.html
%%PORTDOCS%%share/doc/sqlite/arch.png
%%PORTDOCS%%share/doc/sqlite/c_interface.html
%%PORTDOCS%%share/doc/sqlite/changes.html
%%PORTDOCS%%share/doc/sqlite/crosscompile.html
-%%PORTDOCS%%share/doc/sqlite/dynload.html
-%%PORTDOCS%%share/doc/sqlite/fileformat.html
+%%PORTDOCS%%share/doc/sqlite/download.html
+%%PORTDOCS%%share/doc/sqlite/faq.html
%%PORTDOCS%%share/doc/sqlite/index.html
%%PORTDOCS%%share/doc/sqlite/lang.html
+%%PORTDOCS%%share/doc/sqlite/lemon.html
%%PORTDOCS%%share/doc/sqlite/mingw.html
%%PORTDOCS%%share/doc/sqlite/opcode.html
+%%PORTDOCS%%share/doc/sqlite/report1.txt
+%%PORTDOCS%%share/doc/sqlite/speed.html
%%PORTDOCS%%share/doc/sqlite/sqlite.html
%%PORTDOCS%%share/doc/sqlite/tclsqlite.html
%%PORTDOCS%%share/doc/sqlite/vdbe.html
+@comment %%PORTDOCS%%share/doc/sqlite/example.tcl
%%PORTDOCS%%@dirrm share/doc/sqlite