aboutsummaryrefslogtreecommitdiff
path: root/databases/sqlrelay
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2004-05-26 14:26:21 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2004-05-26 14:26:21 +0000
commit9230a343c459a3738380c6520e46ad3e9388505e (patch)
tree02e023abd6033f63b203300452899d6f6d7e970a /databases/sqlrelay
parent83ab2ea2b9888af7715d0a7d60a2cd45900a0940 (diff)
downloadports-9230a343c459a3738380c6520e46ad3e9388505e.tar.gz
ports-9230a343c459a3738380c6520e46ad3e9388505e.zip
Update to version 0.34.2.
Remove BROKEN for 5.X. Leave BROKEN for 4.X since I didn't test there, but I hope it should work. More testing is needed. I switched off all DB variants support but MySQL due to the lack of tests. Comments welcome.
Notes
Notes: svn path=/head/; revision=110063
Diffstat (limited to 'databases/sqlrelay')
-rw-r--r--databases/sqlrelay/Makefile48
-rw-r--r--databases/sqlrelay/Makefile.common2
-rw-r--r--databases/sqlrelay/distinfo4
-rw-r--r--databases/sqlrelay/files/extra-patch-src+api+c+++src+Makefile26
-rw-r--r--databases/sqlrelay/files/extra-patch-src+api+c+src+Makefile26
-rw-r--r--databases/sqlrelay/files/patch-Makefile14
-rw-r--r--databases/sqlrelay/files/patch-config.mk.in10
-rw-r--r--databases/sqlrelay/files/patch-configure164
-rw-r--r--databases/sqlrelay/files/patch-src+api+java+Makefile18
-rw-r--r--databases/sqlrelay/pkg-plist213
10 files changed, 220 insertions, 305 deletions
diff --git a/databases/sqlrelay/Makefile b/databases/sqlrelay/Makefile
index 1162dea38e02..650895175238 100644
--- a/databases/sqlrelay/Makefile
+++ b/databases/sqlrelay/Makefile
@@ -7,7 +7,6 @@
PORTNAME= ${SQLRELAY_PORTNAME}
PORTVERSION= ${SQLRELAY_PORTVERSION}
-PORTREVISION= 4
CATEGORIES= databases
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= sqlrelay
@@ -38,22 +37,22 @@ POSTGRESQL_PORT?= databases/postgresql7
.include "${.CURDIR}/Makefile.common"
.if defined(PACKAGE_BUILDING) || defined(BATCH)
-WITH_SQLITE?= yes
+WITH_SQLITE?= no
WITH_MYSQL?= yes
WITH_MSQL?= no
-WITH_POSTGRESQL?= yes
-WITH_ODBC?= yes
-WITH_FREETDS?= yes
-WITH_GTK?= yes
-WITH_INTERBASE?= yes
+WITH_POSTGRESQL?= no
+WITH_ODBC?= no
+WITH_FREETDS?= no
+WITH_GTK?= no
+WITH_INTERBASE?= no
.else
WITH_SQLITE?= no
WITH_MYSQL?= yes
WITH_MSQL?= no
-WITH_POSTGRESQL?= yes
+WITH_POSTGRESQL?= no
WITH_ODBC?= no
WITH_FREETDS?= no
-WITH_GTK?= yes
+WITH_GTK?= no
WITH_INTERBASE?= no
.endif
@@ -141,6 +140,10 @@ PLIST_SUB= IF_SQLITE=${IF_SQLITE} \
IF_INTERBASE=${IF_INTERBASE} \
IF_GTK=${IF_GTK}
+MAN1= fields.1 query.1 query.py.1 sqlr-config-gtk.1 sqlrsh.1
+MAN8= sqlr-connection.8 sqlr-cachemanager.8 sqlr-ipclean.8 \
+ sqlr-listener.8 sqlr-scaler.8 sqlr-start.8 sqlr-stop.8
+
# --with-sybase-prefix Location of Sybase
# --with-oracle-home Location of Oracle
# --with-interbase-prefix Location of Interbase
@@ -150,24 +153,12 @@ PLIST_SUB= IF_SQLITE=${IF_SQLITE} \
.if ${OSVERSION} < 500000
BROKEN= "Broken pkg-plist"
-.else
-BROKEN= "Does not compile on 5.x"
.endif
-DEPRECATED= ${BROKEN}
-EXPIRATION_DATE=2004-06-18
-.if ${OSVERSION} >= 500000
-EXTRA_PATCHES= ${PATCHDIR}/extra-patch-*
-
-PLIST_SUB+= PROFILE="@comment "
-.else
-PLIST_SUB+= PROFILE=""
-.endif
-
-post-extract:
- ${MKDIR} ${WRKDIR}/prefixes/libxml
- ${LN} -s ${LOCALBASE}/include/libxml2 ${WRKDIR}/prefixes/libxml/include
- ${LN} -s ${LOCALBASE}/lib ${WRKDIR}/prefixes/libxml/lib
+#post-extract:
+# ${MKDIR} ${WRKDIR}/prefixes/libxml
+# ${LN} -s ${LOCALBASE}/include/libxml2 ${WRKDIR}/prefixes/libxml/include
+# ${LN} -s ${LOCALBASE}/lib ${WRKDIR}/prefixes/libxml/lib
post-patch:
${REINPLACE_CMD} -E \
@@ -178,10 +169,7 @@ post-patch:
-e 's,\.so\.\$$\(SQLR_VERSION\),\.so\.$$(basename $$(SQLR_VERSION)),g;' \
${WRKSRC}/src/api/c/src/Makefile \
${WRKSRC}/src/api/c++/src/Makefile
-
-post-install:
-.if !defined(NOPORTDOCS)
- cd ${WRKSRC} && ${MAKE} install-doc
-.endif
+ ${FIND} ${WRKSRC} -name Makefile | ${XARGS} ${REINPLACE_CMD} -E \
+ -e 's#-release \$$\(SQLR_VERSION\)##g;'
.include <bsd.port.post.mk>
diff --git a/databases/sqlrelay/Makefile.common b/databases/sqlrelay/Makefile.common
index fde7aea263d2..34338f85a12b 100644
--- a/databases/sqlrelay/Makefile.common
+++ b/databases/sqlrelay/Makefile.common
@@ -1,7 +1,7 @@
# $FreeBSD$
SQLRELAY_PORTNAME= sqlrelay
-SQLRELAY_PORTVERSION= 0.32
+SQLRELAY_PORTVERSION= 0.34.2
SQLRELAY_PORTDIR= ${PORTSDIR}/databases/${SQLRELAY_PORTNAME}
SQLRELAY_WRKSRC_CMD= cd ${SQLRELAY_PORTDIR} && ${MAKE} -V WRKSRC
diff --git a/databases/sqlrelay/distinfo b/databases/sqlrelay/distinfo
index f605614505a5..0fca3c9a697a 100644
--- a/databases/sqlrelay/distinfo
+++ b/databases/sqlrelay/distinfo
@@ -1,2 +1,2 @@
-MD5 (sqlrelay-0.32.tar.gz) = 711f1edc83a61644715462e78976586d
-SIZE (sqlrelay-0.32.tar.gz) = 998694
+MD5 (sqlrelay-0.34.2.tar.gz) = b40c66273d733be9ef186d1bd1798945
+SIZE (sqlrelay-0.34.2.tar.gz) = 1423776
diff --git a/databases/sqlrelay/files/extra-patch-src+api+c+++src+Makefile b/databases/sqlrelay/files/extra-patch-src+api+c+++src+Makefile
deleted file mode 100644
index b20316d8d48e..000000000000
--- a/databases/sqlrelay/files/extra-patch-src+api+c+++src+Makefile
+++ /dev/null
@@ -1,26 +0,0 @@
---- src/api/c++/src/Makefile.orig Sat Apr 13 16:37:18 2002
-+++ src/api/c++/src/Makefile Wed Dec 18 21:53:01 2002
-@@ -11,7 +11,6 @@
-
- all:
- $(MAKE) ../lib/libsqlrclient.a; \
-- $(MAKE) ../lib/libsqlrclient_p.a; \
- if ( test "$(MINGW32)" != "yes" -a "$(CYGWIN)" != "yes" -a "$(UWIN)" != "yes" ); then \
- $(MAKE) ../lib/libsqlrclient.so.$(SQLR_VERSION); \
- else \
-@@ -54,7 +53,6 @@
- install:
- $(top_srcdir)/mkinstalldirs $(libdir)
- $(INSTALL) -m 644 ../lib/libsqlrclient.a $(libdir); \
-- $(INSTALL) -m 644 ../lib/libsqlrclient_p.a $(libdir); \
- if ( test "$(MINGW32)" != "yes" -a "$(CYGWIN)" != "yes" -a "$(UWIN)" != "yes" ); then \
- $(RM) $(libdir)/libsqlrclient.so*; \
- $(INSTALL) ../lib/libsqlrclient.so.$(SQLR_VERSION) $(libdir); \
-@@ -70,7 +68,6 @@
- uninstall:
- $(RM) $(libdir)/libsqlrclient.so*
- $(RM) $(libdir)/libsqlrclient.a
-- $(RM) $(libdir)/libsqlrclient_p.a
- $(RM) $(libdir)/libsqlrclient.dll
- $(RM) $(libdir)/libsqlrclient.lib
- $(RMTREE) $(cachedir)
diff --git a/databases/sqlrelay/files/extra-patch-src+api+c+src+Makefile b/databases/sqlrelay/files/extra-patch-src+api+c+src+Makefile
deleted file mode 100644
index 6c0c55424a83..000000000000
--- a/databases/sqlrelay/files/extra-patch-src+api+c+src+Makefile
+++ /dev/null
@@ -1,26 +0,0 @@
---- src/api/c/src/Makefile.orig Sat Apr 13 16:37:08 2002
-+++ src/api/c/src/Makefile Wed Dec 18 21:52:24 2002
-@@ -11,7 +11,6 @@
-
- all:
- $(MAKE) ../lib/libsqlrclientwrapper.a; \
-- $(MAKE) ../lib/libsqlrclientwrapper_p.a; \
- if ( test "$(MINGW32)" != "yes" -a "$(CYGWIN)" != "yes" -a "$(UWIN)" != "yes" ); then \
- $(MAKE) ../lib/libsqlrclientwrapper.so.$(SQLR_VERSION); \
- else \
-@@ -51,7 +50,6 @@
- install:
- $(top_srcdir)/mkinstalldirs $(libdir)
- $(INSTALL) -m 644 ../lib/libsqlrclientwrapper.a $(libdir); \
-- $(INSTALL) -m 644 ../lib/libsqlrclientwrapper_p.a $(libdir); \
- if ( test "$(MINGW32)" != "yes" -a "$(CYGWIN)" != "yes" -a "$(UWIN)" != "yes" ); then \
- $(RM) $(libdir)/libsqlrclientwrapper.so*; \
- $(INSTALL) ../lib/libsqlrclientwrapper.so.$(SQLR_VERSION) $(libdir); \
-@@ -67,7 +65,6 @@
- uninstall:
- $(RM) $(libdir)/libsqlrclientwrapper.so*
- $(RM) $(libdir)/libsqlrclientwrapper.a
-- $(RM) $(libdir)/libsqlrclientwrapper_p.a
- $(RM) $(libdir)/libsqlrclientwrapper.dll
- $(RM) $(libdir)/libsqlrclientwrapper.lib
- $(RMTREE) $(cachedir)
diff --git a/databases/sqlrelay/files/patch-Makefile b/databases/sqlrelay/files/patch-Makefile
deleted file mode 100644
index 1dcfc92cbb33..000000000000
--- a/databases/sqlrelay/files/patch-Makefile
+++ /dev/null
@@ -1,14 +0,0 @@
---- Makefile.orig Wed Oct 17 06:20:48 2001
-+++ Makefile Sun Feb 24 01:42:57 2002
-@@ -24,9 +24,10 @@
-
- install:
- cd bin; $(MAKE) install
-- cd doc; $(MAKE) install
- cd etc; $(MAKE) install
- cd src; $(MAKE) install
-+install-doc:
-+ cd doc; $(MAKE) install
-
- uninstall:
- cd bin; $(MAKE) uninstall
diff --git a/databases/sqlrelay/files/patch-config.mk.in b/databases/sqlrelay/files/patch-config.mk.in
index 2ad92f17abbf..f08d7a46e42c 100644
--- a/databases/sqlrelay/files/patch-config.mk.in
+++ b/databases/sqlrelay/files/patch-config.mk.in
@@ -1,6 +1,6 @@
---- config.mk.in.orig Thu Oct 18 11:54:14 2001
-+++ config.mk.in Sun Feb 24 01:49:43 2002
-@@ -8,13 +8,13 @@
+--- config.mk.in.orig Tue Dec 16 19:05:34 2003
++++ config.mk.in Wed May 26 16:34:41 2004
+@@ -14,13 +14,13 @@
exec_prefix= @exec_prefix@
incdir = @includedir@
libdir = @libdir@
@@ -10,9 +10,9 @@
bindir = @bindir@
localstatedir = @localstatedir@
sysconfdir = @sysconfdir@
- localstatedir = @localstatedir@
+ mandir = @mandir@
-docdir = ${prefix}/doc/sqlrelay
+docdir = ${prefix}/share/doc/sqlrelay
tmpdir = ${localstatedir}/sqlrelay/tmp
cachedir = ${localstatedir}/sqlrelay/cache
-
+ debugdir = ${localstatedir}/sqlrelay/debug
diff --git a/databases/sqlrelay/files/patch-configure b/databases/sqlrelay/files/patch-configure
index 7506249be732..9ab39e3cb629 100644
--- a/databases/sqlrelay/files/patch-configure
+++ b/databases/sqlrelay/files/patch-configure
@@ -1,115 +1,63 @@
---- configure.orig Mon Apr 15 14:23:31 2002
-+++ configure Thu Nov 21 19:00:36 2002
-@@ -1705,7 +1705,7 @@
- fi
- if eval "test \"`echo '$ac_cv_file_'$ac_safe`\" = yes"; then
- echo "$ac_t""yes" 1>&6
-- HAVE_GNOME_XML="yes"; XMLINCLUDES="-I$LIBXMLPATH"
-+ HAVE_GNOME_XML="yes"; XMLINCLUDES="-I$LIBXMLPATH/include"
- else
- echo "$ac_t""no" 1>&6
+--- configure.orig Tue Dec 16 19:06:16 2003
++++ configure Wed May 26 17:56:40 2004
+@@ -37573,13 +37573,7 @@
-@@ -1784,7 +1784,7 @@
- fi
- if eval "test \"`echo '$ac_cv_file_'$ac_safe`\" = yes"; then
- echo "$ac_t""yes" 1>&6
-- HAVE_LIBXML="yes"; HAVE_GNOME_XML=""; XMLINCLUDES="-I$LIBXMLPATH"
-+ HAVE_LIBXML="yes"; HAVE_GNOME_XML=""; XMLINCLUDES="-I$LIBXMLPATH/include"
- else
- echo "$ac_t""no" 1>&6
+ if ( test -n "$JAVAINCLUDES" )
+ then
+- for i in `ls -d $JAVAPATH/include/*`
+- do
+- if ( test -d "$i" )
+- then
+- JAVAINCLUDES="$JAVAINCLUDES -I$i"
+- fi
+- done
++ JAVAINCLUDES="$JAVAINCLUDES -I`dirname $JAVAPATH/include/*/jni_md.h`"
+ fi
+ fi
-@@ -7314,7 +7314,7 @@
+@@ -37958,14 +37952,14 @@
+ if ( test -n "$GTKPATH" )
+ then
+
+-if ( test -r ""$GTKPATH/bin/gtk-config"" )
++if ( test -r ""$GTKPATH/bin/gtk12-config"" )
+ then
+- eval "GTKCONFIG=\"$GTKPATH/bin/gtk-config\""
++ eval "GTKCONFIG=\"$GTKPATH/bin/gtk12-config\""
fi
- if eval "test \"`echo '$ac_cv_file_'$ac_safe`\" = yes"; then
- echo "$ac_t""yes" 1>&6
-- INTERBASELIBSPATH="$INTERBASPATH/lib"; INTERBASELIBS="-L$INTERBASEPATH/lib -lgds -lcrypt"
-+ INTERBASELIBSPATH="$INTERBASEPATH/lib"; INTERBASELIBS="-L$INTERBASEPATH/lib -lgds -lcrypt"
- else
- echo "$ac_t""no" 1>&6
-@@ -7403,8 +7403,8 @@
+ else
+- # Extract the first word of ""gtk-config"", so it can be a program name with args.
+-set dummy "gtk-config"; ac_word=$2
++ # Extract the first word of ""gtk12-config"", so it can be a program name with args.
++set dummy "gtk12-config"; ac_word=$2
+ echo "$as_me:$LINENO: checking for $ac_word" >&5
+ echo $ECHO_N "checking for $ac_word... $ECHO_C" >&6
+ if test "${ac_cv_prog_GTKCONFIG+set}" = set; then
+@@ -37981,7 +37975,7 @@
+ test -z "$as_dir" && as_dir=.
+ for ac_exec_ext in '' $ac_executable_extensions; do
+ if $as_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
+- ac_cv_prog_GTKCONFIG=""gtk-config""
++ ac_cv_prog_GTKCONFIG=""gtk12-config""
+ echo "$as_me:$LINENO: found $as_dir/$ac_word$ac_exec_ext" >&5
+ break 2
+ fi
+@@ -38003,7 +37997,7 @@
+ then
+ for i in "/usr/bin" "/usr/local/bin" "/usr/pkg/bin" "/usr/local/gtk/bin" "/usr/local/gtk+/bin" "/opt/sfw/bin"
+ do
+- for j in "gtk-config" "gtk12-config" "gtk10-config"
++ for j in "gtk12-config" "gtk12-config" "gtk10-config"
+ do
+
+ if ( test -r ""$i/$j"" )
+@@ -41269,7 +41263,7 @@
+ #define SQLR_VERSION "$SQLR_VERSION"
+ _ACEOF
+
+-SONAME_VERSION_INFO="1:0:0"
++SONAME_VERSION_INFO="0:0:0"
- LINKFAIL=""
- if ( test -n "$INTERBASESTATIC" -a -n "$INTERBASELIBS" ); then
-- echo $ac_n "checking if Interbase can be statically linked without $DLLIB""... $ac_c" 1>&6
--echo "configure:7408: checking if Interbase can be statically linked without $DLLIB" >&5
-+ echo $ac_n "checking if Interbase can be statically linked without -lcrypt""... $ac_c" 1>&6
-+echo "configure:7408: checking if Interbase can be statically linked without -lcrypt" >&5
- TEMPCPPFLAGS="$CPPFLAGS"
- CPPFLAGS="$INTERBASESTATIC $INTERBASEINCLUDES"
- LIBS="$INTERBASELIBS $SOCKETLIB"
-@@ -7429,12 +7429,12 @@
- rm -f conftest*
- LIBS=""
- CPPFLAGS="$TEMPCPPFLAGS"
-- if ( test -n "$LINKFAIL" -a -n "$DLLIB" ); then
-- echo $ac_n "checking if Interbase can be statically linked with $DLLIB""... $ac_c" 1>&6
--echo "configure:7435: checking if Interbase can be statically linked with $DLLIB" >&5
-+ if ( test -n "$LINKFAIL" ); then
-+ echo $ac_n "checking if Interbase can be statically linked with -lcrypt""... $ac_c" 1>&6
-+echo "configure:7435: checking if Interbase can be statically linked with -lcrypt" >&5
- TEMPCPPFLAGS="$CPPFLAGS"
- CPPFLAGS="$INTERBASESTATIC $INTERBASEINCLUDES"
-- LIBS="$INTERBASELIBS $SOCKETLIB $DLLIB"
-+ LIBS="$INTERBASELIBS $SOCKETLIB -lcrypt"
- cat > conftest.$ac_ext <<EOF
- #line 7440 "configure"
- #include "confdefs.h"
-@@ -7446,7 +7446,7 @@
- EOF
- if { (eval echo configure:7448: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
- rm -rf conftest*
-- echo "$ac_t""yes" 1>&6; INTERBASELIBS="$INTERBASELIBS $DLLIB"; LINKFAIL="";
-+ echo "$ac_t""yes" 1>&6; INTERBASELIBS="$INTERBASELIBS -lcrypt"; LINKFAIL="";
- else
- echo "configure: failed program was:" >&5
- cat conftest.$ac_ext >&5
-@@ -7463,8 +7463,8 @@
- if ( test -n "$RPATHFLAG" -a -n "$INTERBASELIBSPATH" ); then
- INTERBASELIBS="-Wl,-rpath $INTERBASELIBSPATH $INTERBASELIBS"
- fi
-- echo $ac_n "checking if Interbase can be dynamically linked without $DLLIB""... $ac_c" 1>&6
--echo "configure:7468: checking if Interbase can be dynamically linked without $DLLIB" >&5
-+ echo $ac_n "checking if Interbase can be dynamically linked without -lcrypt""... $ac_c" 1>&6
-+echo "configure:7468: checking if Interbase can be dynamically linked without -lcrypt" >&5
- TEMPCPPFLAGS="$CPPFLAGS"
- CPPFLAGS="$INTERBASEINCLUDES"
- LIBS="$INTERBASELIBS $SOCKETLIB"
-@@ -7489,12 +7489,12 @@
- rm -f conftest*
- LIBS=""
- CPPFLAGS="$TEMPCPPFLAGS"
-- if ( test -n "$LINKFAIL" -a -n "$DLLIB" ); then
-- echo $ac_n "checking if Interbase can be dynamically linked with $DLLIB""... $ac_c" 1>&6
--echo "configure:7495: checking if Interbase can be dynamically linked with $DLLIB" >&5
-+ if ( test -n "$LINKFAIL" ); then
-+ echo $ac_n "checking if Interbase can be dynamically linked with -lcrypt""... $ac_c" 1>&6
-+echo "configure:7495: checking if Interbase can be dynamically linked with -lcrypt" >&5
- TEMPCPPFLAGS="$CPPFLAGS"
- CPPFLAGS="$INTERBASEINCLUDES"
-- LIBS="$INTERBASELIBS $SOCKETLIB $DLLIB"
-+ LIBS="$INTERBASELIBS $SOCKETLIB -lcrypt"
- cat > conftest.$ac_ext <<EOF
- #line 7500 "configure"
- #include "confdefs.h"
-@@ -7506,7 +7506,7 @@
- EOF
- if { (eval echo configure:7508: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
- rm -rf conftest*
-- echo "$ac_t""yes" 1>&6; INTERBASELIBS="$INTERBASELIBS $DLLIB"; LINKFAIL=""
-+ echo "$ac_t""yes" 1>&6; INTERBASELIBS="$INTERBASELIBS -lcrypt"; LINKFAIL=""
- else
- echo "configure: failed program was:" >&5
- cat conftest.$ac_ext >&5
-@@ -8122,10 +8122,7 @@
- fi
- if ( test -n "$JAVAINCLUDES"); then
-- for i in `ls -l $JAVAPATH/include | grep drw | awk '{print $9}'`
-- do
-- JAVAINCLUDES="$JAVAINCLUDES -I$JAVAPATH/include/$i"
-- done
-+ JAVAINCLUDES="$JAVAINCLUDES -I`dirname $JAVAPATH/include/*/jni_md.h`"
- fi
- fi
diff --git a/databases/sqlrelay/files/patch-src+api+java+Makefile b/databases/sqlrelay/files/patch-src+api+java+Makefile
index f9be5672d1bc..a232abdcc67d 100644
--- a/databases/sqlrelay/files/patch-src+api+java+Makefile
+++ b/databases/sqlrelay/files/patch-src+api+java+Makefile
@@ -1,11 +1,11 @@
---- src/api/java/Makefile.orig Sun Mar 24 09:09:19 2002
-+++ src/api/java/Makefile Mon Oct 28 02:46:52 2002
-@@ -3,7 +3,7 @@
- top_srcdir = ../../..
- INSTALL = $(top_srcdir)/install-sh -c
+--- src/api/java/Makefile.orig Wed Dec 17 09:29:12 2003
++++ src/api/java/Makefile Wed May 26 16:41:43 2004
+@@ -2,7 +2,7 @@
--CPPFLAGS = $(BASECPPFLAGS) -I./ -I../c++/include $(RUDIMENTSINCLUDES) $(JAVAINCLUDES)
-+CPPFLAGS = $(JAVAINCLUDES) $(BASECPPFLAGS) -I./ -I../c++/include $(RUDIMENTSINCLUDES)
+ include ../../../config.mk
- SRCS = SQLRConnection.C SQLRCursor.C
- OBJS = SQLRConnection.o SQLRCursor.o
+-CPPFLAGS = $(BASECPPFLAGS) -I./ -I$(top_builddir)/src/api/c++/include $(RUDIMENTSINCLUDES) $(JAVAINCLUDES)
++CPPFLAGS = $(JAVAINCLUDES) $(BASECPPFLAGS) -I./ -I$(top_builddir)/src/api/c++/include $(RUDIMENTSINCLUDES)
+ RPATH =
+ ifneq ($(strip $(libdir)),)
+ ifeq ($(JAVAUSERPATH),yes)
diff --git a/databases/sqlrelay/pkg-plist b/databases/sqlrelay/pkg-plist
index c389992e3ba1..fe0bdb7d4fba 100644
--- a/databases/sqlrelay/pkg-plist
+++ b/databases/sqlrelay/pkg-plist
@@ -2,6 +2,8 @@ bin/backupschema
bin/fields
bin/query
bin/sqlr-cachemanager
+bin/sqlrclient-config
+bin/sqlrclientwrapper-config
%%IF_GTK%%bin/sqlr-config-gtk
%%IF_FREETDS%%bin/sqlr-connection-freetds
%%IF_FREETDS%%bin/sqlr-connection-freetds-debug
@@ -37,96 +39,139 @@ include/sqlrelay/sqlrclientwrapper.h
@dirrm include/sqlrelay/private
@dirrm include/sqlrelay
lib/libsqlrclient.a
+lib/libsqlrclient.la
lib/libsqlrclient.so
lib/libsqlrclient.so.0
-%%PROFILE%%lib/libsqlrclient_p.a
lib/libsqlrclientwrapper.a
+lib/libsqlrclientwrapper.la
lib/libsqlrclientwrapper.so
lib/libsqlrclientwrapper.so.0
-%%PROFILE%%lib/libsqlrclientwrapper_p.a
+lib/libpqsqlrelay.a
+lib/libpqsqlrelay.la
+lib/libpqsqlrelay.so
+lib/libpqsqlrelay.so.0
+lib/libsqlrconnection.a
+lib/libsqlrconnection.la
+lib/libsqlrconnection.so
+lib/libsqlrconnection.so.0
+lib/libsqlrconnection_debug.a
+lib/libsqlrconnection_debug.la
+lib/libsqlrconnection_debug.so
+lib/libsqlrconnection_debug.so.0
+lib/libsqlrutil.a
+lib/libsqlrutil.la
+lib/libsqlrutil.so
+lib/libsqlrutil.so.0
+lib/sqlrelay/pkgIndex.tcl
+lib/sqlrelay/sqlrelay.so
+share/doc/sqlrelay/api/c++/sqlrclient.h.html
+share/doc/sqlrelay/api/c/sqlrclientwrapper.h.html
+share/doc/sqlrelay/api/java/allclasses-frame.html
+share/doc/sqlrelay/api/java/allclasses-noframe.html
+share/doc/sqlrelay/api/java/com/firstworks/sqlrelay/SQLRConnection.html
+share/doc/sqlrelay/api/java/com/firstworks/sqlrelay/SQLRCursor.html
+share/doc/sqlrelay/api/java/com/firstworks/sqlrelay/package-frame.html
+share/doc/sqlrelay/api/java/com/firstworks/sqlrelay/package-summary.html
+share/doc/sqlrelay/api/java/com/firstworks/sqlrelay/package-tree.html
+share/doc/sqlrelay/api/java/constant-values.html
+share/doc/sqlrelay/api/java/deprecated-list.html
+share/doc/sqlrelay/api/java/help-doc.html
+share/doc/sqlrelay/api/java/index-all.html
+share/doc/sqlrelay/api/java/index.html
+share/doc/sqlrelay/api/java/overview-tree.html
+share/doc/sqlrelay/api/java/package-list
+share/doc/sqlrelay/api/java/packages.html
+share/doc/sqlrelay/api/java/stylesheet.css
+share/doc/sqlrelay/api/perl/SQLRConnection.html
+share/doc/sqlrelay/api/perl/SQLRCursor.html
+share/doc/sqlrelay/api/perl/SQLRelay.html
+share/doc/sqlrelay/api/perl/perl.html
+share/doc/sqlrelay/api/php/doc.html
+share/doc/sqlrelay/api/python/PySQLRClient.py.html
+share/doc/sqlrelay/api/python/PySQLRDB.py.html
+share/doc/sqlrelay/api/ruby/ruby.html
+share/doc/sqlrelay/api/ruby/rubydbi.html
+share/doc/sqlrelay/clientapis.html
+share/doc/sqlrelay/configuring.html
+share/doc/sqlrelay/connections.html
+share/doc/sqlrelay/css/styles.css
+share/doc/sqlrelay/gettingstarted/db2.html
+share/doc/sqlrelay/gettingstarted/interbase.html
+share/doc/sqlrelay/gettingstarted/lago.html
+share/doc/sqlrelay/gettingstarted/msql.html
+share/doc/sqlrelay/gettingstarted/mssqlserver.html
+share/doc/sqlrelay/gettingstarted/mysql.html
+share/doc/sqlrelay/gettingstarted/oracle.html
+share/doc/sqlrelay/gettingstarted/oracle/linux/redhat/5/805.html
+share/doc/sqlrelay/gettingstarted/oracle/linux/redhat/6/8i.html
+share/doc/sqlrelay/gettingstarted/oracle/linux/redhat/7/8i.html
+share/doc/sqlrelay/gettingstarted/oracle/linux/redhat/7/9i.html
+share/doc/sqlrelay/gettingstarted/oracle/linux/redhat/9/9iR2.html
+share/doc/sqlrelay/gettingstarted/oracle/linux/slackware/7/8i.html
+share/doc/sqlrelay/gettingstarted/oracle/linux/slackware/8/8i.html
+share/doc/sqlrelay/gettingstarted/oracle/linux/slackware/8/9i.html
+share/doc/sqlrelay/gettingstarted/postgresql.html
+share/doc/sqlrelay/gettingstarted/sqlite.html
+share/doc/sqlrelay/gettingstarted/sybase.html
+share/doc/sqlrelay/gettingstarted/sybase/11.0.3.3.html
+share/doc/sqlrelay/gettingstarted/sybase/11.9.2.html
+share/doc/sqlrelay/index.html
+share/doc/sqlrelay/installing.html
+share/doc/sqlrelay/introduction.html
+share/doc/sqlrelay/introtowebdb.html
+share/doc/sqlrelay/invisible.gif
+share/doc/sqlrelay/oraclentier.html
+share/doc/sqlrelay/programming/binds.html
+share/doc/sqlrelay/programming/c++.html
+share/doc/sqlrelay/programming/c.html
+share/doc/sqlrelay/programming/java.html
+share/doc/sqlrelay/programming/perl.html
+share/doc/sqlrelay/programming/perldbi.html
+share/doc/sqlrelay/programming/php.html
+share/doc/sqlrelay/programming/python.html
+share/doc/sqlrelay/programming/pythondb.html
+share/doc/sqlrelay/programming/ruby.html
+share/doc/sqlrelay/programming/rubydbi.html
+share/doc/sqlrelay/programming/zope.html
+share/doc/sqlrelay/programming/zope/instance.gif
+share/doc/sqlrelay/programming/zope/management.gif
+share/doc/sqlrelay/programming/zope/resultset.gif
+share/doc/sqlrelay/programming/zope/sqlrelay.gif
+share/doc/sqlrelay/programming/zope/test.gif
+share/doc/sqlrelay/programming/zope/testzsqlmethod.gif
+share/doc/sqlrelay/programming/zope/zsqlmethod.gif
+share/doc/sqlrelay/programming/zope/zsqlmethodresultset.gif
+share/doc/sqlrelay/running.html
+@dirrm lib/sqlrelay
@dirrm sqlrelay/tmp
@dirrm sqlrelay/debug
@dirrm sqlrelay/cache
@dirrm sqlrelay
-%%PORTDOCS%%share/doc/sqlrelay/api/c++/sqlrclient.h.html
-%%PORTDOCS%%share/doc/sqlrelay/api/c/sqlrclientwrapper.h.html
-%%PORTDOCS%%share/doc/sqlrelay/api/java/SQLRConnection.html
-%%PORTDOCS%%share/doc/sqlrelay/api/java/SQLRCursor.html
-%%PORTDOCS%%share/doc/sqlrelay/api/java/allclasses-frame.html
-%%PORTDOCS%%share/doc/sqlrelay/api/java/deprecated-list.html
-%%PORTDOCS%%share/doc/sqlrelay/api/java/help-doc.html
-%%PORTDOCS%%share/doc/sqlrelay/api/java/index-all.html
-%%PORTDOCS%%share/doc/sqlrelay/api/java/index.html
-%%PORTDOCS%%share/doc/sqlrelay/api/java/overview-tree.html
-%%PORTDOCS%%share/doc/sqlrelay/api/java/package-list
-%%PORTDOCS%%share/doc/sqlrelay/api/java/packages.html
-%%PORTDOCS%%share/doc/sqlrelay/api/java/serialized-form.html
-%%PORTDOCS%%share/doc/sqlrelay/api/java/stylesheet.css
-%%PORTDOCS%%share/doc/sqlrelay/api/perl/SQLRConnection.html
-%%PORTDOCS%%share/doc/sqlrelay/api/perl/SQLRCursor.html
-%%PORTDOCS%%share/doc/sqlrelay/api/perl/SQLRelay.html
-%%PORTDOCS%%share/doc/sqlrelay/api/php/doc.html
-%%PORTDOCS%%share/doc/sqlrelay/api/python/PySQLRClient.py.html
-%%PORTDOCS%%share/doc/sqlrelay/api/python/PySQLRDB.py.html
-%%PORTDOCS%%share/doc/sqlrelay/api/ruby/ruby.html
-%%PORTDOCS%%share/doc/sqlrelay/api/ruby/rubydbi.html
-%%PORTDOCS%%share/doc/sqlrelay/clientapis.html
-%%PORTDOCS%%share/doc/sqlrelay/configuring.html
-%%PORTDOCS%%share/doc/sqlrelay/connections.html
-%%PORTDOCS%%share/doc/sqlrelay/css/styles.css
-%%PORTDOCS%%share/doc/sqlrelay/gettingstarted/db2.html
-%%PORTDOCS%%share/doc/sqlrelay/gettingstarted/interbase.html
-%%PORTDOCS%%share/doc/sqlrelay/gettingstarted/lago.html
-%%PORTDOCS%%share/doc/sqlrelay/gettingstarted/msql.html
-%%PORTDOCS%%share/doc/sqlrelay/gettingstarted/mssqlserver.html
-%%PORTDOCS%%share/doc/sqlrelay/gettingstarted/mysql.html
-%%PORTDOCS%%share/doc/sqlrelay/gettingstarted/oracle.html
-%%PORTDOCS%%share/doc/sqlrelay/gettingstarted/oracle/805.html
-%%PORTDOCS%%share/doc/sqlrelay/gettingstarted/oracle/817.html
-%%PORTDOCS%%share/doc/sqlrelay/gettingstarted/postgresql.html
-%%PORTDOCS%%share/doc/sqlrelay/gettingstarted/sqlite.html
-%%PORTDOCS%%share/doc/sqlrelay/gettingstarted/sybase.html
-%%PORTDOCS%%share/doc/sqlrelay/gettingstarted/sybase/11.0.3.3.html
-%%PORTDOCS%%share/doc/sqlrelay/gettingstarted/sybase/11.9.2.html
-%%PORTDOCS%%share/doc/sqlrelay/index.html
-%%PORTDOCS%%share/doc/sqlrelay/installing.html
-%%PORTDOCS%%share/doc/sqlrelay/introduction.html
-%%PORTDOCS%%share/doc/sqlrelay/introtowebdb.html
-%%PORTDOCS%%share/doc/sqlrelay/invisible.gif
-%%PORTDOCS%%share/doc/sqlrelay/oraclentier.html
-%%PORTDOCS%%share/doc/sqlrelay/programming/binds.html
-%%PORTDOCS%%share/doc/sqlrelay/programming/c++.html
-%%PORTDOCS%%share/doc/sqlrelay/programming/c.html
-%%PORTDOCS%%share/doc/sqlrelay/programming/java.html
-%%PORTDOCS%%share/doc/sqlrelay/programming/perl.html
-%%PORTDOCS%%share/doc/sqlrelay/programming/perldbi.html
-%%PORTDOCS%%share/doc/sqlrelay/programming/php.html
-%%PORTDOCS%%share/doc/sqlrelay/programming/python.html
-%%PORTDOCS%%share/doc/sqlrelay/programming/pythondb.html
-%%PORTDOCS%%share/doc/sqlrelay/programming/ruby.html
-%%PORTDOCS%%share/doc/sqlrelay/programming/rubydbi.html
-%%PORTDOCS%%share/doc/sqlrelay/programming/zope.html
-%%PORTDOCS%%share/doc/sqlrelay/programming/zope/instance.gif
-%%PORTDOCS%%share/doc/sqlrelay/programming/zope/management.gif
-%%PORTDOCS%%share/doc/sqlrelay/programming/zope/resultset.gif
-%%PORTDOCS%%share/doc/sqlrelay/programming/zope/sqlrelay.gif
-%%PORTDOCS%%share/doc/sqlrelay/programming/zope/test.gif
-%%PORTDOCS%%share/doc/sqlrelay/programming/zope/testzsqlmethod.gif
-%%PORTDOCS%%share/doc/sqlrelay/programming/zope/zsqlmethod.gif
-%%PORTDOCS%%share/doc/sqlrelay/programming/zope/zsqlmethodresultset.gif
-%%PORTDOCS%%share/doc/sqlrelay/running.html
-%%PORTDOCS%%@dirrm share/doc/sqlrelay/programming/zope
-%%PORTDOCS%%@dirrm share/doc/sqlrelay/programming
-%%PORTDOCS%%@dirrm share/doc/sqlrelay/gettingstarted/sybase
-%%PORTDOCS%%@dirrm share/doc/sqlrelay/gettingstarted/oracle
-%%PORTDOCS%%@dirrm share/doc/sqlrelay/gettingstarted
-%%PORTDOCS%%@dirrm share/doc/sqlrelay/css
-%%PORTDOCS%%@dirrm share/doc/sqlrelay/api/ruby
-%%PORTDOCS%%@dirrm share/doc/sqlrelay/api/python
-%%PORTDOCS%%@dirrm share/doc/sqlrelay/api/php
-%%PORTDOCS%%@dirrm share/doc/sqlrelay/api/perl
-%%PORTDOCS%%@dirrm share/doc/sqlrelay/api/java
-%%PORTDOCS%%@dirrm share/doc/sqlrelay/api/c++
-%%PORTDOCS%%@dirrm share/doc/sqlrelay/api/c
-%%PORTDOCS%%@dirrm share/doc/sqlrelay/api
-%%PORTDOCS%%@dirrm share/doc/sqlrelay
+@dirrm share/doc/sqlrelay/programming/zope
+@dirrm share/doc/sqlrelay/programming
+@dirrm share/doc/sqlrelay/gettingstarted/sybase
+@dirrm share/doc/sqlrelay/gettingstarted/oracle/linux/slackware/8
+@dirrm share/doc/sqlrelay/gettingstarted/oracle/linux/slackware/7
+@dirrm share/doc/sqlrelay/gettingstarted/oracle/linux/slackware
+@dirrm share/doc/sqlrelay/gettingstarted/oracle/linux/redhat/9
+@dirrm share/doc/sqlrelay/gettingstarted/oracle/linux/redhat/8
+@dirrm share/doc/sqlrelay/gettingstarted/oracle/linux/redhat/7
+@dirrm share/doc/sqlrelay/gettingstarted/oracle/linux/redhat/6
+@dirrm share/doc/sqlrelay/gettingstarted/oracle/linux/redhat/5
+@dirrm share/doc/sqlrelay/gettingstarted/oracle/linux/redhat
+@dirrm share/doc/sqlrelay/gettingstarted/oracle/linux
+@dirrm share/doc/sqlrelay/gettingstarted/oracle
+@dirrm share/doc/sqlrelay/gettingstarted
+@dirrm share/doc/sqlrelay/css
+@dirrm share/doc/sqlrelay/api/ruby
+@dirrm share/doc/sqlrelay/api/python
+@dirrm share/doc/sqlrelay/api/php
+@dirrm share/doc/sqlrelay/api/perl
+@dirrm share/doc/sqlrelay/api/java/com/firstworks/sqlrelay
+@dirrm share/doc/sqlrelay/api/java/com/firstworks
+@dirrm share/doc/sqlrelay/api/java/com
+@dirrm share/doc/sqlrelay/api/java
+@dirrm share/doc/sqlrelay/api/c++
+@dirrm share/doc/sqlrelay/api/c
+@dirrm share/doc/sqlrelay/api
+@dirrm share/doc/sqlrelay