aboutsummaryrefslogtreecommitdiff
path: root/databases/xmysql
diff options
context:
space:
mode:
authorDirk Froemberg <dirk@FreeBSD.org>1999-01-14 21:22:29 +0000
committerDirk Froemberg <dirk@FreeBSD.org>1999-01-14 21:22:29 +0000
commit35ba9be9a534990941acbfb19b6c347ca54c1e83 (patch)
tree30ba7104084a1f7f97c5a99e590f3d0dddde9ec4 /databases/xmysql
parent3297c2031fe84458959ab0cb49e55d049f83d4ff (diff)
downloadports-35ba9be9a534990941acbfb19b6c347ca54c1e83.tar.gz
ports-35ba9be9a534990941acbfb19b6c347ca54c1e83.zip
Change the dependencies to MySQL:
The default is mysql322 now, but take mysql321 if it is installed. (mysql321 installs a static libmysqlclient.a only, mysql322 installs a static and shared version of the library. Note that the build dependency to mysql321 is a no op actually. It is in there to improve understanding(?).)
Notes
Notes: svn path=/head/; revision=16048
Diffstat (limited to 'databases/xmysql')
-rw-r--r--databases/xmysql/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/databases/xmysql/Makefile b/databases/xmysql/Makefile
index 2c17efec87d8..3f24a4845ff0 100644
--- a/databases/xmysql/Makefile
+++ b/databases/xmysql/Makefile
@@ -3,7 +3,7 @@
# Date created: Tue Sep 2 15:46:09 CEST 1997
# Whom: Andreas Klemm <andreas@klemm.gtn.com>
#
-# $Id: Makefile,v 1.13 1998/12/27 19:30:32 dirk Exp $
+# $Id: Makefile,v 1.14 1999/01/07 08:19:26 simokawa Exp $
#
DISTNAME= xmysql-1.9
@@ -14,9 +14,13 @@ MASTER_SITES= http://www.tcx.se/Contrib/ \
MAINTAINER= andreas@FreeBSD.ORG
-BUILD_DEPENDS= mysql:${PORTSDIR}/databases/mysql321
LIB_DEPENDS= Xpm.4:${PORTSDIR}/graphics/xpm \
xforms.0:${PORTSDIR}/x11-toolkits/xforms
+.if !exists(${PREFIX}/lib/mysql/libmysqlclient.a) || exists(${PREFIX}/lib/mysql/libmysqlclient.so)
+LIB_DEPENDS+= mysqlclient.5:${PORTSDIR}/databases/mysql322
+.else
+BUILD_DEPENDS= ${PREFIX}/lib/mysql/libmysqlclient.a:${PORTSDIR}/databases/mysql321
+.endif
# depends on xforms
ONLY_FOR_ARCHS= i386