aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-03-27 09:41:44 +0000
committerJohn Marino <marino@FreeBSD.org>2014-03-27 09:41:44 +0000
commit92a3e465c389eb5b15306524fe09e719e8c2896c (patch)
tree17efb582969694a960d5f7fd7060e72c1807458f /databases
parent613e9d821af9c4e33dd2cf62b32629069697f728 (diff)
downloadports-92a3e465c389eb5b15306524fe09e719e8c2896c.tar.gz
ports-92a3e465c389eb5b15306524fe09e719e8c2896c.zip
Add new Ocaml port: databases/dbm
The initial version submitted in the PR was augmented by later changes seen in pkgsrc where the counterpart is maintained by the submitter. == This OCaml library is a binding to the NDBM/GDBM Unix "databases". It provides persistent storage of key-value pairs of strings. WWW: http://forge.ocamlcore.org/projects/camldbm/ == PR: ports/176115 Submitted by: Jaap Boender Maintainer: Jaap Boender Stage support: Taken from pkgsrc
Notes
Notes: svn path=/head/; revision=349322
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/ocaml-dbm/Makefile32
-rw-r--r--databases/ocaml-dbm/distinfo2
-rw-r--r--databases/ocaml-dbm/files/patch-META10
-rw-r--r--databases/ocaml-dbm/files/patch-Makefile27
-rw-r--r--databases/ocaml-dbm/pkg-descr4
-rw-r--r--databases/ocaml-dbm/pkg-plist11
7 files changed, 87 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 3feffc5d8a4d..567815773bb2 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -250,6 +250,7 @@
SUBDIR += nagios-check_redis
SUBDIR += namazu2
SUBDIR += ntdb
+ SUBDIR += ocaml-dbm
SUBDIR += ocaml-mysql
SUBDIR += ocaml-pgocaml
SUBDIR += ocaml-sqlite3
diff --git a/databases/ocaml-dbm/Makefile b/databases/ocaml-dbm/Makefile
new file mode 100644
index 000000000000..08988c2cc37b
--- /dev/null
+++ b/databases/ocaml-dbm/Makefile
@@ -0,0 +1,32 @@
+# Created by: Jaap Boender <jaapb@kerguelen.org>
+# $FreeBSD$
+
+PORTNAME= dbm
+PORTVERSION= 1.0
+CATEGORIES= databases
+MASTER_SITES= https://forge.ocamlcore.org/frs/download.php/728/
+PKGNAMEPREFIX= ocaml-
+DISTNAME= caml${PORTNAME}-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= jaapb@kerguelen.org
+COMMENT= OCaml binding to the NDBM and GDBM database library
+
+LICENSE= LGPL20
+
+CONFLICTS= ocaml-[0-3]* ocaml-nox11-[0-3]*
+
+HAS_CONFIGURE= yes
+USE_OCAML= yes
+DOCSDIR= ${PREFIX}/share/doc/ocaml/${PORTNAME}
+MAKE_ENV+= DESTDIR="${STAGEDIR}"
+
+pre-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/ocaml/site-lib/dbm \
+ ${STAGEDIR}${PREFIX}/lib/ocaml/stublibs
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/META \
+ ${STAGEDIR}${PREFIX}/lib/ocaml/site-lib/dbm
+
+.include <bsd.port.mk>
diff --git a/databases/ocaml-dbm/distinfo b/databases/ocaml-dbm/distinfo
new file mode 100644
index 000000000000..4e0c76d57473
--- /dev/null
+++ b/databases/ocaml-dbm/distinfo
@@ -0,0 +1,2 @@
+SHA256 (camldbm-1.0.tgz) = 19741fa7827c306ae43b18170b01f5547326ec7ea6c2f4bd80c93439b5ff538f
+SIZE (camldbm-1.0.tgz) = 14397
diff --git a/databases/ocaml-dbm/files/patch-META b/databases/ocaml-dbm/files/patch-META
new file mode 100644
index 000000000000..861715dffc1e
--- /dev/null
+++ b/databases/ocaml-dbm/files/patch-META
@@ -0,0 +1,10 @@
+$NetBSD: patch-META,v 1.1 2013/07/21 17:04:29 jaapb Exp $
+
+point to correct directory for library files
+--- META.orig 2011-11-22 15:56:49.000000000 +0000
++++ META
+@@ -3,3 +3,4 @@ requires = ""
+ version = "1.0"
+ archive(byte) = "dbm.cma"
+ archive(native) = "dbm.cmxa"
++directory = "^"
diff --git a/databases/ocaml-dbm/files/patch-Makefile b/databases/ocaml-dbm/files/patch-Makefile
new file mode 100644
index 000000000000..c1e15f46971f
--- /dev/null
+++ b/databases/ocaml-dbm/files/patch-Makefile
@@ -0,0 +1,27 @@
+$NetBSD: patch-Makefile,v 1.1 2012/12/15 10:25:52 jaapb Exp $
+
+Install into DESTDIR
+--- Makefile.orig 2011-11-22 15:56:49.000000000 +0000
++++ Makefile
+@@ -57,13 +57,14 @@ depend:
+ $(OCAMLDEP) *.ml *.mli > .depend
+
+ install::
+- if test -f dllcamldbm.$(SO); then cp dllcamldbm.$(SO) $(STUBLIBDIR)/; fi
+- cp libcamldbm.$(A) $(LIBDIR)/
+- cd $(LIBDIR) && ranlib libcamldbm.$(A)
+- cp dbm.cma dbm.cmxa dbm.cmi dbm.mli $(LIBDIR)/
+- cp dbm.$(A) $(LIBDIR)/
+- cd $(LIBDIR) && ranlib dbm.$(A)
+- if test -f dbm.cmxs; then cp dbm.cmxs $(LIBDIR)/; fi
++ if test -f dllcamldbm.$(SO); then cp dllcamldbm.$(SO) \
++ $(DESTDIR)/$(STUBLIBDIR)/; fi
++ cp libcamldbm.$(A) $(DESTDIR)/$(LIBDIR)/
++ cd $(DESTDIR)/$(LIBDIR) && ranlib libcamldbm.$(A)
++ cp dbm.cma dbm.cmxa dbm.cmi dbm.mli $(DESTDIR)/$(LIBDIR)/
++ cp dbm.$(A) $(DESTDIR)/$(LIBDIR)/
++ cd $(DESTDIR)/$(LIBDIR) && ranlib dbm.$(A)
++ if test -f dbm.cmxs; then cp dbm.cmxs $(DESTDIR)/$(LIBDIR)/; fi
+
+ clean::
+ rm -f *.cm* *.$(O) *.$(A) *.$(SO)
diff --git a/databases/ocaml-dbm/pkg-descr b/databases/ocaml-dbm/pkg-descr
new file mode 100644
index 000000000000..f395263f8b2e
--- /dev/null
+++ b/databases/ocaml-dbm/pkg-descr
@@ -0,0 +1,4 @@
+This OCaml library is a binding to the NDBM/GDBM Unix "databases". It
+provides persistent storage of key-value pairs of strings.
+
+WWW: http://forge.ocamlcore.org/projects/camldbm/
diff --git a/databases/ocaml-dbm/pkg-plist b/databases/ocaml-dbm/pkg-plist
new file mode 100644
index 000000000000..253d2ecdc947
--- /dev/null
+++ b/databases/ocaml-dbm/pkg-plist
@@ -0,0 +1,11 @@
+lib/ocaml/dbm.a
+lib/ocaml/dbm.cma
+lib/ocaml/dbm.cmi
+lib/ocaml/dbm.cmxa
+lib/ocaml/dbm.cmxs
+lib/ocaml/dbm.mli
+lib/ocaml/libcamldbm.a
+lib/ocaml/site-lib/dbm/META
+lib/ocaml/stublibs/dllcamldbm.so
+@dirrm lib/ocaml/site-lib/dbm
+@dirrmtry lib/ocaml/site-lib