aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorNikolai Lifanov <lifanov@FreeBSD.org>2017-03-12 16:44:33 +0000
committerNikolai Lifanov <lifanov@FreeBSD.org>2017-03-12 16:44:33 +0000
commit99d7fc48aab6577deee79a3ee3fce94578002529 (patch)
treebc8ef0510ed4f7a0a9a51bcb496020381a859eed /databases
parentbe5fc6964fc3cabc7240371a7a3f58061b585f5e (diff)
downloadports-99d7fc48aab6577deee79a3ee3fce94578002529.tar.gz
ports-99d7fc48aab6577deee79a3ee3fce94578002529.zip
New port: databases/phpliteadmin , web-based SQLite database admin tool written in PHP
Features Lightweight - consists of a single 200KB source file for portability Supports SQLite3 and SQLite2 databases Translated and available in over 10 languages - and counting Specify and manage an unlimited number of databases Specify a directory and optionally its subdirectories to scan for databases Create and delete databases Add, delete, rename, empty, and drop tables Browse, add, edit, and delete records Add, delete, and edit table columns Manage table indexes Manage table triggers Import and export tables, structure, indexes, and data (SQL, CSV) View data as bar, pie, and line charts Graphical search tool to find records based on specified field values Create and run your own custom SQL queries in the free-form query editor/builder Easily apply core SQLite functions to column values using the GUI Write your own PHP functions to be available to apply to column values Design your own theme using CSS or install a pre-made theme from the community All presented in an intuitive, easy-to-use GUI that allows non-technical, SQL-illiterate users to fully manage databases Allows multiple installations on the same server, each with a different password Secure password-protected interface with login screen and cookies PR: 214806 Submitted by: olevole@olevole.ru
Notes
Notes: svn path=/head/; revision=435995
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/phpliteadmin/Makefile33
-rw-r--r--databases/phpliteadmin/distinfo3
-rw-r--r--databases/phpliteadmin/files/pkg-message.in7
-rw-r--r--databases/phpliteadmin/pkg-descr19
5 files changed, 63 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index e55331243bea..2231eb131f34 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -645,6 +645,7 @@
SUBDIR += php71-pdo_sqlite
SUBDIR += php71-pgsql
SUBDIR += php71-sqlite3
+ SUBDIR += phpliteadmin
SUBDIR += phpminiadmin
SUBDIR += phpmyadmin
SUBDIR += phppgadmin
diff --git a/databases/phpliteadmin/Makefile b/databases/phpliteadmin/Makefile
new file mode 100644
index 000000000000..af17d98b9a5d
--- /dev/null
+++ b/databases/phpliteadmin/Makefile
@@ -0,0 +1,33 @@
+# Created by: olevole@olevole.ru
+# $FreeBSD$
+
+PORTNAME= phpLiteAdmin
+DISTVERSION= 1.9.7.1
+CATEGORIES= databases www
+MASTER_SITES= https://bitbucket.org/phpliteadmin/public/downloads/
+DISTNAME= ${PORTNAME}_v${DISTVERSION:S/./-/g}
+
+MAINTAINER= olevole@olevole.ru
+COMMENT= Web-based database management tool for Sqlite
+
+LICENSE= GPLv3
+
+USES= php:web zip
+
+NO_ARCH= yes
+NO_BUILD= yes
+USE_PHP= pdo_sqlite session
+
+PLIST_FILES= ${WWWDIR}/phpliteadmin.php \
+ ${WWWDIR}/phpliteadmin.config.sample.php
+
+SUB_FILES= pkg-message
+
+do-install:
+ @${MKDIR} ${STAGEDIR}/${WWWDIR}
+ ${INSTALL_DATA} ${WRKDIR}/phpliteadmin.php \
+ ${STAGEDIR}${WWWDIR}
+ ${INSTALL_DATA} ${WRKDIR}/phpliteadmin.config.sample.php \
+ ${STAGEDIR}${WWWDIR}
+
+.include <bsd.port.mk>
diff --git a/databases/phpliteadmin/distinfo b/databases/phpliteadmin/distinfo
new file mode 100644
index 000000000000..45fb69d995fd
--- /dev/null
+++ b/databases/phpliteadmin/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1488554930
+SHA256 (phpLiteAdmin_v1-9-7-1.zip) = d44e1ed5d8e6680aca97df8a406817231c05ab3484e8ced0b4e56c922e46d64d
+SIZE (phpLiteAdmin_v1-9-7-1.zip) = 54002
diff --git a/databases/phpliteadmin/files/pkg-message.in b/databases/phpliteadmin/files/pkg-message.in
new file mode 100644
index 000000000000..a69b5cee05e4
--- /dev/null
+++ b/databases/phpliteadmin/files/pkg-message.in
@@ -0,0 +1,7 @@
+
+phpliteadmin has been installed into:
+
+ %%WWWDIR%%
+
+Please copy phpliteadmin.config.sample.php to phpliteadmin.config.php and
+ edit as you needs.
diff --git a/databases/phpliteadmin/pkg-descr b/databases/phpliteadmin/pkg-descr
new file mode 100644
index 000000000000..21ea241e7604
--- /dev/null
+++ b/databases/phpliteadmin/pkg-descr
@@ -0,0 +1,19 @@
+phpLiteAdmin is a web-based SQLite database admin tool written in PHP with
+support for SQLite3 and SQLite2.
+
+Features
+
+- Lightweight - consists of a single 200KB source file for portability
+- Specify and manage an unlimited number of databases
+- Specify a directory and optionally its subdirectories to scan for databases
+- Create and delete databases
+- Add, delete, rename, empty, and drop tables
+- Browse, add, edit, and delete records
+- Add, delete, and edit table columns
+- Manage table indexes
+- Manage table triggers
+- Import and export tables, structure, indexes, and data (SQL, CSV)
+- View data as bar, pie, and line charts
+- And many other...
+
+WWW: https://www.phpliteadmin.org/