aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>2005-04-11 08:04:41 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>2005-04-11 08:04:41 +0000
commitf2fc2d60ae226a1b8d5411fb4aab91ea92be6f91 (patch)
treee9a77f53d4fe679665594e718ad34b49668507cc /databases
parent063f8ca62467e4709e58c8bb6b67c85970fe28a1 (diff)
downloadports-f2fc2d60ae226a1b8d5411fb4aab91ea92be6f91.tar.gz
ports-f2fc2d60ae226a1b8d5411fb4aab91ea92be6f91.zip
Assist getting more ports working on AMD64 by obeying the
Ports Collection documentation and use 'ARCH' rather than 'MACHINE_ARCH'.
Notes
Notes: svn path=/head/; revision=132992
Diffstat (limited to 'databases')
-rw-r--r--databases/courier-authlib-mysql/Makefile2
-rw-r--r--databases/courier-authlib-pgsql/Makefile2
-rw-r--r--databases/courier-authlib-userdb/Makefile2
-rw-r--r--databases/courier-authlib-usergdbm/Makefile2
-rw-r--r--databases/db3/Makefile2
-rw-r--r--databases/db4/Makefile2
-rw-r--r--databases/db41/Makefile2
-rw-r--r--databases/dbconnect/Makefile2
-rw-r--r--databases/fireprofile/Makefile2
-rw-r--r--databases/gdbm/Makefile2
-rw-r--r--databases/gigabase/Makefile2
-rw-r--r--databases/gnome-db/Makefile2
-rw-r--r--databases/gnomedb/Makefile2
-rw-r--r--databases/hk_classes/Makefile2
-rw-r--r--databases/knoda/Makefile2
-rw-r--r--databases/libgda/Makefile2
-rw-r--r--databases/mysql-navigator/Makefile2
-rw-r--r--databases/mysql323-server/Makefile2
-rw-r--r--databases/mysql40-server/Makefile2
-rw-r--r--databases/mysql41-server/Makefile2
-rw-r--r--databases/mysql50-server/Makefile2
-rw-r--r--databases/mysql51-server/Makefile2
-rw-r--r--databases/mysql54-server/Makefile2
-rw-r--r--databases/mysql55-server/Makefile2
-rw-r--r--databases/mysql60-server/Makefile2
-rw-r--r--databases/percona55-server/Makefile2
-rw-r--r--databases/rrdtool/Makefile2
-rw-r--r--databases/rrdtool10/Makefile2
-rw-r--r--databases/sqlite2/Makefile2
-rw-r--r--databases/sqlite3/Makefile2
-rw-r--r--databases/sqlite34/Makefile2
-rw-r--r--databases/sqlrelay/Makefile2
-rw-r--r--databases/xbsql/Makefile2
33 files changed, 33 insertions, 33 deletions
diff --git a/databases/courier-authlib-mysql/Makefile b/databases/courier-authlib-mysql/Makefile
index 902b25be6031..96eb0a2976ab 100644
--- a/databases/courier-authlib-mysql/Makefile
+++ b/databases/courier-authlib-mysql/Makefile
@@ -55,7 +55,7 @@ CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
CXXFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
LIBS="${LDFLAGS} -L${LOCALBASE}/lib"
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --sysconfdir=${CONFDIR} \
--without-authshadow \
--without-authcustom \
diff --git a/databases/courier-authlib-pgsql/Makefile b/databases/courier-authlib-pgsql/Makefile
index 902b25be6031..96eb0a2976ab 100644
--- a/databases/courier-authlib-pgsql/Makefile
+++ b/databases/courier-authlib-pgsql/Makefile
@@ -55,7 +55,7 @@ CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
CXXFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
LIBS="${LDFLAGS} -L${LOCALBASE}/lib"
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --sysconfdir=${CONFDIR} \
--without-authshadow \
--without-authcustom \
diff --git a/databases/courier-authlib-userdb/Makefile b/databases/courier-authlib-userdb/Makefile
index 902b25be6031..96eb0a2976ab 100644
--- a/databases/courier-authlib-userdb/Makefile
+++ b/databases/courier-authlib-userdb/Makefile
@@ -55,7 +55,7 @@ CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
CXXFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
LIBS="${LDFLAGS} -L${LOCALBASE}/lib"
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --sysconfdir=${CONFDIR} \
--without-authshadow \
--without-authcustom \
diff --git a/databases/courier-authlib-usergdbm/Makefile b/databases/courier-authlib-usergdbm/Makefile
index 902b25be6031..96eb0a2976ab 100644
--- a/databases/courier-authlib-usergdbm/Makefile
+++ b/databases/courier-authlib-usergdbm/Makefile
@@ -55,7 +55,7 @@ CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
CXXFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
LIBS="${LDFLAGS} -L${LOCALBASE}/lib"
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --sysconfdir=${CONFDIR} \
--without-authshadow \
--without-authcustom \
diff --git a/databases/db3/Makefile b/databases/db3/Makefile
index 1e189ac6f3f5..66a63c97e59b 100644
--- a/databases/db3/Makefile
+++ b/databases/db3/Makefile
@@ -33,7 +33,7 @@ CONFIGURE_ARGS= --enable-compat185 \
--enable-dynamic \
--prefix=${PREFIX} \
--includedir=${PREFIX}/include/db3
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
INSTALL_TARGET= install_include install_lib install_utilities
.if !defined(NOPORTDOCS)
INSTALL_TARGET+= install_docs docdir=${DOCSDIR}
diff --git a/databases/db4/Makefile b/databases/db4/Makefile
index fed7092819e9..427d069268b4 100644
--- a/databases/db4/Makefile
+++ b/databases/db4/Makefile
@@ -22,7 +22,7 @@ WRKSRC= ${WRKDIR}/${DISTNAME}/build_unix
USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_SCRIPT= ../dist/configure
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --enable-compat185 --enable-dump185 \
--enable-cxx --enable-dynamic \
--includedir=${PREFIX}/include/db4
diff --git a/databases/db41/Makefile b/databases/db41/Makefile
index 49767b36f05d..b0864665bf9a 100644
--- a/databases/db41/Makefile
+++ b/databases/db41/Makefile
@@ -26,7 +26,7 @@ WRKSRC= ${WRKDIR}/${DISTNAME}/build_unix
USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_SCRIPT= ../dist/configure
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --enable-compat185 --enable-dump185 \
--enable-cxx --enable-dynamic \
--includedir=${PREFIX}/include/db41
diff --git a/databases/dbconnect/Makefile b/databases/dbconnect/Makefile
index ea3d5ac9aeaf..f89801d2cbe5 100644
--- a/databases/dbconnect/Makefile
+++ b/databases/dbconnect/Makefile
@@ -18,7 +18,7 @@ COMMENT= Use C++ object API to allow applications to connect to databases
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_AUTOCONF_VER= 259
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
INSTALLS_SHLIB= yes
CXXFLAGS+= ${PTHREAD_CFLAGS} -fPIC -DFREEBSD
diff --git a/databases/fireprofile/Makefile b/databases/fireprofile/Makefile
index 02293275ae6c..b76a3f4d6fa2 100644
--- a/databases/fireprofile/Makefile
+++ b/databases/fireprofile/Makefile
@@ -29,7 +29,7 @@ WANT_MYSQL_VER= 323
post-install:
$(LN) ${PREFIX}/lib/libfireprofile.so ${PREFIX}/lib/libfireprofile.so.0
-.if ${MACHINE_ARCH:L} == amd64
+.if ${ARCH:L} == amd64
CFLAGS+= -fPIC
.endif
.include <bsd.port.mk>
diff --git a/databases/gdbm/Makefile b/databases/gdbm/Makefile
index b150bab27b24..122f10341572 100644
--- a/databases/gdbm/Makefile
+++ b/databases/gdbm/Makefile
@@ -17,7 +17,7 @@ COMMENT= The GNU database manager
USE_GMAKE= yes
USE_INC_LIBTOOL_VER= 13
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
INSTALLS_SHLIB= yes
.if defined(WITH_COMPAT)
diff --git a/databases/gigabase/Makefile b/databases/gigabase/Makefile
index 05dd6e2953d0..50ae608c469d 100644
--- a/databases/gigabase/Makefile
+++ b/databases/gigabase/Makefile
@@ -17,7 +17,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
USE_GMAKE= yes
USE_LIBTOOL_VER= 15
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS?=--prefix=${LOCALBASE}
CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS}" LDFLAGS="${PTHREAD_LIBS}"
INSTALLS_SHLIB= yes
diff --git a/databases/gnome-db/Makefile b/databases/gnome-db/Makefile
index 385a1d093608..cb0522d38b06 100644
--- a/databases/gnome-db/Makefile
+++ b/databases/gnome-db/Makefile
@@ -25,7 +25,7 @@ USE_INC_LIBTOOL_VER= 13
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="${PTHREAD_LIBS} -L${LOCALBASE}/lib -lintl"
-CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
+CONFIGURE_TARGET= --target=${ARCH}-unknown-freebsd${OSREL}
PLIST_SUB= VERSION=${PORTVERSION}
.include <bsd.port.mk>
diff --git a/databases/gnomedb/Makefile b/databases/gnomedb/Makefile
index 385a1d093608..cb0522d38b06 100644
--- a/databases/gnomedb/Makefile
+++ b/databases/gnomedb/Makefile
@@ -25,7 +25,7 @@ USE_INC_LIBTOOL_VER= 13
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="${PTHREAD_LIBS} -L${LOCALBASE}/lib -lintl"
-CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
+CONFIGURE_TARGET= --target=${ARCH}-unknown-freebsd${OSREL}
PLIST_SUB= VERSION=${PORTVERSION}
.include <bsd.port.mk>
diff --git a/databases/hk_classes/Makefile b/databases/hk_classes/Makefile
index e854530f2efa..5efae94e6656 100644
--- a/databases/hk_classes/Makefile
+++ b/databases/hk_classes/Makefile
@@ -23,7 +23,7 @@ USE_PYTHON= yes
CXXFLAGS+= ${PTHREAD_CFLAGS}
CONFIGURE_ENV+= LIBPYTHON="-l${PYTHON_VERSION} ${PTHREAD_LIBS}" \
LDFLAGS="${PTHREAD_LIBS} -largp -L${LOCALBASE}/lib"
-CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET=--build=${ARCH}-portbld-freebsd${OSREL}
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
USE_LIBTOOL_VER= 15
diff --git a/databases/knoda/Makefile b/databases/knoda/Makefile
index 18da2b219634..619ff12bc63b 100644
--- a/databases/knoda/Makefile
+++ b/databases/knoda/Makefile
@@ -25,7 +25,7 @@ INSTALLS_SHLIB= yes
USE_INC_LIBTOOL_VER= 13
USE_REINPLACE= yes
CONFIGURE_TARGET=
-CONFIGURE_ARGS+= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL} \
+CONFIGURE_ARGS+= --build=${ARCH}-portbld-freebsd${OSREL} \
--with-hk_classes-dir=${LOCALBASE}/lib/hk_classes \
--with-hk_classes-incdir=${LOCALBASE}/include/hk_classes
diff --git a/databases/libgda/Makefile b/databases/libgda/Makefile
index 2d79d522a229..967a41795679 100644
--- a/databases/libgda/Makefile
+++ b/databases/libgda/Makefile
@@ -28,7 +28,7 @@ USE_INC_LIBTOOL_VER= 13
CONFIGURE_ARGS= --disable-gtk-doc
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib -lintl -lgdbm"
-CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
+CONFIGURE_TARGET= --target=${ARCH}-unknown-freebsd${OSREL}
PLIST_SUB= VERSION=${PORTVERSION}
post-patch:
diff --git a/databases/mysql-navigator/Makefile b/databases/mysql-navigator/Makefile
index 2e1df2a8777d..39eb4034207d 100644
--- a/databases/mysql-navigator/Makefile
+++ b/databases/mysql-navigator/Makefile
@@ -25,7 +25,7 @@ GNU_CONFIGURE= yes
USE_REINPLACE= yes
CONFIGURE_ARGS+=--with-mysql-includes=${LOCALBASE}/include/mysql \
--with-mysql-libraries=${LOCALBASE}/lib/mysql
-CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET=--build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV+= MOC="${MOC}" QTDIR="${X11BASE}"
MAKE_ENV+= MOC="${MOC}" QTDIR="${X11BASE}"
diff --git a/databases/mysql323-server/Makefile b/databases/mysql323-server/Makefile
index c43f33808ccf..8dd404b6dc43 100644
--- a/databases/mysql323-server/Makefile
+++ b/databases/mysql323-server/Makefile
@@ -24,7 +24,7 @@ USE_REINPLACE= yes
USE_RC_SUBR= mysql-server.sh
.endif
-CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET=--build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --localstatedir=/var/db/mysql \
--without-debug \
--without-readline \
diff --git a/databases/mysql40-server/Makefile b/databases/mysql40-server/Makefile
index 0af62dba291f..6d57034b63e4 100644
--- a/databases/mysql40-server/Makefile
+++ b/databases/mysql40-server/Makefile
@@ -24,7 +24,7 @@ USE_REINPLACE= yes
USE_RC_SUBR= mysql-server.sh
.endif
-CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET=--build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --localstatedir=/var/db/mysql \
--without-debug \
--without-readline \
diff --git a/databases/mysql41-server/Makefile b/databases/mysql41-server/Makefile
index eb3cb05bfc40..f9c224f7166d 100644
--- a/databases/mysql41-server/Makefile
+++ b/databases/mysql41-server/Makefile
@@ -24,7 +24,7 @@ USE_REINPLACE= yes
USE_RC_SUBR= mysql-server.sh
.endif
-CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET=--build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --localstatedir=/var/db/mysql \
--without-debug \
--without-readline \
diff --git a/databases/mysql50-server/Makefile b/databases/mysql50-server/Makefile
index a40f9be8d2a7..4ba0f5b35d05 100644
--- a/databases/mysql50-server/Makefile
+++ b/databases/mysql50-server/Makefile
@@ -26,7 +26,7 @@ USE_REINPLACE= yes
USE_RC_SUBR= mysql-server.sh
.endif
-CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET=--build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --localstatedir=/var/db/mysql \
--without-debug \
--without-readline \
diff --git a/databases/mysql51-server/Makefile b/databases/mysql51-server/Makefile
index a40f9be8d2a7..4ba0f5b35d05 100644
--- a/databases/mysql51-server/Makefile
+++ b/databases/mysql51-server/Makefile
@@ -26,7 +26,7 @@ USE_REINPLACE= yes
USE_RC_SUBR= mysql-server.sh
.endif
-CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET=--build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --localstatedir=/var/db/mysql \
--without-debug \
--without-readline \
diff --git a/databases/mysql54-server/Makefile b/databases/mysql54-server/Makefile
index a40f9be8d2a7..4ba0f5b35d05 100644
--- a/databases/mysql54-server/Makefile
+++ b/databases/mysql54-server/Makefile
@@ -26,7 +26,7 @@ USE_REINPLACE= yes
USE_RC_SUBR= mysql-server.sh
.endif
-CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET=--build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --localstatedir=/var/db/mysql \
--without-debug \
--without-readline \
diff --git a/databases/mysql55-server/Makefile b/databases/mysql55-server/Makefile
index a40f9be8d2a7..4ba0f5b35d05 100644
--- a/databases/mysql55-server/Makefile
+++ b/databases/mysql55-server/Makefile
@@ -26,7 +26,7 @@ USE_REINPLACE= yes
USE_RC_SUBR= mysql-server.sh
.endif
-CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET=--build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --localstatedir=/var/db/mysql \
--without-debug \
--without-readline \
diff --git a/databases/mysql60-server/Makefile b/databases/mysql60-server/Makefile
index a40f9be8d2a7..4ba0f5b35d05 100644
--- a/databases/mysql60-server/Makefile
+++ b/databases/mysql60-server/Makefile
@@ -26,7 +26,7 @@ USE_REINPLACE= yes
USE_RC_SUBR= mysql-server.sh
.endif
-CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET=--build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --localstatedir=/var/db/mysql \
--without-debug \
--without-readline \
diff --git a/databases/percona55-server/Makefile b/databases/percona55-server/Makefile
index a40f9be8d2a7..4ba0f5b35d05 100644
--- a/databases/percona55-server/Makefile
+++ b/databases/percona55-server/Makefile
@@ -26,7 +26,7 @@ USE_REINPLACE= yes
USE_RC_SUBR= mysql-server.sh
.endif
-CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET=--build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --localstatedir=/var/db/mysql \
--without-debug \
--without-readline \
diff --git a/databases/rrdtool/Makefile b/databases/rrdtool/Makefile
index 501cf6d0ebba..fda0e1a848d8 100644
--- a/databases/rrdtool/Makefile
+++ b/databases/rrdtool/Makefile
@@ -23,7 +23,7 @@ INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --enable-shared --enable-local-zlib \
--program-transform-name=''
CONFIGURE_ENV= PERL=${PERL}
-CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET=--build=${ARCH}-portbld-freebsd${OSREL}
CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib -fPIC
LDFLAGS+= -L${LOCALBASE}/lib
CFLAGS:= ${CFLAGS:N-ffast-math}
diff --git a/databases/rrdtool10/Makefile b/databases/rrdtool10/Makefile
index 501cf6d0ebba..fda0e1a848d8 100644
--- a/databases/rrdtool10/Makefile
+++ b/databases/rrdtool10/Makefile
@@ -23,7 +23,7 @@ INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --enable-shared --enable-local-zlib \
--program-transform-name=''
CONFIGURE_ENV= PERL=${PERL}
-CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET=--build=${ARCH}-portbld-freebsd${OSREL}
CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib -fPIC
LDFLAGS+= -L${LOCALBASE}/lib
CFLAGS:= ${CFLAGS:N-ffast-math}
diff --git a/databases/sqlite2/Makefile b/databases/sqlite2/Makefile
index 41e56068643e..659acd84cb8c 100644
--- a/databases/sqlite2/Makefile
+++ b/databases/sqlite2/Makefile
@@ -60,7 +60,7 @@ USE_LIBTOOL_VER= 13
GNU_CONFIGURE= YES
USE_REINPLACE= YES
CONFIGURE_ARGS= --prefix=${PREFIX} --with-hints=freebsd.hints
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
ALL_TARGET= all
#.if defined(WITH_TCL)
#ALL_TARGET+= libtclsqlite.la
diff --git a/databases/sqlite3/Makefile b/databases/sqlite3/Makefile
index 5e887bc8ddba..a0ba5c2e77a5 100644
--- a/databases/sqlite3/Makefile
+++ b/databases/sqlite3/Makefile
@@ -54,7 +54,7 @@ USE_LIBTOOL_VER= 13
GNU_CONFIGURE= YES
USE_REINPLACE= YES
CONFIGURE_ARGS= --prefix=${PREFIX} --with-hints=freebsd.hints
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
ALL_TARGET= all
INSTALLS_SHLIB= YES
diff --git a/databases/sqlite34/Makefile b/databases/sqlite34/Makefile
index 5e887bc8ddba..a0ba5c2e77a5 100644
--- a/databases/sqlite34/Makefile
+++ b/databases/sqlite34/Makefile
@@ -54,7 +54,7 @@ USE_LIBTOOL_VER= 13
GNU_CONFIGURE= YES
USE_REINPLACE= YES
CONFIGURE_ARGS= --prefix=${PREFIX} --with-hints=freebsd.hints
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
ALL_TARGET= all
INSTALLS_SHLIB= YES
diff --git a/databases/sqlrelay/Makefile b/databases/sqlrelay/Makefile
index b41525043f4e..e6661e2b8013 100644
--- a/databases/sqlrelay/Makefile
+++ b/databases/sqlrelay/Makefile
@@ -31,7 +31,7 @@ CONFIGURE_ARGS= ${SQLRELAY_CONFIGURE_ARGS} \
--disable-python \
--disable-ruby \
--disable-zope
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
INSTALLS_SHLIB= yes
.include "${.CURDIR}/Makefile.common"
diff --git a/databases/xbsql/Makefile b/databases/xbsql/Makefile
index d4eef2874089..23fd9f9e11a6 100644
--- a/databases/xbsql/Makefile
+++ b/databases/xbsql/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= xbase-2.0.0:${PORTSDIR}/databases/xbase
USE_BISON= yes
USE_INC_LIBTOOL_VER= 13
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
INSTALLS_SHLIB= yes
USE_REINPLACE= yes