aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2005-05-17 16:09:29 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2005-05-17 16:09:29 +0000
commit913cb3ae08e2bb3058572039ad7a1adcead8df3a (patch)
tree4421d0af7029c63503917d9f0a75946fb3005826 /databases
parent3c81cc0a137500dc746a0b4409361cd185dbdf2a (diff)
downloadports-913cb3ae08e2bb3058572039ad7a1adcead8df3a.tar.gz
ports-913cb3ae08e2bb3058572039ad7a1adcead8df3a.zip
- Fix after spliting firebird
- Bump PORTREVISION PR: ports/79337 Submitted by: Renato Botelho <freebsd@galle.com.br> (firebird maintainer)
Notes
Notes: svn path=/head/; revision=135485
Diffstat (limited to 'databases')
-rw-r--r--databases/clip/Makefile3
-rw-r--r--databases/clip/files/patch-cliplibs::clip-interbase::Makefile2
-rw-r--r--databases/kinterbasdb/Makefile4
-rw-r--r--databases/kinterbasdb/files/patch-setup.py11
-rw-r--r--databases/p5-DBD-InterBase/Makefile6
-rw-r--r--databases/qt-ibase-plugin/Makefile3
-rw-r--r--databases/qt-ibase-plugin/files/Makefile.bsd3
-rw-r--r--databases/ruby-interbase/Makefile7
-rw-r--r--databases/sqlrelay/Makefile5
9 files changed, 29 insertions, 15 deletions
diff --git a/databases/clip/Makefile b/databases/clip/Makefile
index 5ba91557dba0..bb617509490f 100644
--- a/databases/clip/Makefile
+++ b/databases/clip/Makefile
@@ -7,6 +7,7 @@
PORTNAME= clip
PORTVERSION= 1.1.14.1
+PORTREVISION= 1
CATEGORIES= databases lang
MASTER_SITES= ftp://ftp.itk.ru/pub/clip/ \
ftp://ftp.linux.ru.net/mirrors/clip/
@@ -112,7 +113,7 @@ MAKE_ENV= HOME="${WRKDIR}" \
PKGMESSAGE= ${WRKDIR}/pkg-message
-FIREBIRD_PORT?= databases/firebird
+FIREBIRD_PORT?= databases/firebird-client
BIN2STRIP= bdbf clip clip_bl clip_blank clip_cld clip_conv clip_dbf2txt \
clip_dbg clip_fl clip_hashextract clip_hindex clip_hseek \
diff --git a/databases/clip/files/patch-cliplibs::clip-interbase::Makefile b/databases/clip/files/patch-cliplibs::clip-interbase::Makefile
index df2b325516c5..38aaf4e15eff 100644
--- a/databases/clip/files/patch-cliplibs::clip-interbase::Makefile
+++ b/databases/clip/files/patch-cliplibs::clip-interbase::Makefile
@@ -5,7 +5,7 @@
#
-IBROOT=/opt/interbase
-+IBROOT=/usr/local/firebird
++IBROOT=/usr/local
ifdef CLIPROOT
include $(CLIPROOT)/include/Makefile.inc
diff --git a/databases/kinterbasdb/Makefile b/databases/kinterbasdb/Makefile
index d9f4a3c1988a..255999984b25 100644
--- a/databases/kinterbasdb/Makefile
+++ b/databases/kinterbasdb/Makefile
@@ -7,7 +7,7 @@
PORTNAME= kinterbasdb
PORTVERSION= 3.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= databases python
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= kinterbasdb
@@ -17,7 +17,7 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}.src
MAINTAINER= rud@cs.uni-magdeburg.de
COMMENT= Python extension for Firebird/Interbase(R) relational databases
-LIB_DEPENDS= gds.1:${PORTSDIR}/databases/firebird
+LIB_DEPENDS= gds.1:${PORTSDIR}/databases/firebird-client
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/mx/DateTime/__init__.py:${PORTSDIR}/lang/py-mx-base
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
diff --git a/databases/kinterbasdb/files/patch-setup.py b/databases/kinterbasdb/files/patch-setup.py
new file mode 100644
index 000000000000..6cd289f3db77
--- /dev/null
+++ b/databases/kinterbasdb/files/patch-setup.py
@@ -0,0 +1,11 @@
+--- setup.py.orig Sun May 15 10:11:47 2005
++++ setup.py Sun May 15 10:12:02 2005
+@@ -834,7 +834,7 @@
+ #
+ # This "autodetection" will probably work for some other Unixes as well.
+ if not DATABASE_HOME_DIR:
+- DEFAULT_FREEBSD_HOME_DIR = '/usr/local/firebird'
++ DEFAULT_FREEBSD_HOME_DIR = '/usr/local'
+ if os.path.isdir(DEFAULT_FREEBSD_HOME_DIR):
+ DATABASE_HOME_DIR = DEFAULT_FREEBSD_HOME_DIR
+ if not DATABASE_INCLUDE_DIR:
diff --git a/databases/p5-DBD-InterBase/Makefile b/databases/p5-DBD-InterBase/Makefile
index 80fc48c3164e..522dfc4990fa 100644
--- a/databases/p5-DBD-InterBase/Makefile
+++ b/databases/p5-DBD-InterBase/Makefile
@@ -7,7 +7,7 @@
PORTNAME= DBD-InterBase
PORTVERSION= 0.43
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= databases perl5
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= dbi-interbase
@@ -16,12 +16,12 @@ PKGNAMEPREFIX= p5-
MAINTAINER= skv@FreeBSD.org
COMMENT= DBI driver for InterBase RDBMS server
-LIB_DEPENDS= gds:${PORTSDIR}/databases/firebird
+LIB_DEPENDS= gds:${PORTSDIR}/databases/firebird-client
PERL_CONFIGURE= yes
post-patch:
- @${PERL} -pi -e 's,%%IB_BASE%%,${PREFIX}/firebird,g' \
+ @${PERL} -pi -e 's,%%IB_BASE%%,${LOCALBASE},g' \
${WRKSRC}/Makefile.PL
MAN3= Bundle::DBD::InterBase.3 DBD::InterBase.3 DBD::InterBase::FAQ.3
diff --git a/databases/qt-ibase-plugin/Makefile b/databases/qt-ibase-plugin/Makefile
index 0dbfe03c4bbd..098356af050a 100644
--- a/databases/qt-ibase-plugin/Makefile
+++ b/databases/qt-ibase-plugin/Makefile
@@ -8,6 +8,7 @@
PORTNAME= qt-${DB}-plugin
PORTVERSION= 3.3.4
+PORTREVISION= 1
CATEGORIES= databases
MASTER_SITES= ${MASTER_SITE_QT}
DISTNAME= qt-x11-free-${PORTVERSION}
@@ -18,7 +19,7 @@ COMMENT= A plugin for QT to connect to IBase/Firebird-Databases
DB= ibase
-LIB_DEPENDS+= gds:${PORTSDIR}/databases/firebird \
+LIB_DEPENDS+= gds:${PORTSDIR}/databases/firebird-client \
qt-mt:${PORTSDIR}/x11-toolkits/qt33
USE_BZIP2= yes
diff --git a/databases/qt-ibase-plugin/files/Makefile.bsd b/databases/qt-ibase-plugin/files/Makefile.bsd
index 6ad2389a0275..84998a7f5f48 100644
--- a/databases/qt-ibase-plugin/files/Makefile.bsd
+++ b/databases/qt-ibase-plugin/files/Makefile.bsd
@@ -2,10 +2,9 @@ SHLIB_NAME= libqsql${DB}.so
VPATH= ${PLUGIN}:${DRIVER}
CXXFLAGS+= -I${PLUGIN} -I${DRIVER} \
- -I${LOCALBASE}/firebird/include \
-I${LOCALBASE}/include -I${X11BASE}/include \
${PTHREAD_CFLAGS} -DQT_THREAD_SUPPORT
-LDADD= -L${X11BASE}/lib -L${LOCALBASE}/firebird/lib ${PTHREAD_LIBS} -lqt-mt -lgds
+LDADD= -L${X11BASE}/lib -L${LOCALBASE}/lib ${PTHREAD_LIBS} -lqt-mt -lgds
SRCS= qsql_${DB}.cpp main.cpp
LIBDIR= ${PREFIX}/lib/plugins/sqldrivers
diff --git a/databases/ruby-interbase/Makefile b/databases/ruby-interbase/Makefile
index 35de95e01cc5..ce0360c149fd 100644
--- a/databases/ruby-interbase/Makefile
+++ b/databases/ruby-interbase/Makefile
@@ -7,6 +7,7 @@
PORTNAME= interbase
PORTVERSION= 0.05
+PORTREVISION= 1
CATEGORIES= databases ruby
MASTER_SITES= http://www.rowlandresearch.com/ruby/
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
@@ -15,15 +16,15 @@ DIST_SUBDIR= ruby
MAINTAINER= skv@FreeBSD.org
COMMENT= Ruby interface to Interbase library
-LIB_DEPENDS= gds:${PORTSDIR}/databases/firebird
+LIB_DEPENDS= gds:${PORTSDIR}/databases/firebird-client
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
-CONFIGURE_ARGS= --with-interbase-include-dir="${LOCALBASE}/firebird/include" \
- --with-interbase-lib-dir="${LOCALBASE}/firebird/lib"
+CONFIGURE_ARGS= --with-interbase-include-dir="${LOCALBASE}/include" \
+ --with-interbase-lib-dir="${LOCALBASE}/lib"
INSTALL_TARGET= site-install
DOCS_EN= README
diff --git a/databases/sqlrelay/Makefile b/databases/sqlrelay/Makefile
index ee30c1743fbf..efc035a0ca51 100644
--- a/databases/sqlrelay/Makefile
+++ b/databases/sqlrelay/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ${SQLRELAY_PORTNAME}
PORTVERSION= ${SQLRELAY_PORTVERSION}
+PORTREVISION= 1
CATEGORIES= databases
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= sqlrelay
@@ -68,8 +69,8 @@ IF_MYSQL= "@comment "
.endif
.if defined(WITH_INTERBASE) && ${WITH_INTERBASE:L} != no
-LIB_DEPENDS+= gds.1:${PORTSDIR}/databases/firebird
-CONFIGURE_ARGS+= --with-interbase-prefix="${LOCALBASE}/firebird"
+LIB_DEPENDS+= gds.1:${PORTSDIR}/databases/firebird-client
+CONFIGURE_ARGS+= --with-interbase-prefix="${LOCALBASE}"
IF_INTERBASE= ""
.else
CONFIGURE_ARGS+= --disable-interbase