aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2010-11-26 09:35:56 +0000
committerAlex Dupre <ale@FreeBSD.org>2010-11-26 09:35:56 +0000
commitb5e3d79bde91ce403f620704b47ab5b5d2c2ddbb (patch)
tree18aaef115e43d444571cd899e175569e86bc6ec8 /databases
parent29a77bfafc40194ba8ff11eb281c32b69cb27e62 (diff)
downloadports-b5e3d79bde91ce403f620704b47ab5b5d2c2ddbb.tar.gz
ports-b5e3d79bde91ce403f620704b47ab5b5d2c2ddbb.zip
Allow to enable userland dtrace only on supported FreeBSD versions.
PR: ports/152590 Submitted by: Sevan Janiyan <venture37@geeklan.co.uk>
Notes
Notes: svn path=/head/; revision=265171
Diffstat (limited to 'databases')
-rw-r--r--databases/mysql55-server/Makefile15
-rw-r--r--databases/percona55-server/Makefile15
2 files changed, 18 insertions, 12 deletions
diff --git a/databases/mysql55-server/Makefile b/databases/mysql55-server/Makefile
index fca5cde888bc..e1c2da06c88d 100644
--- a/databases/mysql55-server/Makefile
+++ b/databases/mysql55-server/Makefile
@@ -44,12 +44,6 @@ CONFIGURE_ARGS+=--with-charset=${WITH_CHARSET}
.if defined(WITH_XCHARSET) && ${WITH_XCHARSET} != ""
CONFIGURE_ARGS+=--with-extra-charsets=${WITH_XCHARSET}
.endif
-.if defined(WITH_DTRACE)
-CONFIGURE_ARGS+=--enable-dtrace
-CONFIGURE_ENV+= LDFLAGS=-lelf
-.else
-CONFIGURE_ARGS+=--disable-dtrace
-.endif
.if defined(WITH_OPENSSL)
.if !defined(WITHOUT_YASSL)
CONFIGURE_ARGS+=--with-ssl=bundled
@@ -73,6 +67,13 @@ CONFIGURE_ARGS+=--with-collation=${WITH_COLLATION}
.include <bsd.port.pre.mk>
+.if defined(WITH_DTRACE) && ${OSVERSION} >= 900021
+CONFIGURE_ARGS+=--enable-dtrace
+CONFIGURE_ENV+= LDFLAGS=-lelf
+.else
+CONFIGURE_ARGS+=--disable-dtrace
+.endif
+
.if ${ARCH} == "i386"
CONFIGURE_ARGS+=--enable-assembler
.endif
@@ -132,7 +133,9 @@ pre-fetch:
@${ECHO} " WITH_CHARSET=charset Define the primary built-in charset (latin1)."
@${ECHO} " WITH_XCHARSET=list Define other built-in charsets (may be 'all')."
@${ECHO} " WITH_COLLATION=collate Define default collation (latin1_swedish_ci)."
+.if ${OSVERSION} >= 900021
@${ECHO} " WITH_DTRACE=yes Enable DTrace."
+.endif
@${ECHO} " WITH_OPENSSL=yes Enable secure connections"
@${ECHO} " (define WITHOUT_YASSL for backward compatibility)."
@${ECHO} " WITH_LINUXTHREADS=yes Use the linuxthreads pthread library."
diff --git a/databases/percona55-server/Makefile b/databases/percona55-server/Makefile
index fca5cde888bc..e1c2da06c88d 100644
--- a/databases/percona55-server/Makefile
+++ b/databases/percona55-server/Makefile
@@ -44,12 +44,6 @@ CONFIGURE_ARGS+=--with-charset=${WITH_CHARSET}
.if defined(WITH_XCHARSET) && ${WITH_XCHARSET} != ""
CONFIGURE_ARGS+=--with-extra-charsets=${WITH_XCHARSET}
.endif
-.if defined(WITH_DTRACE)
-CONFIGURE_ARGS+=--enable-dtrace
-CONFIGURE_ENV+= LDFLAGS=-lelf
-.else
-CONFIGURE_ARGS+=--disable-dtrace
-.endif
.if defined(WITH_OPENSSL)
.if !defined(WITHOUT_YASSL)
CONFIGURE_ARGS+=--with-ssl=bundled
@@ -73,6 +67,13 @@ CONFIGURE_ARGS+=--with-collation=${WITH_COLLATION}
.include <bsd.port.pre.mk>
+.if defined(WITH_DTRACE) && ${OSVERSION} >= 900021
+CONFIGURE_ARGS+=--enable-dtrace
+CONFIGURE_ENV+= LDFLAGS=-lelf
+.else
+CONFIGURE_ARGS+=--disable-dtrace
+.endif
+
.if ${ARCH} == "i386"
CONFIGURE_ARGS+=--enable-assembler
.endif
@@ -132,7 +133,9 @@ pre-fetch:
@${ECHO} " WITH_CHARSET=charset Define the primary built-in charset (latin1)."
@${ECHO} " WITH_XCHARSET=list Define other built-in charsets (may be 'all')."
@${ECHO} " WITH_COLLATION=collate Define default collation (latin1_swedish_ci)."
+.if ${OSVERSION} >= 900021
@${ECHO} " WITH_DTRACE=yes Enable DTrace."
+.endif
@${ECHO} " WITH_OPENSSL=yes Enable secure connections"
@${ECHO} " (define WITHOUT_YASSL for backward compatibility)."
@${ECHO} " WITH_LINUXTHREADS=yes Use the linuxthreads pthread library."