aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-03-15 17:11:18 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-03-15 17:11:18 +0000
commit21e82a3c446acacb93d223b4c0fa263dcbd18d4d (patch)
tree5989b27153cc51f6aa90605cc9530bd0b9d5f241 /databases
parent8e4871b7715fec786c17b264b172326c9f7142eb (diff)
downloadports-21e82a3c446acacb93d223b4c0fa263dcbd18d4d.tar.gz
ports-21e82a3c446acacb93d223b4c0fa263dcbd18d4d.zip
ORLite is an object-relation system specifically tailored for SQLite that
follows many of the same principles as the ::Tiny series of modules and has a design and feature set that aligns directly to the capabilities of SQLite. WWW: http://search.cpan.org/dist/ORLite/ PR: ports/132406 Submitted by: Cezary Morga <cm at therek.net>
Notes
Notes: svn path=/head/; revision=230131
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/p5-ORLite/Makefile27
-rw-r--r--databases/p5-ORLite/distinfo3
-rw-r--r--databases/p5-ORLite/pkg-descr5
-rw-r--r--databases/p5-ORLite/pkg-plist3
5 files changed, 39 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 4acce69c714f..511460a0f46f 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -340,6 +340,7 @@
SUBDIR += p5-Metadata
SUBDIR += p5-Mysql
SUBDIR += p5-Mysql-Diff
+ SUBDIR += p5-ORLite
SUBDIR += p5-ORLite-Migrate
SUBDIR += p5-Oryx
SUBDIR += p5-POE-Component-DBIAgent
diff --git a/databases/p5-ORLite/Makefile b/databases/p5-ORLite/Makefile
new file mode 100644
index 000000000000..b54c8bd9ad94
--- /dev/null
+++ b/databases/p5-ORLite/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-ORLite
+# Date created: March 8th 2009
+# Whom: Cezary Morga <cm@therek.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ORLite
+PORTVERSION= 1.20
+CATEGORIES= databases perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../by-authors/id/A/AD/ADAMK
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= cm@therek.net
+COMMENT= Perl5 extremely light weight SQLite-specific ORM
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
+ ${SITE_PERL}/${PERL_ARCH}/DBD/SQLite.pm:${PORTSDIR}/databases/p5-DBD-SQLite \
+ ${SITE_PERL}/${PERL_ARCH}/Params/Util.pm:${PORTSDIR}/devel/p5-Params-Util
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= YES
+
+MAN3= ORLite.3
+
+.include <bsd.port.mk>
diff --git a/databases/p5-ORLite/distinfo b/databases/p5-ORLite/distinfo
new file mode 100644
index 000000000000..e0d66141909c
--- /dev/null
+++ b/databases/p5-ORLite/distinfo
@@ -0,0 +1,3 @@
+MD5 (ORLite-1.20.tar.gz) = 680b3266dfa55f023329b2f7bec30d7e
+SHA256 (ORLite-1.20.tar.gz) = ff3716d8dba6388539245c9c1c29d3ba41fa0dec93ca8a3d62d9b33697fc9ecc
+SIZE (ORLite-1.20.tar.gz) = 32797
diff --git a/databases/p5-ORLite/pkg-descr b/databases/p5-ORLite/pkg-descr
new file mode 100644
index 000000000000..e28f577699d6
--- /dev/null
+++ b/databases/p5-ORLite/pkg-descr
@@ -0,0 +1,5 @@
+ORLite is an object-relation system specifically tailored for SQLite that
+follows many of the same principles as the ::Tiny series of modules and has
+a design and feature set that aligns directly to the capabilities of SQLite.
+
+WWW: http://search.cpan.org/dist/ORLite/
diff --git a/databases/p5-ORLite/pkg-plist b/databases/p5-ORLite/pkg-plist
new file mode 100644
index 000000000000..2c436179597e
--- /dev/null
+++ b/databases/p5-ORLite/pkg-plist
@@ -0,0 +1,3 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/ORLite/.packlist
+%%SITE_PERL%%/ORLite.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/ORLite