aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2005-06-11 12:32:44 +0000
committerAlex Dupre <ale@FreeBSD.org>2005-06-11 12:32:44 +0000
commitcee3a2fc9f55b4f700b02935be99886ffee075c6 (patch)
tree780a0f74943716d05a21ebd507ad32b091232401 /databases
parent3495fdae2cfc579f4c9c9f9708b84ecc19da3b59 (diff)
downloadports-cee3a2fc9f55b4f700b02935be99886ffee075c6.tar.gz
ports-cee3a2fc9f55b4f700b02935be99886ffee075c6.zip
Fix compilation on FreeBSD 4.X.
Submitted by: many
Notes
Notes: svn path=/head/; revision=137261
Diffstat (limited to 'databases')
-rw-r--r--databases/mysql41-server/Makefile3
-rw-r--r--databases/mysql50-server/Makefile3
-rw-r--r--databases/mysql51-server/Makefile3
-rw-r--r--databases/mysql54-server/Makefile3
-rw-r--r--databases/mysql55-server/Makefile3
-rw-r--r--databases/mysql60-server/Makefile3
-rw-r--r--databases/percona55-server/Makefile3
7 files changed, 14 insertions, 7 deletions
diff --git a/databases/mysql41-server/Makefile b/databases/mysql41-server/Makefile
index ec4e83882f8f..16a1f0daf8e3 100644
--- a/databases/mysql41-server/Makefile
+++ b/databases/mysql41-server/Makefile
@@ -89,8 +89,9 @@ CFLAGS+= ${PTHREAD_CFLAGS}
.if ${OSVERSION} < 500000
LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
-CFLAGS+= -I${LOCALBASE}/include
+CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CXX= ${CC}
.endif
.if defined(BUILD_OPTIMIZED)
diff --git a/databases/mysql50-server/Makefile b/databases/mysql50-server/Makefile
index f173ae2e955c..76138ff78ad9 100644
--- a/databases/mysql50-server/Makefile
+++ b/databases/mysql50-server/Makefile
@@ -90,8 +90,9 @@ CFLAGS+= ${PTHREAD_CFLAGS}
.if ${OSVERSION} < 500000
LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
-CFLAGS+= -I${LOCALBASE}/include
+CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CXX= ${CC}
.endif
.if defined(BUILD_OPTIMIZED)
diff --git a/databases/mysql51-server/Makefile b/databases/mysql51-server/Makefile
index f173ae2e955c..76138ff78ad9 100644
--- a/databases/mysql51-server/Makefile
+++ b/databases/mysql51-server/Makefile
@@ -90,8 +90,9 @@ CFLAGS+= ${PTHREAD_CFLAGS}
.if ${OSVERSION} < 500000
LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
-CFLAGS+= -I${LOCALBASE}/include
+CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CXX= ${CC}
.endif
.if defined(BUILD_OPTIMIZED)
diff --git a/databases/mysql54-server/Makefile b/databases/mysql54-server/Makefile
index f173ae2e955c..76138ff78ad9 100644
--- a/databases/mysql54-server/Makefile
+++ b/databases/mysql54-server/Makefile
@@ -90,8 +90,9 @@ CFLAGS+= ${PTHREAD_CFLAGS}
.if ${OSVERSION} < 500000
LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
-CFLAGS+= -I${LOCALBASE}/include
+CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CXX= ${CC}
.endif
.if defined(BUILD_OPTIMIZED)
diff --git a/databases/mysql55-server/Makefile b/databases/mysql55-server/Makefile
index f173ae2e955c..76138ff78ad9 100644
--- a/databases/mysql55-server/Makefile
+++ b/databases/mysql55-server/Makefile
@@ -90,8 +90,9 @@ CFLAGS+= ${PTHREAD_CFLAGS}
.if ${OSVERSION} < 500000
LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
-CFLAGS+= -I${LOCALBASE}/include
+CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CXX= ${CC}
.endif
.if defined(BUILD_OPTIMIZED)
diff --git a/databases/mysql60-server/Makefile b/databases/mysql60-server/Makefile
index f173ae2e955c..76138ff78ad9 100644
--- a/databases/mysql60-server/Makefile
+++ b/databases/mysql60-server/Makefile
@@ -90,8 +90,9 @@ CFLAGS+= ${PTHREAD_CFLAGS}
.if ${OSVERSION} < 500000
LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
-CFLAGS+= -I${LOCALBASE}/include
+CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CXX= ${CC}
.endif
.if defined(BUILD_OPTIMIZED)
diff --git a/databases/percona55-server/Makefile b/databases/percona55-server/Makefile
index f173ae2e955c..76138ff78ad9 100644
--- a/databases/percona55-server/Makefile
+++ b/databases/percona55-server/Makefile
@@ -90,8 +90,9 @@ CFLAGS+= ${PTHREAD_CFLAGS}
.if ${OSVERSION} < 500000
LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
-CFLAGS+= -I${LOCALBASE}/include
+CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CXX= ${CC}
.endif
.if defined(BUILD_OPTIMIZED)