aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-11-20 12:24:10 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-11-20 12:24:10 +0000
commitfc1a499ec3ef541d776f52fd568c238471e65503 (patch)
treeb50f861f310385d539a56dea93988e3201bb0c12 /databases
parent2f0189100294a448861c2923782ce95bee152144 (diff)
downloadports-fc1a499ec3ef541d776f52fd568c238471e65503.tar.gz
ports-fc1a499ec3ef541d776f52fd568c238471e65503.zip
upgrade to 2.73
PR: 45424 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=70567
Diffstat (limited to 'databases')
-rw-r--r--databases/gigabase/Makefile9
-rw-r--r--databases/gigabase/distinfo2
-rw-r--r--databases/gigabase/files/patch-aa48
-rw-r--r--databases/gigabase/files/patch-configure10
-rw-r--r--databases/gigabase/pkg-comment2
-rw-r--r--databases/gigabase/pkg-plist5
6 files changed, 52 insertions, 24 deletions
diff --git a/databases/gigabase/Makefile b/databases/gigabase/Makefile
index 5d2d4e53f0ef..032eb115c719 100644
--- a/databases/gigabase/Makefile
+++ b/databases/gigabase/Makefile
@@ -6,15 +6,18 @@
#
PORTNAME= gigabase
-PORTVERSION= 2.65
+PORTVERSION= 2.73
CATEGORIES= databases
MASTER_SITES= http://www.garret.ru/~knizhnik/
MAINTAINER= ports@FreeBSD.org
WRKSRC= ${WRKDIR}/${PORTNAME}
-INSTALLS_SHLIB= yes
+
USE_GMAKE= yes
-GNU_CONFIGURE= yes
+USE_LIBTOOL= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS}" LDFLAGS="${PTHREAD_LIBS}"
+INSTALLS_SHLIB= yes
.include <bsd.port.mk>
diff --git a/databases/gigabase/distinfo b/databases/gigabase/distinfo
index 541f810a227c..2cd9d7e49f3e 100644
--- a/databases/gigabase/distinfo
+++ b/databases/gigabase/distinfo
@@ -1 +1 @@
-MD5 (gigabase-2.65.tar.gz) = 58b095c30d81b51d60fe42939f4191ed
+MD5 (gigabase-2.73.tar.gz) = 2e209fed2002c4a8e8b446e49377ab4d
diff --git a/databases/gigabase/files/patch-aa b/databases/gigabase/files/patch-aa
index 94ab4abb1132..9c3ed11e3a71 100644
--- a/databases/gigabase/files/patch-aa
+++ b/databases/gigabase/files/patch-aa
@@ -1,22 +1,38 @@
---- Makefile.in.orig Thu Aug 30 15:00:48 2001
-+++ Makefile.in Thu Aug 30 15:01:32 2001
-@@ -41,8 +41,8 @@
+--- Makefile.in.orig Wed Nov 6 01:30:34 2002
++++ Makefile.in Mon Nov 11 20:07:30 2002
+@@ -7,6 +7,8 @@
+ VPATH = @srcdir@
+ LIBTOOL = $(srcdir)/libtool
+ INSTALL = @INSTALL@
++INSTALL_PROGRAM = @INSTALL_PROGRAM@
++INSTALL_DATA = @INSTALL_DATA@
+
+ # Coment this for AIX/xlC 5.0
+ LIBEXT=la
+@@ -49,7 +51,7 @@
+
CXX = @CXX@
CC = @CC@
- DEFS = @DEFS@
--CXXFLAGS = @CXXFLAGS@ $(DEFS)
--CFLAGS = @CFLAGS@ $(DEFS)
-+CXXFLAGS = @CXXFLAGS@ $(DEFS) -D_THREAD_SAFE
-+CFLAGS = @CFLAGS@ $(DEFS) -D_THREAD_SAFE
+-DEFS = @DEFS@
++DEFS = @DEFS@ @CPPFLAGS@
+ CXXFLAGS = @CXXFLAGS@ $(DEFS)
+ CFLAGS = @CFLAGS@ $(DEFS)
LD = $(CXX)
- LDFLAGS = @LDFLAGS@ @TDEFS@ @LIBS@
- AR = ar
-@@ -126,7 +126,7 @@
+@@ -146,14 +148,14 @@
+
+ install: subsql $(GB_LIB) $(CLI_LIB)
+ mkdir -p $(includedir)
+- cp $(INCS) $(CLI_INCS) $(includedir)
++ $(INSTALL_DATA) $(INCS) $(CLI_INCS) $(includedir)
+ mkdir -p $(libdir)
+ $(LIBTOOL) --mode=install $(INSTALL) $(GB_LIB) $(CLI_LIB) $(libdir)
+ mkdir -p $(bindir)
+ if test -x .libs/subsql ; then \
+- cp .libs/subsql $(bindir); \
++ $(INSTALL_PROGRAM) .libs/subsql $(bindir); \
else \
- cp subsql $(bindir); \
+- cp subsql $(bindir); \
++ $(INSTALL_PROGRAM) subsql $(bindir); \
fi
--# strip $(bindir)/subsql
-+ strip $(bindir)/subsql
+ # strip $(bindir)/subsql
- clean:
- rm -f *.o *.lo core *~
diff --git a/databases/gigabase/files/patch-configure b/databases/gigabase/files/patch-configure
new file mode 100644
index 000000000000..bb9f2026648b
--- /dev/null
+++ b/databases/gigabase/files/patch-configure
@@ -0,0 +1,10 @@
+--- configure.orig Sat Sep 28 01:31:38 2002
++++ configure Sun Nov 3 09:18:40 2002
+@@ -12910,6 +12910,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/databases/gigabase/pkg-comment b/databases/gigabase/pkg-comment
index 411a714d79e3..879ce8637d49 100644
--- a/databases/gigabase/pkg-comment
+++ b/databases/gigabase/pkg-comment
@@ -1 +1 @@
-GigaBASE: Object-Relational Database Management System
+Object-Relational Database Management System
diff --git a/databases/gigabase/pkg-plist b/databases/gigabase/pkg-plist
index d467032b39e1..74eb17af406a 100644
--- a/databases/gigabase/pkg-plist
+++ b/databases/gigabase/pkg-plist
@@ -13,17 +13,16 @@ include/gigabase/gigabase.h
include/gigabase/hashtab.h
include/gigabase/pagepool.h
include/gigabase/query.h
-include/gigabase/reference.h
include/gigabase/rectangle.h
+include/gigabase/reference.h
+include/gigabase/selection.h
include/gigabase/stdtp.h
include/gigabase/sync.h
include/gigabase/wwwapi.h
lib/libcli_r.a
-lib/libcli_r.la
lib/libcli_r.so
lib/libcli_r.so.2
lib/libgigabase_r.a
-lib/libgigabase_r.la
lib/libgigabase_r.so
lib/libgigabase_r.so.2
@dirrm include/gigabase