aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2011-03-21 17:39:41 +0000
committerMatthias Andree <mandree@FreeBSD.org>2011-03-21 17:39:41 +0000
commite1268a4d7c1b1aae1d8ae0a175cae4053f4fec14 (patch)
tree5af503d27cfd215e2af682d35b3381d0745760e8 /databases
parent9ad88950de9753a6fde33271eaa5516ab855ce9c (diff)
downloadports-e1268a4d7c1b1aae1d8ae0a175cae4053f4fec14.tar.gz
ports-e1268a4d7c1b1aae1d8ae0a175cae4053f4fec14.zip
Port cleanup:
- minor whitespace cleanups - stop abusing PATCH_DIST_STRIP, use PATCH_WRKSRC instead - mark MAKE_JOBS_SAFE - clean up Tcl handling - note that WITH_TCL_VER now expects the version without a dot - supports Tcl 8.5 - use TCL_LIBDIR and TCL_INCLUDEDIR and USE_TCL rather than guesswork - combine, refresh, and rename patches
Notes
Notes: svn path=/head/; revision=271407
Diffstat (limited to 'databases')
-rw-r--r--databases/db3/Makefile32
-rw-r--r--databases/db3/files/patch-dist__Makefile.in (renamed from databases/db3/files/patch-dist::Makefile.in)4
-rw-r--r--databases/db3/files/patch-dist__configure (renamed from databases/db3/files/patch-dist::configure)13
-rw-r--r--databases/db3/files/patch-objformat11
4 files changed, 32 insertions, 28 deletions
diff --git a/databases/db3/Makefile b/databases/db3/Makefile
index 82751873aff2..236fb95fec9a 100644
--- a/databases/db3/Makefile
+++ b/databases/db3/Makefile
@@ -10,21 +10,22 @@ PORTVERSION= 3.3.11
PORTREVISION= 3
PORTEPOCH?= 1
CATEGORIES= databases
-MASTER_SITES= http://download.oracle.com/berkeley-db/
+MASTER_SITES= http://download.oracle.com/berkeley-db/
DISTNAME= db-${PORTVERSION}
DIST_SUBDIR= bdb
PATCH_SITES= http://download.oracle.com/berkeley-db/patches/db/${PORTVERSION}/
PATCHFILES= patch.${PORTVERSION}.1 patch.${PORTVERSION}.2
-PATCH_DIST_STRIP= -d ${WRKDIR}/${DISTNAME}
MAINTAINER= mandree@FreeBSD.org
COMMENT= The Berkeley DB package, revision 3.3
+PATCH_WRKSRC= ${WRKDIR}/${DISTNAME}
WRKSRC= ${WRKDIR}/${DISTNAME}/build_unix
USE_LDCONFIG= yes
-GNU_CONFIGURE= yes
+GNU_CONFIGURE= yes
+MAKE_JOBS_SAFE= yes
CONFIGURE_SCRIPT= ../dist/configure
LIBTOOLFILES= ${CONFIGURE_SCRIPT}
CONFIGURE_ARGS= --enable-compat185 \
@@ -38,14 +39,19 @@ INSTALL_TARGET+= install_docs docdir=${DOCSDIR}
PORTDOCS= *
.endif
-.if defined(WITH_TCL_VER)
-.if ${WITH_TCL_VER} == 8.4 || ${WITH_TCL_VER} == 8.3
-CONFIGURE_ARGS+= --enable-tcl --with-tcl=${LOCALBASE}/lib/tcl${WITH_TCL_VER}
-LIB_DEPENDS+= tcl${WITH_TCL_VER:S/.//}.1:${PORTSDIR}/lang/tcl${WITH_TCL_VER:S/.//}
-PLIST_SUB+= WITHTCL=""
-.else
-IGNORE= WITH_TCL_VER must be 8.4 or 8.3
+.if defined(WITH_TCL_VER) && !defined(WITH_TCL)
+WITH_TCL:= yes
+.endif
+
+.if defined(WITH_TCL)
+USE_TCL= 83+
.endif
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_TCL)
+CONFIGURE_ARGS+= --enable-tcl --with-tcl=${TCL_LIBDIR}
+PLIST_SUB+= WITHTCL=""
.else
PLIST_SUB+= WITHTCL="@comment "
.endif
@@ -58,8 +64,8 @@ post-patch:
@${REINPLACE_CMD} -e "s|%%LOCALBASE%%|${LOCALBASE}|g" ${WRKSRC}/../dist/configure
post-configure:
-.if defined(WITH_TCL_VER)
- @${REINPLACE_CMD} -e "s|TCFLAGS=.*|TCFLAGS=-I${LOCALBASE}/include/tcl${WITH_TCL_VER} -L${LOCALBASE}/lib/tcl${WITH_TCL_VER}|g" ${WRKSRC}/Makefile
+.if defined(WITH_TCL)
+ @${REINPLACE_CMD} -e "s|TCFLAGS=.*|TCFLAGS=-I${TCL_INCLUDEDIR} -L${TCL_LIBDIR}|g" ${WRKSRC}/Makefile
.endif
post-install:
@@ -67,4 +73,4 @@ post-install:
${RMDIR} ${DOCSDIR}/ref/splash
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/databases/db3/files/patch-dist::Makefile.in b/databases/db3/files/patch-dist__Makefile.in
index 75c0110084b3..22554a281660 100644
--- a/databases/db3/files/patch-dist::Makefile.in
+++ b/databases/db3/files/patch-dist__Makefile.in
@@ -1,5 +1,5 @@
---- ../dist/Makefile.in.orig Fri Jul 6 15:53:16 2001
-+++ ../dist/Makefile.in Tue May 14 12:26:13 2002
+--- ./dist/Makefile.in.orig 2001-07-06 22:53:16.000000000 +0200
++++ ./dist/Makefile.in 2011-03-21 18:22:00.000000000 +0100
@@ -61,12 +61,12 @@
LIBSO_LIBS= @LIBSO_LIBS@
diff --git a/databases/db3/files/patch-dist::configure b/databases/db3/files/patch-dist__configure
index 6f15e3b82012..6cd5f33da99d 100644
--- a/databases/db3/files/patch-dist::configure
+++ b/databases/db3/files/patch-dist__configure
@@ -1,5 +1,14 @@
---- ../dist/configure.orig Tue May 14 12:23:44 2002
-+++ ../dist/configure Tue May 14 12:24:11 2002
+--- ./dist/configure.orig 2011-03-21 18:22:00.000000000 +0100
++++ ./dist/configure 2011-03-21 18:22:00.000000000 +0100
+@@ -7002,7 +7002,7 @@
+ ;;
+
+ freebsd*)
+- objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo aout`
++ objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo elf`
+ version_type=freebsd-$objformat
+ case $version_type in
+ freebsd-elf*)
@@ -8449,7 +8449,7 @@
MAKEFILE_CCLINK="\$(LIBTOOL) --mode=link ${SAVE_CC}"
MAKEFILE_CXXLINK="\$(LIBTOOL) --mode=link ${SAVE_CXX}"
diff --git a/databases/db3/files/patch-objformat b/databases/db3/files/patch-objformat
deleted file mode 100644
index 2aa1daaaa21b..000000000000
--- a/databases/db3/files/patch-objformat
+++ /dev/null
@@ -1,11 +0,0 @@
---- ../dist/configure.foo Sun Feb 4 14:10:01 2007
-+++ ../dist/configure Sun Feb 4 14:11:26 2007
-@@ -7002,7 +7002,7 @@
- ;;
-
- freebsd*)
-- objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo aout`
-+ objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo elf`
- version_type=freebsd-$objformat
- case $version_type in
- freebsd-elf*)