aboutsummaryrefslogtreecommitdiff
path: root/deskutils/adesklets
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2005-05-26 03:28:16 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2005-05-26 03:28:16 +0000
commit0eacc0373f1bd3aafc2b9cc5005c71b32584b28f (patch)
treeb11d281c57cf8991f81074488c28b6b32fdc86f2 /deskutils/adesklets
parent14aab1be628fbbd169c5dc62af8f19d9659dbee2 (diff)
downloadports-0eacc0373f1bd3aafc2b9cc5005c71b32584b28f.tar.gz
ports-0eacc0373f1bd3aafc2b9cc5005c71b32584b28f.zip
- Install documentation
- Add pkg-message which informs that desklets are designed to be installed manually by user and there are no ports for them
Notes
Notes: svn path=/head/; revision=136144
Diffstat (limited to 'deskutils/adesklets')
-rw-r--r--deskutils/adesklets/Makefile15
-rw-r--r--deskutils/adesklets/files/pkg-message.in11
2 files changed, 26 insertions, 0 deletions
diff --git a/deskutils/adesklets/Makefile b/deskutils/adesklets/Makefile
index 7b9b6cd41408..7ce6044945a9 100644
--- a/deskutils/adesklets/Makefile
+++ b/deskutils/adesklets/Makefile
@@ -25,4 +25,19 @@ MAN1= adesklets.1
INFO= adesklets \
adesklets_fr
+SUB_FILES= pkg-message
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= *.html
+.endif
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for i in ${PORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/doc/html/en/${i} ${DOCSDIR}
+.endfor
+.endif
+ @${CAT} ${PKGMESSAGE}
+
.include <bsd.port.mk>
diff --git a/deskutils/adesklets/files/pkg-message.in b/deskutils/adesklets/files/pkg-message.in
new file mode 100644
index 000000000000..75c5d88805fa
--- /dev/null
+++ b/deskutils/adesklets/files/pkg-message.in
@@ -0,0 +1,11 @@
+
+--------------------------------------------------------------------------
+adesklets comes without any desklet by default. Desklets are intended to
+be installed by user, so there are no ports for them. They all are
+availbe here: http://adesklets.sourceforge.net/desklets.html
+
+Read documentation: %%DOCSDIR%%
+(unless build with NOPORTDOCS) or http://adesklets.sourceforge.net/doc/en/
+to know how to install it.
+--------------------------------------------------------------------------
+