aboutsummaryrefslogtreecommitdiff
path: root/deskutils/buoh
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2005-12-11 06:52:36 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2005-12-11 06:52:36 +0000
commit956c4ea97fa7ce3aec50221b6cf29642af0d31b0 (patch)
tree19a3fcda31b85eb0a8f0a1a75603ab43be093522 /deskutils/buoh
parent6fba2e4b6e3c695e14031580d639a833a47bd8b3 (diff)
downloadports-956c4ea97fa7ce3aec50221b6cf29642af0d31b0.tar.gz
ports-956c4ea97fa7ce3aec50221b6cf29642af0d31b0.zip
Add g_mutex_unlock() to solve the dump core at exit. I am not sure if it is a
right way to do it, but at least no more crash for now. Later, the correct way will be come up if I get any respone. Bump the PORTREVISION.
Notes
Notes: svn path=/head/; revision=150857
Diffstat (limited to 'deskutils/buoh')
-rw-r--r--deskutils/buoh/Makefile1
-rw-r--r--deskutils/buoh/files/patch-src_buoh-comic-loader.c10
2 files changed, 11 insertions, 0 deletions
diff --git a/deskutils/buoh/Makefile b/deskutils/buoh/Makefile
index 56eaa654b4a0..df48a09340b6 100644
--- a/deskutils/buoh/Makefile
+++ b/deskutils/buoh/Makefile
@@ -7,6 +7,7 @@
PORTNAME= buoh
PORTVERSION= 0.8.1
+PORTREVISION= 1
CATEGORIES= deskutils www gnome
MASTER_SITES= http://buoh.steve-o.org/downloads/
diff --git a/deskutils/buoh/files/patch-src_buoh-comic-loader.c b/deskutils/buoh/files/patch-src_buoh-comic-loader.c
new file mode 100644
index 000000000000..6133d783e0de
--- /dev/null
+++ b/deskutils/buoh/files/patch-src_buoh-comic-loader.c
@@ -0,0 +1,10 @@
+--- src/buoh-comic-loader.c.orig Sun Dec 11 00:25:18 2005
++++ src/buoh-comic-loader.c Sun Dec 11 00:25:39 2005
+@@ -184,6 +184,7 @@
+ }
+
+ if (loader->thread_mutex) {
++ g_mutex_unlock (loader->thread_mutex);
+ g_mutex_free (loader->thread_mutex);
+ loader->thread_mutex = NULL;
+ }