aboutsummaryrefslogtreecommitdiff
path: root/deskutils/etoile-extendedworkspacekit
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2006-11-19 16:34:12 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2006-11-19 16:34:12 +0000
commitf39c5127321e8a96b02f4613f80b55e3f4a0b5bd (patch)
tree89ea3e2fce99f720fa0a2ccae86fc00661ab0aff /deskutils/etoile-extendedworkspacekit
parent35015d38aa4a7208d8bfcd13c7ee1b5c487b3ea8 (diff)
downloadports-f39c5127321e8a96b02f4613f80b55e3f4a0b5bd.tar.gz
ports-f39c5127321e8a96b02f4613f80b55e3f4a0b5bd.zip
Etoile intends to be an innovative GNUstep based user environnement built
from the ground up on highly modular and light components with project and document orientation in mind, in order to allow users to create their own workflow by reshaping or recombining provided Services (aka Applications), Components etc. Flexibility and modularity on both User Interface and code level should allow us to scale from PDA to computer environment. This package installs the ExtendedWorkspaceKit framework. WWW: http://www.etoile-project.org/
Notes
Notes: svn path=/head/; revision=177592
Diffstat (limited to 'deskutils/etoile-extendedworkspacekit')
-rw-r--r--deskutils/etoile-extendedworkspacekit/Makefile35
-rw-r--r--deskutils/etoile-extendedworkspacekit/distinfo3
-rw-r--r--deskutils/etoile-extendedworkspacekit/pkg-descr10
-rw-r--r--deskutils/etoile-extendedworkspacekit/pkg-plist23
4 files changed, 71 insertions, 0 deletions
diff --git a/deskutils/etoile-extendedworkspacekit/Makefile b/deskutils/etoile-extendedworkspacekit/Makefile
new file mode 100644
index 000000000000..d76737ddd957
--- /dev/null
+++ b/deskutils/etoile-extendedworkspacekit/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: etoile-extendedworkspacekit
+# Date created: 18 Nov 2006
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= extendedworkspacekit
+PORTVERSION= 0.1.${SNAPSHOT}
+CATEGORIES= deskutils
+MASTER_SITES= http://florida.ethz.ch/ports/distfiles/
+PKGNAMEPREFIX= etoile-
+DISTNAME= etoile_0+${SNAPSHOT}+dfsg.orig
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= Etoile Project ExtendedWorkspaceKit framework
+
+SNAPSHOT= 20060917
+WRKSRC= ${WRKDIR}/etoile-0+${SNAPSHOT}+dfsg/Etoile/
+USE_GMAKE= yes
+USE_GNUSTEP= yes
+USE_GNUSTEP_PREFIX= yes
+USE_GNUSTEP_BACK= yes
+USE_GNUSTEP_BUILD= yes
+USE_GNUSTEP_INSTALL= yes
+MAKEFILE= GNUmakefile
+LDCONFIG_DIRS= ${LOCALLIBDIR}
+INSTALLS_SHLIB= yes
+NO_FILTER_SHLIBS= yes
+USE_GNUSTEP_SYSTEM_LIBS+= TrackerKit:${TRACKERKIT_PORT}
+USE_GNUSTEP_MAKE_DIRS+= Frameworks/ExtendedWorkspaceKit
+
+TRACKERKIT_PORT?= deskutils/etoile-trackerkit
+
+.include <bsd.port.mk>
diff --git a/deskutils/etoile-extendedworkspacekit/distinfo b/deskutils/etoile-extendedworkspacekit/distinfo
new file mode 100644
index 000000000000..2d5c7ccf5d13
--- /dev/null
+++ b/deskutils/etoile-extendedworkspacekit/distinfo
@@ -0,0 +1,3 @@
+MD5 (etoile_0+20060917+dfsg.orig.tar.gz) = bc96dcaba7ac66abb1320d5cfc98f05e
+SHA256 (etoile_0+20060917+dfsg.orig.tar.gz) = de7cb026ccebdbb72d115ca800a13910cd51c9df27f5578ad7059b13f88eb334
+SIZE (etoile_0+20060917+dfsg.orig.tar.gz) = 10478850
diff --git a/deskutils/etoile-extendedworkspacekit/pkg-descr b/deskutils/etoile-extendedworkspacekit/pkg-descr
new file mode 100644
index 000000000000..7b07f41576be
--- /dev/null
+++ b/deskutils/etoile-extendedworkspacekit/pkg-descr
@@ -0,0 +1,10 @@
+Etoile intends to be an innovative GNUstep based user environnement built
+from the ground up on highly modular and light components with project and
+document orientation in mind, in order to allow users to create their own
+workflow by reshaping or recombining provided Services (aka Applications),
+Components etc. Flexibility and modularity on both User Interface and code
+level should allow us to scale from PDA to computer environment.
+
+This package installs the ExtendedWorkspaceKit framework.
+
+WWW: http://www.etoile-project.org/
diff --git a/deskutils/etoile-extendedworkspacekit/pkg-plist b/deskutils/etoile-extendedworkspacekit/pkg-plist
new file mode 100644
index 000000000000..8ebd69b1691a
--- /dev/null
+++ b/deskutils/etoile-extendedworkspacekit/pkg-plist
@@ -0,0 +1,23 @@
+System/Library/Headers/ExtendedWorkspaceKit/EXAttribute.h
+System/Library/Headers/ExtendedWorkspaceKit/EXBasicFSAttributesExtracter.h
+System/Library/Headers/ExtendedWorkspaceKit/EXContext.h
+System/Library/Headers/ExtendedWorkspaceKit/EXEXIFAttributesExtracter.h
+System/Library/Headers/ExtendedWorkspaceKit/EXExtendedFSAttributesExtracter.h
+System/Library/Headers/ExtendedWorkspaceKit/EXExtensionProtocols.h
+System/Library/Headers/ExtendedWorkspaceKit/EXFileManager.h
+System/Library/Headers/ExtendedWorkspaceKit/EXPresentationAttribute.h
+System/Library/Headers/ExtendedWorkspaceKit/EXPreviewAttribute.h
+System/Library/Headers/ExtendedWorkspaceKit/EXQuery.h
+System/Library/Headers/ExtendedWorkspaceKit/EXTypeAttribute.h
+System/Library/Headers/ExtendedWorkspaceKit/EXVFS.h
+System/Library/Headers/ExtendedWorkspaceKit/EXVFSHandle.h
+System/Library/Headers/ExtendedWorkspaceKit/EXVFSProtocol.h
+System/Library/Headers/ExtendedWorkspaceKit/EXWorkspace.h
+System/Library/Headers/ExtendedWorkspaceKit/EXXMLAttributesExtracter.h
+System/Library/Headers/ExtendedWorkspaceKit/ExtendedWorkspaceConfig.h
+System/Library/Headers/ExtendedWorkspaceKit/ExtendedWorkspaceKit.h
+System/Library/Headers/ExtendedWorkspaceKit/NSURL+ExtendedWorkspace.h
+System/Library/Libraries/libExtendedWorkspace.so
+System/Library/Libraries/libExtendedWorkspace.so.%%MAJORLIBVERSION%%
+System/Library/Libraries/libExtendedWorkspace.so.%%MAJORLIBVERSION%%.1
+@dirrm System/Library/Headers/ExtendedWorkspaceKit