aboutsummaryrefslogtreecommitdiff
path: root/deskutils/gmcal
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2002-03-30 11:21:03 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2002-03-30 11:21:03 +0000
commit6a0d8433fab9545372730a168f6b5b684da1f151 (patch)
treeaec7568d4339a1af6b569978eb54fc2bb4b9877c /deskutils/gmcal
parent73d38c252f1eb27c1996deb689a34e65b393b15f (diff)
downloadports-6a0d8433fab9545372730a168f6b5b684da1f151.tar.gz
ports-6a0d8433fab9545372730a168f6b5b684da1f151.zip
mcal & gmcal use the libmcal library (see PR ports/31416 )
to access calendars that can be stored in many different formats. They are mostly exsamples and how-to use the MCAL library PR: 31461 Submitted by: thierry@pompo.net
Notes
Notes: svn path=/head/; revision=56927
Diffstat (limited to 'deskutils/gmcal')
-rw-r--r--deskutils/gmcal/Makefile41
-rw-r--r--deskutils/gmcal/distinfo1
-rw-r--r--deskutils/gmcal/files/patch-aa15
-rw-r--r--deskutils/gmcal/files/patch-ab36
-rw-r--r--deskutils/gmcal/pkg-comment1
-rw-r--r--deskutils/gmcal/pkg-descr8
-rw-r--r--deskutils/gmcal/pkg-plist1
7 files changed, 103 insertions, 0 deletions
diff --git a/deskutils/gmcal/Makefile b/deskutils/gmcal/Makefile
new file mode 100644
index 000000000000..bc28fd6591ab
--- /dev/null
+++ b/deskutils/gmcal/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: gmcal
+# Date created: Mon Oct 15 09:09:46 GMT 2001
+# Whom: thierry@pompo.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= gmcal
+PORTVERSION= 0.0.1
+CATEGORIES= deskutils
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= libmcal
+
+MAINTAINER= thierry@pompo.net
+
+LIB_DEPENDS= mcal.0:${PORTSDIR}/misc/libmcal
+RUN_DEPENDS= ${LOCALBASE}/mcal/mcal:${PORTSDIR}/deskutils/mcal
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+USE_GTK= yes
+
+STRIP= /usr/bin/strip
+
+post-extract:
+ ${CHMOD} a-x ${WRKSRC}/*
+
+post-build:
+ ${STRIP} ${WRKSRC}/gmcal
+
+do-install:
+ ${CP} ${WRKSRC}/gmcal ${PREFIX}/gmcal
+
+post-install:
+ @${ECHO} "*****************************************************************************"
+ @${ECHO} ""
+ @${ECHO} " gmcal has been installed in ${PREFIX}/gmcal."
+ @${ECHO} ""
+ @${ECHO} "*****************************************************************************"
+
+.include <bsd.port.mk>
diff --git a/deskutils/gmcal/distinfo b/deskutils/gmcal/distinfo
new file mode 100644
index 000000000000..1463bc02b76c
--- /dev/null
+++ b/deskutils/gmcal/distinfo
@@ -0,0 +1 @@
+MD5 (gmcal-0.0.1.tar.gz) = 9ed12226ec83512a0fe64af05eafd3d1
diff --git a/deskutils/gmcal/files/patch-aa b/deskutils/gmcal/files/patch-aa
new file mode 100644
index 000000000000..4bf1dcf62228
--- /dev/null
+++ b/deskutils/gmcal/files/patch-aa
@@ -0,0 +1,15 @@
+--- Makefile.orig Fri Dec 17 17:59:16 1999
++++ Makefile Mon Oct 15 22:59:33 2001
+@@ -1,7 +1,11 @@
+ # $Id: Makefile,v 1.1.1.1 1999/12/02 08:00:57 zircote Exp $
+
++INCLUDE=-I$(LOCALBASE)/include/mcal -I/usr/include/rpcsvc/
++
++all: gmcal
++
+ gmcal: gmcal.c
+- gcc -I../libmcal -Wall -g gmcal.c -o gmcal -L../libmcal -lmcal -lcrypt `gtk-config --cflags` `gtk-config --libs`
++ $(CC) $(INCLUDE) $(CFLAGS) gmcal.c -o gmcal -L$(LOCALBASE)/lib -lmcal -lcrypt `$(GTK_CONFIG) --cflags` `$(GTK_CONFIG) --libs`
+ clean:
+ rm gmcal
+
diff --git a/deskutils/gmcal/files/patch-ab b/deskutils/gmcal/files/patch-ab
new file mode 100644
index 000000000000..5faa77733e71
--- /dev/null
+++ b/deskutils/gmcal/files/patch-ab
@@ -0,0 +1,36 @@
+--- gmcal.c.orig Fri Dec 17 17:59:16 1999
++++ gmcal.c Mon Oct 15 23:56:27 2001
+@@ -8,9 +8,15 @@
+
+ #include <string.h>
+ #include <pwd.h>
++#if HAVE_GETOPT_H
+ #include <getopt.h>
++#else
++extern int getopt();
++extern char *optarg;
++extern int optind;
++#endif
++
+
+-#include <malloc.h>
+ #include <gtk/gtk.h>
+ #include <gtk/gtkcalendar.h>
+ #include <mcal.h>
+@@ -177,15 +183,8 @@
+ while (1)
+ {
+ int option_index = 0;
+- static struct option long_options[] =
+- {
+- {"version", 0, 0, 'v'},
+- {"help", 0, 0, 'h'},
+- {0, 0, 0, 0}
+- };
+
+- c = getopt_long (argc, argv, ":hv",
+- long_options, &option_index);
++ c = getopt (argc, argv, ":hv");
+ if (c == -1)
+ break;
+
diff --git a/deskutils/gmcal/pkg-comment b/deskutils/gmcal/pkg-comment
new file mode 100644
index 000000000000..e1baeb66279b
--- /dev/null
+++ b/deskutils/gmcal/pkg-comment
@@ -0,0 +1 @@
+GMCAL is a GTK+ frontend for the libmcal package
diff --git a/deskutils/gmcal/pkg-descr b/deskutils/gmcal/pkg-descr
new file mode 100644
index 000000000000..6dc7bcbadd98
--- /dev/null
+++ b/deskutils/gmcal/pkg-descr
@@ -0,0 +1,8 @@
+This is a very early release of a GTK+ app that can display your
+calendar and appointment either via mstore or ICAP protocol drivers.
+You may create these calendars with mcal (see deskutils/mcal).
+
+The use of this should only be considered for testing and development.
+It still has much work left before it is a stable production application.
+
+WWW: http://mcal.chek.com/
diff --git a/deskutils/gmcal/pkg-plist b/deskutils/gmcal/pkg-plist
new file mode 100644
index 000000000000..b2d8f4f9a4a9
--- /dev/null
+++ b/deskutils/gmcal/pkg-plist
@@ -0,0 +1 @@
+mcal/gmcal