aboutsummaryrefslogtreecommitdiff
path: root/deskutils/gnome-utils
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-11-07 22:24:32 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-11-07 22:24:32 +0000
commit58406bee8938178fc317574c4236434b0dd11a25 (patch)
treeb4fa34eca69e23769c548b4436cbf65d765e5fe2 /deskutils/gnome-utils
parent98eb5c95a29c8dd1a76435744e5316092835f696 (diff)
downloadports-58406bee8938178fc317574c4236434b0dd11a25.tar.gz
ports-58406bee8938178fc317574c4236434b0dd11a25.zip
Presenting GNOME 2.8 for FreeBSD (2.8.1 to be exact).
This release notes detailing all of the new goodies in GNOME 2.8 can be found at http://www.gnome.org/start/2.8/notes/, and the list of what was fixed in GNOME 2.8.1 can be found at http://lists.gnome.org/archives/gnome-announce-list/2004-October/msg00056.html. This release, as well as all of our others, would not have been possible without the great efforts of our FreeBSD GNOME Team. The list of current members can be found at http://www.freebsd.org/gnome/contact.html (including our newest member, Michael Johnson <ahze@FreeBSD.org>). Special thanks also goes out to all of the loyal FreeBSD GNOME users that put up with crashes and hangs to test and debug GNOME on FreeBSD. We would especially like to thank those users that provided patches for GNOME 2.7 and 2.8: Franz Klammer <klammer@webonaut.com> Piotr Smyrak <piotr.smyrak@heron.pl> Radek Kozlowski <radek@raadradd.com> Khairil Yusof <kaeru@pd.jaring.my> Yasuda Keisuke <kysd@po.harenet.ne.jp> Tom McLaughlin <tmclaugh@sdf.lonestar.org> Vladimir Grebenschikov <vova@fbsd.ru> GNOME 2.8 also features a new, FreeBSD-specific splashscreen that was designed by jimmac for GNOME 2.8, then daemonized by Franz Klammer <klammer@webonaut.com> and Radek Kozlowski <radek@raadradd.com>. As with GNOME 2.6, you cannot just "portupgrade" to GNOME 2.8. There is a script provided at http://www.marcuscom.com/downloads/gnome_upgrade28.sh that will aid in the upgrade process. Full documentation on the GNOME 2.8 upgrade is coming following this commit. From all of us at FreeBSD GNOME, ENJOY!
Notes
Notes: svn path=/head/; revision=121068
Diffstat (limited to 'deskutils/gnome-utils')
-rw-r--r--deskutils/gnome-utils/Makefile12
-rw-r--r--deskutils/gnome-utils/distinfo4
-rw-r--r--deskutils/gnome-utils/files/patch-logview_logview.c18
-rw-r--r--deskutils/gnome-utils/pkg-plist12
4 files changed, 24 insertions, 22 deletions
diff --git a/deskutils/gnome-utils/Makefile b/deskutils/gnome-utils/Makefile
index d91ca1e212f4..d51925c8735a 100644
--- a/deskutils/gnome-utils/Makefile
+++ b/deskutils/gnome-utils/Makefile
@@ -6,12 +6,11 @@
#
PORTNAME= gnomeutils2
-PORTVERSION= 2.6.2
-PORTREVISION= 1
+PORTVERSION= 2.8.1
PORTEPOCH= 1
CATEGORIES= deskutils gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/gnome-utils/2.6
+MASTER_SITE_SUBDIR= sources/gnome-utils/2.8
DISTNAME= gnome-utils-${PORTVERSION}
DIST_SUBDIR= gnome2
@@ -23,11 +22,12 @@ USE_X_PREFIX= yes
USE_REINPLACE= yes
USE_GMAKE= yes
GNOME_DESKTOP_VERSION=2
-USE_GNOME= gnomeprefix gnomehack lthack intlhack gnomehier gnomepanel
-USE_LIBTOOL_VER=13
+USE_GNOME= gnomeprefix gnomehack intlhack gnomehier gnomepanel
+USE_LIBTOOL_VER=15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-MAN1= gnome-dictionary.1 gnome-search-tool.1 gnome-system-log.1
+MAN1= gnome-dictionary.1 gnome-search-tool.1 gnome-system-log.1
+GCONF_SCHEMAS= gdict.schemas gnome-search-tool.schemas logview.schemas
.include <bsd.port.mk>
diff --git a/deskutils/gnome-utils/distinfo b/deskutils/gnome-utils/distinfo
index 68c17473d366..a5647e87561d 100644
--- a/deskutils/gnome-utils/distinfo
+++ b/deskutils/gnome-utils/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/gnome-utils-2.6.2.tar.bz2) = b2325307fd311c8ba1bd045d7432830e
-SIZE (gnome2/gnome-utils-2.6.2.tar.bz2) = 1625287
+MD5 (gnome2/gnome-utils-2.8.1.tar.bz2) = 048224275454781c7eebc5afd4004069
+SIZE (gnome2/gnome-utils-2.8.1.tar.bz2) = 1738576
diff --git a/deskutils/gnome-utils/files/patch-logview_logview.c b/deskutils/gnome-utils/files/patch-logview_logview.c
index 1155fdb97624..942ed8a02d6b 100644
--- a/deskutils/gnome-utils/files/patch-logview_logview.c
+++ b/deskutils/gnome-utils/files/patch-logview_logview.c
@@ -1,6 +1,6 @@
---- logview/logview.c.orig Sun Feb 16 15:36:07 2003
-+++ logview/logview.c Thu Apr 24 12:53:35 2003
-@@ -774,7 +774,7 @@
+--- logview/logview.c.orig Fri May 7 21:47:59 2004
++++ logview/logview.c Wed Aug 4 18:40:24 2004
+@@ -781,7 +781,7 @@
if ( ! found) {
g_snprintf (full_name, sizeof (full_name),
@@ -9,7 +9,7 @@
if (access (full_name, R_OK) == 0) {
found = TRUE;
g_free (cfg->regexp_db_path);
-@@ -797,7 +797,7 @@
+@@ -804,7 +804,7 @@
if ( ! found) {
g_snprintf (full_name, sizeof (full_name),
@@ -18,7 +18,7 @@
if (access (full_name, R_OK) == 0) {
found = TRUE;
g_free (cfg->descript_db_path);
-@@ -831,7 +831,7 @@
+@@ -838,7 +838,7 @@
if ( ! found) {
g_snprintf (full_name, sizeof (full_name),
@@ -27,3 +27,11 @@
if (access (full_name, R_OK) == 0) {
found = TRUE;
g_free (cfg->action_db_path);
+@@ -922,6 +922,7 @@
+ /* remove trailing newline */
+ if (logfile[strlen(logfile)-1] == '\n')
+ logfile[strlen(logfile)-1] = '\0';
++ if (strcmp (logfile, "/dev/console") == 0) continue;
+ fprintf(stderr, "Found a logfile: (%s)\n", logfile);
+ return logfile;
+ }
diff --git a/deskutils/gnome-utils/pkg-plist b/deskutils/gnome-utils/pkg-plist
index c687a6206f15..ff9d54341346 100644
--- a/deskutils/gnome-utils/pkg-plist
+++ b/deskutils/gnome-utils/pkg-plist
@@ -1,15 +1,6 @@
bin/gnome-dictionary
bin/gnome-search-tool
bin/gnome-system-log
-@unexec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-uninstall-rule %D/etc/gconf/schemas/gdict.schemas > /dev/null || /usr/bin/true
-etc/gconf/schemas/gdict.schemas
-@exec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-install-rule %D/etc/gconf/schemas/gdict.schemas > /dev/null || /usr/bin/true
-@unexec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-uninstall-rule %D/etc/gconf/schemas/gnome-search-tool.schemas > /dev/null || /usr/bin/true
-etc/gconf/schemas/gnome-search-tool.schemas
-@exec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-install-rule %D/etc/gconf/schemas/gnome-search-tool.schemas > /dev/null || /usr/bin/true
-@unexec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-uninstall-rule %D/etc/gconf/schemas/logview.schemas > /dev/null || /usr/bin/true
-etc/gconf/schemas/logview.schemas
-@exec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-install-rule %D/etc/gconf/schemas/logview.schemas > /dev/null || /usr/bin/true
libdata/bonobo/servers/GNOME_GDictApplet.server
libexec/gdict-applet
share/gnome/applications/gnome-dictionary.desktop
@@ -137,6 +128,7 @@ share/locale/az/LC_MESSAGES/gnome-utils-2.0.mo
share/locale/be/LC_MESSAGES/gnome-utils-2.0.mo
share/locale/bg/LC_MESSAGES/gnome-utils-2.0.mo
share/locale/bn/LC_MESSAGES/gnome-utils-2.0.mo
+share/locale/bs/LC_MESSAGES/gnome-utils-2.0.mo
share/locale/ca/LC_MESSAGES/gnome-utils-2.0.mo
share/locale/cs/LC_MESSAGES/gnome-utils-2.0.mo
share/locale/cy/LC_MESSAGES/gnome-utils-2.0.mo
@@ -168,6 +160,8 @@ share/locale/mk/LC_MESSAGES/gnome-utils-2.0.mo
share/locale/ml/LC_MESSAGES/gnome-utils-2.0.mo
share/locale/mn/LC_MESSAGES/gnome-utils-2.0.mo
share/locale/ms/LC_MESSAGES/gnome-utils-2.0.mo
+share/locale/nb/LC_MESSAGES/gnome-utils-2.0.mo
+share/locale/ne/LC_MESSAGES/gnome-utils-2.0.mo
share/locale/nl/LC_MESSAGES/gnome-utils-2.0.mo
share/locale/nn/LC_MESSAGES/gnome-utils-2.0.mo
share/locale/no/LC_MESSAGES/gnome-utils-2.0.mo