aboutsummaryrefslogtreecommitdiff
path: root/deskutils/gnote
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2009-12-03 18:47:46 +0000
committerKoop Mast <kwm@FreeBSD.org>2009-12-03 18:47:46 +0000
commit2e19dace3f96e309f0675ec63ba2d99d5030a323 (patch)
treed9be8eb885287ef71b8fbc5e2eed7dc9e40a1d01 /deskutils/gnote
parentb750bb4f9b2ae5e7dc4e83e50cdfdcd2579b0ead (diff)
downloadports-2e19dace3f96e309f0675ec63ba2d99d5030a323.tar.gz
ports-2e19dace3f96e309f0675ec63ba2d99d5030a323.zip
Fix build on amd64 and fix the plist while here.
Submitted by: pointyhat (via pav) & QAT
Notes
Notes: svn path=/head/; revision=245174
Diffstat (limited to 'deskutils/gnote')
-rw-r--r--deskutils/gnote/Makefile2
-rw-r--r--deskutils/gnote/files/patch-src_debug.cpp11
2 files changed, 12 insertions, 1 deletions
diff --git a/deskutils/gnote/Makefile b/deskutils/gnote/Makefile
index d5f32f010eb3..13a3372d0a1a 100644
--- a/deskutils/gnote/Makefile
+++ b/deskutils/gnote/Makefile
@@ -29,7 +29,7 @@ INSTALLS_ICONS= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib" \
- PANELAPPLET_LIBDIR="${PREFIX}/libdata"
+ PANELAPPLET_SERVER_DIR="${PREFIX}/libdata/bonobo/servers"
CONFIGURE_ARGS= --disable-dbus
DOCS= AUTHORS COPYING ChangeLog NEWS README TODO
MAN1= gnote.1
diff --git a/deskutils/gnote/files/patch-src_debug.cpp b/deskutils/gnote/files/patch-src_debug.cpp
new file mode 100644
index 000000000000..cb2fe38059f6
--- /dev/null
+++ b/deskutils/gnote/files/patch-src_debug.cpp
@@ -0,0 +1,11 @@
+--- src/debug.cpp.orig 2009-11-25 14:12:33.000000000 +0100
++++ src/debug.cpp 2009-12-03 17:28:54.000000000 +0100
+@@ -126,7 +126,7 @@
+ // static boost::recursive_mutex mutex;
+ // boost::recursive_mutex::scoped_lock lock(mutex);
+ char buf[128];
+- snprintf(buf, 128, "(%d) ", (int)pthread_self());
++ snprintf(buf, 128, "(%d) ", (pthread_t)pthread_self());
+ fwrite(buf, 1, strlen(buf), stderr);
+ fwrite(prefix, 1, strlen(prefix), stderr);
+