aboutsummaryrefslogtreecommitdiff
path: root/deskutils/horde4-kronolith
diff options
context:
space:
mode:
authorDirk Froemberg <dirk@FreeBSD.org>2003-01-30 10:05:54 +0000
committerDirk Froemberg <dirk@FreeBSD.org>2003-01-30 10:05:54 +0000
commit2aefbcb14417f90f8db0159809a4d4d2d3118e51 (patch)
treec4fbab4a218867461db5c8a6fffa8a3999353784 /deskutils/horde4-kronolith
parentc54635d5954c80bf7006d7c1a26bb19a25e27075 (diff)
downloadports-2aefbcb14417f90f8db0159809a4d4d2d3118e51.tar.gz
ports-2aefbcb14417f90f8db0159809a4d4d2d3118e51.zip
- fix isWarning
- fix ftp sites PR: ports/47418 Submitted by: Thierry Thomas <thierry@pompo.net>
Notes
Notes: svn path=/head/; revision=74268
Diffstat (limited to 'deskutils/horde4-kronolith')
-rw-r--r--deskutils/horde4-kronolith/Makefile10
-rw-r--r--deskutils/horde4-kronolith/files/patch-lib_Driver_sql.php11
-rw-r--r--deskutils/horde4-kronolith/pkg-deinstall27
-rw-r--r--deskutils/horde4-kronolith/pkg-plist1
4 files changed, 46 insertions, 3 deletions
diff --git a/deskutils/horde4-kronolith/Makefile b/deskutils/horde4-kronolith/Makefile
index 15cbd738af4f..f6c0fc658ace 100644
--- a/deskutils/horde4-kronolith/Makefile
+++ b/deskutils/horde4-kronolith/Makefile
@@ -7,10 +7,14 @@
PORTNAME= kronolith
PORTVERSION= 1.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= deskutils www
-MASTER_SITES= ftp://ftp.horde.org/pub/kronolith/tarballs/%SUBDIR%/
-MASTER_SITE_SUBDIR= . old
+MASTER_SITES= ftp://ftp.horde.org/pub/kronolith/ \
+ ftp://ftp.au.horde.org/pub/horde/kronolith/ \
+ ftp://ftp.es.horde.org/pub/kronolith/ \
+ ftp://ftp.it.horde.org/pub/mirror/horde.org/kronolith/ \
+ ftp://ftp.nl.horde.org/mirror/horde-ftp/pub/kronolith/ \
+ ftp://ftp.pt.horde.org/pub/horde-ftp/kronolith/
MAINTAINER= thierry@pompo.net
diff --git a/deskutils/horde4-kronolith/files/patch-lib_Driver_sql.php b/deskutils/horde4-kronolith/files/patch-lib_Driver_sql.php
new file mode 100644
index 000000000000..e831d6991901
--- /dev/null
+++ b/deskutils/horde4-kronolith/files/patch-lib_Driver_sql.php
@@ -0,0 +1,11 @@
+--- lib/Driver/sql.php.orig Sat May 18 00:58:16 2002
++++ lib/Driver/sql.php Mon Dec 23 23:12:46 2002
+@@ -61,7 +61,7 @@
+
+ /* Connect to the SQL server using the supplied parameters. */
+ $this->db = &DB::connect($this->params, true);
+- if (DB::isError($this->db) || DB::isWarning($this->db)) {
++ if (DB::isError($this->db)) {
+ Horde::fatal($this->db, __FILE__, __LINE__);
+ }
+
diff --git a/deskutils/horde4-kronolith/pkg-deinstall b/deskutils/horde4-kronolith/pkg-deinstall
new file mode 100644
index 000000000000..4578da3f26fe
--- /dev/null
+++ b/deskutils/horde4-kronolith/pkg-deinstall
@@ -0,0 +1,27 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# Backup Kronolith config files, if needed.
+
+if [ x$2 != xDEINSTALL ]; then
+ exit
+fi
+
+if [ -z "${PACKAGE_BUILDING}" ]; then
+ for cf in `ls ${PKG_PREFIX}/www/horde/kronolith/config/*php`; do
+ diff -bBqw $cf $cf.dist >/dev/null 2>&1
+ case $? in
+ 0) # original config file, will be deleted by pkg-plist
+ ;;
+ 1) # config file has been updated, must be backuped
+ cp -p $cf $cf.previous
+ echo "===> Backing-up..."
+ echo "---> $cf has been saved ***"
+ echo "---> as $cf.previous ***"
+ ;;
+ *) # not found?
+ ;;
+ esac
+ done
+fi
diff --git a/deskutils/horde4-kronolith/pkg-plist b/deskutils/horde4-kronolith/pkg-plist
index c9e158fcff18..d1669099a291 100644
--- a/deskutils/horde4-kronolith/pkg-plist
+++ b/deskutils/horde4-kronolith/pkg-plist
@@ -47,6 +47,7 @@
%%KRONOLITHDIR%%/lib/Driver.php
%%KRONOLITHDIR%%/lib/Driver/mcal.php
%%KRONOLITHDIR%%/lib/Driver/sql.php
+%%KRONOLITHDIR%%/lib/Driver/sql.php.orig
%%KRONOLITHDIR%%/lib/Event.php
%%KRONOLITHDIR%%/lib/Kronolith.php
%%KRONOLITHDIR%%/lib/Month.php