aboutsummaryrefslogtreecommitdiff
path: root/deskutils/kbirthday
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2005-01-09 16:51:33 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2005-01-09 16:51:33 +0000
commitbf9fb7777bf83e744188dd94ce43084d2ce460ff (patch)
treeb179f39fbd17092e711e208d99e79cd0bc2e472c /deskutils/kbirthday
parentc683dd301c554c30d8a35867e6de28fc79cd90a1 (diff)
downloadports-bf9fb7777bf83e744188dd94ce43084d2ce460ff.tar.gz
ports-bf9fb7777bf83e744188dd94ce43084d2ce460ff.zip
Fix build on amd64 by using -fPIC to build the applet.
PR: 75982 Reported by: Heiner Eichmann <h.eichmann@gmx.de>
Notes
Notes: svn path=/head/; revision=125966
Diffstat (limited to 'deskutils/kbirthday')
-rw-r--r--deskutils/kbirthday/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/deskutils/kbirthday/Makefile b/deskutils/kbirthday/Makefile
index 32ae2a684684..b7438e20d796 100644
--- a/deskutils/kbirthday/Makefile
+++ b/deskutils/kbirthday/Makefile
@@ -16,6 +16,7 @@ COMMENT= KDE kicker-applet that reminds you of birthdays and anniversaries
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_KDELIBS_VER=3
+USE_REINPLACE= yes
INSTALLS_SHLIB= yes
USE_INC_LIBTOOL_VER= 13
# may or may not solve the alpha compilation issue....
@@ -24,4 +25,7 @@ CONFIGURE_ARGS= --with-pic
# necesary to access the second master site by getting rid of the default switch -A
FETCH_CMD ?=/usr/bin/fetch -Rr
+post-patch:
+ ${REINPLACE_CMD} -e "s,-Wmissing-prototypes,-fPIC," ${WRKSRC}/configure
+
.include <bsd.port.mk>