aboutsummaryrefslogtreecommitdiff
path: root/deskutils/kchmviewer
diff options
context:
space:
mode:
authorMarkus Brueffer <markus@FreeBSD.org>2008-04-08 15:02:10 +0000
committerMarkus Brueffer <markus@FreeBSD.org>2008-04-08 15:02:10 +0000
commitf94c1fb1a5547aff16d8b966c9da6ff00aa0f5f9 (patch)
tree4511da19b8289b33ef9616e23daf5f6f5e6c5fee /deskutils/kchmviewer
parent8062b8c198b467618de9c7e17ac8f0915715a564 (diff)
downloadports-f94c1fb1a5547aff16d8b966c9da6ff00aa0f5f9.tar.gz
ports-f94c1fb1a5547aff16d8b966c9da6ff00aa0f5f9.zip
- Update to version 3.1 [2]
- Fix installation locations if WITHOUT_KDE is set [1] - Fix tinderbox build and package creation if WITHOUT_KDE is set - Don't install locales if WITHOUT_KDE is set, as locale support in the Qt-only version is not present PR: ports/117449 [1] ports/120540 [2] Submitted by: Denise H. G. <denisehg@hotpop.com> [1] Yarodin <yarodin@gmail.com> [2]
Notes
Notes: svn path=/head/; revision=210856
Diffstat (limited to 'deskutils/kchmviewer')
-rw-r--r--deskutils/kchmviewer/Makefile31
-rw-r--r--deskutils/kchmviewer/distinfo6
-rw-r--r--deskutils/kchmviewer/pkg-plist9
3 files changed, 35 insertions, 11 deletions
diff --git a/deskutils/kchmviewer/Makefile b/deskutils/kchmviewer/Makefile
index 4054e2750a3a..11328d3402ae 100644
--- a/deskutils/kchmviewer/Makefile
+++ b/deskutils/kchmviewer/Makefile
@@ -6,29 +6,36 @@
#
PORTNAME= kchmviewer
-PORTVERSION= 3.0
-PORTREVISION= 1
+PORTVERSION= 3.1
CATEGORIES= deskutils kde
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-${PORTVERSION}-2
MAINTAINER= markus@FreeBSD.org
COMMENT= A Qt/KDE viewer for CHM files
LIB_DEPENDS+= chm:${PORTSDIR}/misc/chmlib
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_GMAKE= yes
USE_AUTOTOOLS= libtool:15
DO_NOT_COMPILE+=chmlib
-CONFIGURE_ENV+= LDFLAGS="${PTHREAD_LIBS}" DO_NOT_COMPILE="${DO_NOT_COMPILE}"
+CONFIGURE_ENV+= LDFLAGS="${PTHREAD_LIBS} -L${LOCALBASE}/lib" \
+ CPPFLAGS="-I${LOCALBASE}/include" \
+ DO_NOT_COMPILE="${DO_NOT_COMPILE}"
.if !defined(WITHOUT_KDE)
USE_KDELIBS_VER=3
PLIST_SUB+= KDE=""
+PLIST_SUB+= QT="@comment "
CONFIGURE_ARGS+=--with-kde
.else
USE_QT_VER= 3
+USE_PERL5_BUILD=yes
+RUN_DEPENDS+= ${LOCALBASE}/share/icons/hicolor/index.theme:${PORTSDIR}/misc/hicolor-icon-theme
PLIST_SUB+= KDE="@comment "
+PLIST_SUB+= QT=""
CONFIGURE_TARGET=
CONFIGURE_ARGS+=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
DO_NOT_COMPILE+=kio-msits
@@ -43,4 +50,22 @@ post-patch:
@${REINPLACE_CMD} -e 's|-O2||g;s|-lpthread|${PTHREAD_LIBS}|g' \
${WRKSRC}/${CONFIGURE_SCRIPT}
+post-configure:
+.if defined(WITHOUT_KDE)
+ @${REINPLACE_CMD} -e 's|src po|src|g' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} \
+ -e 's|kde_icondir =.*|kde_icondir = ${PREFIX}/share/icons|g' \
+ ${WRKSRC}/src/pics/Makefile
+ @${REINPLACE_CMD} -e 's|crystalsvg|hicolor|g' \
+ ${WRKSRC}/src/pics/Makefile
+.endif
+
+pre-install:
+.if defined(WITHOUT_KDE)
+ @${REINPLACE_CMD} -e 's|Categories=.*|Categories=Utility;|g' \
+ ${WRKSRC}/lib/kio-msits/kchmviewer.desktop
+ @${INSTALL_DATA} ${WRKSRC}/lib/kio-msits/kchmviewer.desktop \
+ ${PREFIX}/share/applications
+.endif
+
.include <bsd.port.mk>
diff --git a/deskutils/kchmviewer/distinfo b/deskutils/kchmviewer/distinfo
index de2d18848e5e..993215045ecf 100644
--- a/deskutils/kchmviewer/distinfo
+++ b/deskutils/kchmviewer/distinfo
@@ -1,3 +1,3 @@
-MD5 (kchmviewer-3.0.tar.gz) = f14b7c5be4154dfc688bef7ebd3879ff
-SHA256 (kchmviewer-3.0.tar.gz) = 706a74a2ed9e2354decc2796e7e3eebf03d976a1da9eda30b7a57a1d67a6eb34
-SIZE (kchmviewer-3.0.tar.gz) = 707997
+MD5 (kchmviewer-3.1-2.tar.gz) = bc376ce29784f33bf0b5f8d1ae5141bf
+SHA256 (kchmviewer-3.1-2.tar.gz) = e73b4ec4b1b6decbd2ab82f670b843a12813d74653ebc6859deffb3b48abf6db
+SIZE (kchmviewer-3.1-2.tar.gz) = 945640
diff --git a/deskutils/kchmviewer/pkg-plist b/deskutils/kchmviewer/pkg-plist
index 5096af2ee5f7..256d0a2fde9f 100644
--- a/deskutils/kchmviewer/pkg-plist
+++ b/deskutils/kchmviewer/pkg-plist
@@ -4,10 +4,13 @@ bin/kchmviewer
%%KDE%%lib/kde3/kio_msits.so
lib/libchmfile.a
%%KDE%%lib/libkdeextra.a
-%%KDE%%share/applnk/kchmviewer.desktop
+share/applications/kchmviewer.desktop
%%KDE%%share/icons/crystalsvg/128x128/apps/kchmviewer.png
%%KDE%%share/icons/crystalsvg/48x48/apps/kchmviewer.png
%%KDE%%share/icons/crystalsvg/64x64/apps/kchmviewer.png
+%%QT%%share/icons/hicolor/128x128/apps/kchmviewer.png
+%%QT%%share/icons/hicolor/48x48/apps/kchmviewer.png
+%%QT%%share/icons/hicolor/64x64/apps/kchmviewer.png
%%KDE%%share/locale/cs/LC_MESSAGES/kchmviewer.mo
%%KDE%%share/locale/du/LC_MESSAGES/kchmviewer.mo
%%KDE%%share/locale/fr/LC_MESSAGES/kchmviewer.mo
@@ -15,9 +18,5 @@ lib/libchmfile.a
%%KDE%%share/locale/tr/LC_MESSAGES/kchmviewer.mo
%%KDE%%share/locale/zh_CN/LC_MESSAGES/kchmviewer.mo
%%KDE%%share/services/msits.protocol
-%%KDE%%@dirrmtry share/locale/zh_CN/LC_MESSAGES
-%%KDE%%@dirrmtry share/locale/zh_CN
%%KDE%%@dirrmtry share/locale/du/LC_MESSAGES
%%KDE%%@dirrmtry share/locale/du
-%%KDE%%@dirrmtry share/locale/cs/LC_MESSAGES
-%%KDE%%@dirrmtry share/locale/cs