aboutsummaryrefslogtreecommitdiff
path: root/deskutils/kdepim3
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2006-05-06 15:14:39 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2006-05-06 15:14:39 +0000
commite420424612560b37f8829396c2604b52aaa021c4 (patch)
tree86a1dc09076ecaab5e5db382714cd10248b0cc43 /deskutils/kdepim3
parent36c60d34c5956bc798858ecfe9572ce9677e9428 (diff)
downloadports-e420424612560b37f8829396c2604b52aaa021c4.tar.gz
ports-e420424612560b37f8829396c2604b52aaa021c4.zip
Fix KDE Bug 124024.
PR: ports/96367
Notes
Notes: svn path=/head/; revision=161499
Diffstat (limited to 'deskutils/kdepim3')
-rw-r--r--deskutils/kdepim3/Makefile1
-rw-r--r--deskutils/kdepim3/files/patch-kdegantt_KDGanttView.cpp16
-rw-r--r--deskutils/kdepim3/files/patch-kioslaves_imap4-imapparser.cc15
3 files changed, 32 insertions, 0 deletions
diff --git a/deskutils/kdepim3/Makefile b/deskutils/kdepim3/Makefile
index 11bd9c50f0dc..4d35da801976 100644
--- a/deskutils/kdepim3/Makefile
+++ b/deskutils/kdepim3/Makefile
@@ -7,6 +7,7 @@
PORTNAME= kdepim
PORTVERSION= ${KDE_VERSION}
+PORTREVISION= 1
CATEGORIES= deskutils mail news palm kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION:S/.0//}/src
diff --git a/deskutils/kdepim3/files/patch-kdegantt_KDGanttView.cpp b/deskutils/kdepim3/files/patch-kdegantt_KDGanttView.cpp
new file mode 100644
index 000000000000..4b53f326f2fb
--- /dev/null
+++ b/deskutils/kdepim3/files/patch-kdegantt_KDGanttView.cpp
@@ -0,0 +1,16 @@
+--- kdgantt/KDGanttView.cpp.orig Thu May 4 09:19:43 2006
++++ kdgantt/KDGanttView.cpp Tue May 2 10:07:59 2006
+@@ -323,7 +323,12 @@
+ bool block = myTimeTable->blockUpdating();
+ myTimeTable->setBlockUpdating( false );
+ myTimeTable->updateMyContent();
+- qApp->processEvents();
++ /* The below causes recursive calls to various size updating methods, which
++ * cause QCanvas to hide and show items like mad, which is very slow. If
++ * there is a legitimate gui updating issue here somewhere, it will need
++ * to be solved differently.
++ */
++ //qApp->processEvents();
+ int hintHeight = myTimeHeader->height();
+ int legendHeight = 0;
+ if ( showLegendButton() )
diff --git a/deskutils/kdepim3/files/patch-kioslaves_imap4-imapparser.cc b/deskutils/kdepim3/files/patch-kioslaves_imap4-imapparser.cc
new file mode 100644
index 000000000000..cdbca5e288b9
--- /dev/null
+++ b/deskutils/kdepim3/files/patch-kioslaves_imap4-imapparser.cc
@@ -0,0 +1,15 @@
+Index: kioslaves/imap4/imapparser.cc
+===================================================================
+--- kioslaves/imap4/imapparser.cc (revision 537000)
++++ kioslaves/imap4/imapparser.cc (revision 537001)
+@@ -949,7 +949,9 @@ QAsciiDict < QString > imapParser::parse
+
+ while (!inWords.isEmpty () && inWords[0] != ')')
+ {
+- retVal.insert (parseLiteralC(inWords), new QString(parseLiteralC(inWords)));
++ QCString l1 = parseLiteralC(inWords);
++ QCString l2 = parseLiteralC(inWords);
++ retVal.insert (l1, new QString(l2));
+ }
+
+ if (inWords[0] != ')')