aboutsummaryrefslogtreecommitdiff
path: root/deskutils/korganizer
diff options
context:
space:
mode:
authorBrian Somers <brian@FreeBSD.org>1998-10-02 18:21:26 +0000
committerBrian Somers <brian@FreeBSD.org>1998-10-02 18:21:26 +0000
commit1bc1fdd17667f089544ee5e80b1f11f18e334fe0 (patch)
tree9236d9444480b11f3923726478b7eae63e5db61a /deskutils/korganizer
parentfc3b3f89b4815c74fb4247c994a5439886508911 (diff)
downloadports-1bc1fdd17667f089544ee5e80b1f11f18e334fe0.tar.gz
ports-1bc1fdd17667f089544ee5e80b1f11f18e334fe0.zip
Upgrade, unbreak & Elfify
The DST stuff looks broken.
Notes
Notes: svn path=/head/; revision=13601
Diffstat (limited to 'deskutils/korganizer')
-rw-r--r--deskutils/korganizer/Makefile14
-rw-r--r--deskutils/korganizer/distinfo2
-rw-r--r--deskutils/korganizer/files/patch-aa45
-rw-r--r--deskutils/korganizer/pkg-plist48
4 files changed, 72 insertions, 37 deletions
diff --git a/deskutils/korganizer/Makefile b/deskutils/korganizer/Makefile
index 0b01221fb9c8..5403808ebc57 100644
--- a/deskutils/korganizer/Makefile
+++ b/deskutils/korganizer/Makefile
@@ -3,10 +3,10 @@
# Date created: 23 May 1998
# Whom: Hans Petter Bieker <hanspb@persbraten.vgs.no>
#
-# $Id: Makefile,v 1.9 1998/09/19 01:33:45 steve Exp $
+# $Id: Makefile,v 1.10 1998/09/30 02:07:27 jseger Exp $
#
-DISTNAME= korganizer-0.9
+DISTNAME= korganizer-0.9.13
CATEGORIES= deskutils kde
MASTER_SITES= $(MASTER_SITE_KDE)
MASTER_SITE_SUBDIR= unstable/apps/office
@@ -15,12 +15,8 @@ MAINTAINER= hanspb@persbraten.vgs.no
LIB_DEPENDS= gif.3:${PORTSDIR}/graphics/giflib \
jpeg.9:${PORTSDIR}/graphics/jpeg \
- kdecore\\.1\\.:${PORTSDIR}/x11/kdelibs \
- kdeui\\.1\\.:${PORTSDIR}/x11/kdelibs
-
-BROKEN= build
-
-BROKEN_ELF= depends on kdelibs
+ kdecore.1:${PORTSDIR}/x11/kdelibs \
+ kdeui.1:${PORTSDIR}/x11/kdelibs
USE_QT= yes
HAS_CONFIGURE= yes
@@ -31,8 +27,6 @@ CONFIGURE_ARGS= "--prefix=$(PREFIX)" \
CONFIGURE_ENV= CXXFLAGS="$(CFLAGS)" \
INSTALL_SCRIPT="install -c -m 555"
-WRKSRC= ${WRKDIR}/korganizer
-
pre-configure:
${RM} -rf -- $(WRKSRC)/src/.deps $(WRKSRC)/config.cache
diff --git a/deskutils/korganizer/distinfo b/deskutils/korganizer/distinfo
index 3981e5a618ea..6b178c061e36 100644
--- a/deskutils/korganizer/distinfo
+++ b/deskutils/korganizer/distinfo
@@ -1 +1 @@
-MD5 (korganizer-0.9.tar.gz) = e361788b550aa50d5894b5b6c603a57e
+MD5 (korganizer-0.9.13.tar.gz) = f7fbd58f82ddffae9a205d4a6fcb40d8
diff --git a/deskutils/korganizer/files/patch-aa b/deskutils/korganizer/files/patch-aa
index cdde919fb545..f74912f05e9a 100644
--- a/deskutils/korganizer/files/patch-aa
+++ b/deskutils/korganizer/files/patch-aa
@@ -1,11 +1,36 @@
---- src/Makefile.in.orig Sat May 23 18:08:36 1998
-+++ src/Makefile.in Sat May 23 18:08:51 1998
-@@ -160,7 +160,7 @@
+--- src/calobject.cpp.orig Fri Oct 2 13:47:51 1998
++++ src/calobject.cpp Fri Oct 2 13:49:31 1998
+@@ -79,13 +79,17 @@
+ tmpStr = config->readEntry("Time Zone");
+ int dstSetting = config->readNumEntry("Daylight Savings", 0);
+ extern long int timezone;
++#if 0
+ extern int daylight;
++#endif
+ time_t curtime;
+ curtime = time(0);
+ localtime(&curtime);
+ int hourOff = - ((timezone / 60) / 60);
++#if 0
+ if (daylight)
+ hourOff += 1;
++#endif
+ QString tzStr;
+ tzStr.sprintf("%.2d%.2d",
+ hourOff,
+@@ -96,6 +100,7 @@
+ config->writeEntry("Time Zone", tzStr.data());
+ }
+
++#if 0
+ // if daylight savings has changed since last load time, we need
+ // to rewrite these settings to the config file.
+ if ((daylight && !dstSetting) ||
+@@ -103,6 +108,7 @@
+ config->writeEntry("Time Zone", tzStr.data());
+ config->writeEntry("Daylight Savings", daylight);
+ }
++#endif
+
+ setTimeZone(tzStr.data());
- # the library search path.
- #korganizer_LDFLAGS = $(all_libraries) $(KDE_RPATH)
--korganizer_LDFLAGS = $(all_libraries) -Wl,-rpath -Wl,$(KDEDIR)/lib
-+korganizer_LDFLAGS = $(all_libraries)
-
- # the libraries to link against. Be aware of the order. First the libraries,
- # that depend on the following ones.
diff --git a/deskutils/korganizer/pkg-plist b/deskutils/korganizer/pkg-plist
index 32b9723246f6..39880bd2fad8 100644
--- a/deskutils/korganizer/pkg-plist
+++ b/deskutils/korganizer/pkg-plist
@@ -1,5 +1,15 @@
bin/korganizer
-share/applnk/Applications/korganizer.kdelnk
+bin/alarmd
+share/doc/HTML/en/korganizer/korganizer.html
+share/doc/HTML/en/korganizer/korganizer-1.html
+share/doc/HTML/en/korganizer/korganizer-2.html
+share/doc/HTML/en/korganizer/korganizer-3.html
+share/doc/HTML/en/korganizer/korganizer-4.html
+share/doc/HTML/en/korganizer/korganizer-5.html
+share/doc/HTML/en/korganizer/korganizer-6.html
+share/doc/HTML/en/korganizer/logotp3.gif
+share/doc/HTML/en/korganizer/index.html
+share/apps/korganizer/pics/smallcal.xpm
share/apps/korganizer/pics/1downarrow.xpm
share/apps/korganizer/pics/1leftarrow.xpm
share/apps/korganizer/pics/1rightarrow.xpm
@@ -9,30 +19,36 @@ share/apps/korganizer/pics/2leftarrow.xpm
share/apps/korganizer/pics/2rightarrow.xpm
share/apps/korganizer/pics/2uparrow.xpm
share/apps/korganizer/pics/3downarrow.xpm
+share/apps/korganizer/pics/3leftarrow.xpm
+share/apps/korganizer/pics/3rightarrow.xpm
share/apps/korganizer/pics/3uparrow.xpm
-share/apps/korganizer/pics/bell.xpm
-share/apps/korganizer/pics/checkedbox.xpm
share/apps/korganizer/pics/checkmark.xpm
+share/apps/korganizer/pics/checkedbox-mask.xpm
+share/apps/korganizer/pics/checkedbox.xpm
+share/apps/korganizer/pics/emptybox-mask.xpm
share/apps/korganizer/pics/emptybox.xpm
+share/apps/korganizer/pics/bell.xpm
share/apps/korganizer/pics/recur.xpm
-share/apps/korganizer/pics/smallcal.xpm
+share/apps/korganizer/toolbar/listicon.xpm
+share/apps/korganizer/toolbar/5dayicon.xpm
share/apps/korganizer/toolbar/dayicon.xpm
-share/apps/korganizer/toolbar/monthicon.xpm
+share/apps/korganizer/toolbar/agenda.xpm
+share/apps/korganizer/toolbar/weekicon.xpm
+share/apps/korganizer/toolbar/todayicon.xpm
share/apps/korganizer/toolbar/newevent.xpm
share/apps/korganizer/toolbar/newrecurevent.xpm
-share/apps/korganizer/toolbar/todayicon.xpm
-share/apps/korganizer/toolbar/weekicon.xpm
-share/doc/HTML/en/korganizer/korganizer-1.html
-share/doc/HTML/en/korganizer/korganizer-2.html
-share/doc/HTML/en/korganizer/korganizer-3.html
-share/doc/HTML/en/korganizer/korganizer-4.html
-share/doc/HTML/en/korganizer/korganizer-5.html
-share/doc/HTML/en/korganizer/korganizer-6.html
-share/doc/HTML/en/korganizer/korganizer.html
-share/doc/HTML/en/korganizer/logotp3.gif
-share/icons/korganizer.xpm
+share/apps/korganizer/toolbar/delete.xpm
+share/apps/korganizer/toolbar/monthicon.xpm
+share/apps/korganizer/toolbar/search.xpm
+share/apps/korganizer/toolbar/checkedclipboard.xpm
+share/apps/korganizer/toolbar/send.xpm
+share/locale/de/LC_MESSAGES/korganizer.mo
+share/locale/no/LC_MESSAGES/korganizer.mo
+share/locale/fi/LC_MESSAGES/korganizer.mo
share/icons/mini/korganizer.xpm
+share/icons/korganizer.xpm
share/mimelnk/text/x-vcalendar.kdelnk
+share/applnk/Applications/korganizer.kdelnk
@dirrm share/apps/korganizer/pics
@dirrm share/apps/korganizer/toolbar
@dirrm share/doc/HTML/en/korganizer