aboutsummaryrefslogtreecommitdiff
path: root/deskutils/logjam
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2004-12-22 00:40:53 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2004-12-22 00:40:53 +0000
commit956022222b77699977b7df1494af4f1b841c4365 (patch)
tree5716e957ebf07f16b4b009cff494235fb17be5a9 /deskutils/logjam
parentee53836747e0be27c14707183d82b95b0602bb9e (diff)
downloadports-956022222b77699977b7df1494af4f1b841c4365.tar.gz
ports-956022222b77699977b7df1494af4f1b841c4365.zip
[ patch ] fix logjam + gtkhtml3 problem
LogJam's configure script tries to find libgtkhtml-3.0, while we have libgtkhtml-3.1 in ports tree. Of cource, it fails to do so and as a result we have logjam compiled without gtkhtml support even if gtkhtml3 is installed. PR: ports/74260 Submitted by: Roman Bogorodskiy <bogorodskiy@inbox.ru>
Notes
Notes: svn path=/head/; revision=124758
Diffstat (limited to 'deskutils/logjam')
-rw-r--r--deskutils/logjam/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/deskutils/logjam/Makefile b/deskutils/logjam/Makefile
index e27853511461..893e01d5008a 100644
--- a/deskutils/logjam/Makefile
+++ b/deskutils/logjam/Makefile
@@ -7,7 +7,7 @@
PORTNAME= logjam
PORTVERSION= 4.4.0
-PORTREVISION?= 3
+PORTREVISION= 4
CATEGORIES= deskutils
MASTER_SITES= http://logjam.danga.com/download/
@@ -24,6 +24,7 @@ LIB_DEPENDS= curl.3:${PORTSDIR}/ftp/curl
MAN1= logjam.1
+USE_REINPLACE= yes
USE_BZIP2= yes
USE_GMAKE= yes
WANT_GNOME= yes
@@ -69,4 +70,7 @@ pre-everything::
@${ECHO_MSG} " WITH_XMMS Enable XMMS music detection"
@${ECHO_MSG} ""
+post-patch:
+ @${REINPLACE_CMD} -e 's|libgtkhtml-3.0|libgtkhtml-3.1|g' ${WRKSRC}/configure
+
.include <bsd.port.post.mk>