aboutsummaryrefslogtreecommitdiff
path: root/deskutils/logjam
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2006-08-20 09:35:47 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2006-08-20 09:35:47 +0000
commit898e6c376c15b72a5c2a381cbae16cd9e0b336f9 (patch)
tree8395a5c47c184a3b5859ece85bb1386baa89d4bb /deskutils/logjam
parent11f4646b11b3d00dd2659888ca47f6541896e160 (diff)
downloadports-898e6c376c15b72a5c2a381cbae16cd9e0b336f9.tar.gz
ports-898e6c376c15b72a5c2a381cbae16cd9e0b336f9.zip
Add two additional patches, one of them with backdated entries fix and
another provides a keyboard shortcut for insertion of images; and bump PORTREVISION. PR: 102237 Submitted by: danfe
Notes
Notes: svn path=/head/; revision=171018
Diffstat (limited to 'deskutils/logjam')
-rw-r--r--deskutils/logjam/Makefile1
-rw-r--r--deskutils/logjam/files/patch-protocol-liblivejournal-livejournal-entry.c15
-rw-r--r--deskutils/logjam/files/patch-src-menu.c10
3 files changed, 26 insertions, 0 deletions
diff --git a/deskutils/logjam/Makefile b/deskutils/logjam/Makefile
index 982b55c399ae..2c4ddfd9a765 100644
--- a/deskutils/logjam/Makefile
+++ b/deskutils/logjam/Makefile
@@ -7,6 +7,7 @@
PORTNAME= logjam
PORTVERSION= 4.5.3
+PORTREVISION= 1
CATEGORIES= deskutils
MASTER_SITES= http://logjam.danga.com/download/
diff --git a/deskutils/logjam/files/patch-protocol-liblivejournal-livejournal-entry.c b/deskutils/logjam/files/patch-protocol-liblivejournal-livejournal-entry.c
new file mode 100644
index 000000000000..c81d0ed04037
--- /dev/null
+++ b/deskutils/logjam/files/patch-protocol-liblivejournal-livejournal-entry.c
@@ -0,0 +1,15 @@
+--- protocol/liblivejournal/livejournal/entry.c.orig Thu Aug 17 01:40:10 2006
++++ protocol/liblivejournal/livejournal/entry.c Thu Aug 17 01:45:24 2006
+@@ -610,6 +610,12 @@
+ else if (g_ascii_strcasecmp(key, "time") == 0) {
+ if (entry) lj_ljdate_to_tm(val, &entry->time);
+ }
++ else if (g_ascii_strcasecmp(key, "backdated") == 0) {
++ if (entry && val[0]) {
++ if (g_ascii_strcasecmp(val, "yes") == 0)
++ entry->backdated = TRUE;
++ }
++ }
+ else return FALSE;
+
+ return TRUE;
diff --git a/deskutils/logjam/files/patch-src-menu.c b/deskutils/logjam/files/patch-src-menu.c
new file mode 100644
index 000000000000..14f2e328fd50
--- /dev/null
+++ b/deskutils/logjam/files/patch-src-menu.c
@@ -0,0 +1,10 @@
+--- src/menu.c.orig Mon Oct 24 00:11:08 2005
++++ src/menu.c Thu Aug 17 02:01:02 2006
+@@ -408,7 +408,7 @@
+ 0, NULL },
+ { "/Insert/---", NULL, NULL, 0, "<Separator>" },
+ { N_("/Insert/_Link..."), "<ctl>L", menu_make_link },
+-{ N_("/Insert/_Image..."), NULL, menu_insert_image },
++{ N_("/Insert/_Image..."), "<ctl><alt>P", menu_insert_image },
+ { N_("/Insert/_Journal Link..."), "<ctl><alt>L", menu_make_journal_link },
+ { N_("/Insert/lj-_cut..."), "<ctl><alt>X", menu_ljcut, 0, NULL },