aboutsummaryrefslogtreecommitdiff
path: root/deskutils/mcatalog/Makefile
diff options
context:
space:
mode:
authorTom McLaughlin <tmclaugh@FreeBSD.org>2006-01-14 03:24:03 +0000
committerTom McLaughlin <tmclaugh@FreeBSD.org>2006-01-14 03:24:03 +0000
commitd0b304ace051ab51eb8c38097606fc5271a21107 (patch)
tree864d3c7cab1019495ca85b22452101b9059215e9 /deskutils/mcatalog/Makefile
parent957238d301e5de01fb9e75add9de88b0a57c7319 (diff)
downloadports-d0b304ace051ab51eb8c38097606fc5271a21107.tar.gz
ports-d0b304ace051ab51eb8c38097606fc5271a21107.zip
- Convert to USE_GECKO [1]
- Convert to USE_SQLITE [2] PR: 89023 [2] Submitted by: mezz [1], Scot Hetzel <swhetzel@gmail.com> [2]
Notes
Notes: svn path=/head/; revision=153418
Diffstat (limited to 'deskutils/mcatalog/Makefile')
-rw-r--r--deskutils/mcatalog/Makefile29
1 files changed, 7 insertions, 22 deletions
diff --git a/deskutils/mcatalog/Makefile b/deskutils/mcatalog/Makefile
index 5631b85b42b9..24af2be72c10 100644
--- a/deskutils/mcatalog/Makefile
+++ b/deskutils/mcatalog/Makefile
@@ -3,7 +3,7 @@
# Whom: Mezz <mezz@FreeBSD.org>
#
# $FreeBSD$
-# $Id: Makefile,v 1.9 2005/10/22 06:02:34 tmclau02 Exp $
+# $Id: Makefile,v 1.12 2006/01/11 00:29:46 tmclau02 Exp $
#
PORTNAME= mcatalog
@@ -18,22 +18,13 @@ COMMENT= An application for catalogue films and books
BUILD_DEPENDS= gapi2-parser:${PORTSDIR}/x11-toolkits/gtk-sharp20 \
${X11BASE}/libdata/pkgconfig/evolution-sharp.pc:${PORTSDIR}/mail/evolution-sharp \
${X11BASE}/libdata/pkgconfig/gecko-sharp-2.0.pc:${PORTSDIR}/www/gecko-sharp20
-LIB_DEPENDS= sqlite.2:${PORTSDIR}/databases/sqlite2
RUN_DEPENDS= gapi2-parser:${PORTSDIR}/x11-toolkits/gtk-sharp20 \
${X11BASE}/libdata/pkgconfig/evolution-sharp.pc:${PORTSDIR}/mail/evolution-sharp \
${X11BASE}/libdata/pkgconfig/gecko-sharp-2.0.pc:${PORTSDIR}/www/gecko-sharp20
-.if !defined(WITH_MOZILLA)
-MOZILLA= mozilla
-.else
-.if ${WITH_MOZILLA}=="firefox"
-MOZILLA= firefox
-.else
-MOZILLA= mozilla
-.endif
-.endif
-
+USE_GECKO= mozilla firefox
USE_GNOME= gnomeprefix gnomehack gconf2 intlhack
+USE_SQLITE= 2
USE_GMAKE= yes
USE_X_PREFIX= yes
USE_AUTOTOOLS= libtool:15
@@ -43,20 +34,12 @@ CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
DOCS= AUTHORS COPYING ChangeLog NEWS README TODO
GCONF_SCHEMAS= mcatalog.schemas
-pre-everything::
- @${ECHO_MSG} ""
- @${ECHO_MSG} " By default ${PORTNAME} uses www/mozilla for html rendering, but you can"
- @${ECHO_MSG} " change this by defining WITH_MOZILLA to one of the following values:"
- @${ECHO_MSG} ""
- @${ECHO_MSG} " firefox "
- @${ECHO_MSG} ""
-
post-patch:
@${REINPLACE_CMD} -e 's|/pixmaps/mcatalog|/pixmaps|g' \
${WRKSRC}/images/Makefile.in
@${REINPLACE_CMD} -e 's|@prefix@/share|${PREFIX}/share/gnome|g' \
${WRKSRC}/mcatalog.desktop.in
- @${REINPLACE_CMD} -e 's|%%MOZILLA%%|${X11BASE}/lib/${MOZILLA}|g' \
+ @${REINPLACE_CMD} -e 's|%%MOZILLA%%|${X11BASE}/lib/${GECKO}|g' \
${WRKSRC}/src/mcatalog.in
.ifndef (NOPORTDOCS)
@@ -68,4 +51,6 @@ post-install:
.endif
.include "${.CURDIR}/../../lang/mono/bsd.mono.mk"
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.include "${.CURDIR}/../../www/mozilla/bsd.gecko.mk"
+.include <bsd.port.post.mk>