aboutsummaryrefslogtreecommitdiff
path: root/deskutils/orage
diff options
context:
space:
mode:
authorOlivier Duchateau <olivierd@FreeBSD.org>2013-02-02 10:39:40 +0000
committerOlivier Duchateau <olivierd@FreeBSD.org>2013-02-02 10:39:40 +0000
commitf484662326e16958487084e77731719d63a9b957 (patch)
treebfcd9d58721cac4a83f01b44b5fe78747ed05844 /deskutils/orage
parentac23977c27bd92ecf6794aeb3a368aec64ae97e5 (diff)
downloadports-f484662326e16958487084e77731719d63a9b957.tar.gz
ports-f484662326e16958487084e77731719d63a9b957.zip
- Update to 4.8.4
- Use USE_PKGCONFIG - Remove uneeded patch (in post-patch target) - Remove ABI version numbers in LIB_DEPENDS - Add patch, which fixes bug #9249 (taken from project repository) Approved by: rene, miwi (mentors, implicit)
Notes
Notes: svn path=/head/; revision=311419
Diffstat (limited to 'deskutils/orage')
-rw-r--r--deskutils/orage/Makefile21
-rw-r--r--deskutils/orage/distinfo4
-rw-r--r--deskutils/orage/files/patch-src__event-list.c37
3 files changed, 48 insertions, 14 deletions
diff --git a/deskutils/orage/Makefile b/deskutils/orage/Makefile
index 804ae8b4f01a..2923eb629434 100644
--- a/deskutils/orage/Makefile
+++ b/deskutils/orage/Makefile
@@ -2,24 +2,24 @@
# $FreeBSD$
PORTNAME= orage
-PORTVERSION= 4.8.3
-PORTREVISION= 2
+PORTVERSION= 4.8.4
CATEGORIES= deskutils xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
-MASTER_SITE_SUBDIR=/src/apps/${PORTNAME}/${PORTVERSION:R}
+MASTER_SITE_SUBDIR=src/apps/${PORTNAME}/${PORTVERSION:R}
DIST_SUBDIR= xfce4
MAINTAINER= xfce@FreeBSD.org
COMMENT= A calendar application to manage your time with Xfce 4
-LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt
+LIB_DEPENDS= popt:${PORTSDIR}/devel/popt
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
USE_BZIP2= yes
USE_GETTEXT= yes
USE_GMAKE= yes
-USE_GNOME= gnomehack gtk20 intltool intlhack pkgconfig desktopfileutils
+USE_GNOME= gnomehack gtk20 intltool intlhack desktopfileutils
+USE_PKGCONFIG= build
USE_XFCE= configenv libmenu panel
USE_XORG= xext xrender xinerama xi xrandr xcursor xcomposite xdamage x11 \
xfixes
@@ -31,7 +31,7 @@ ICAL_DESC= libical support
MAN1= globaltime.1 orage.1 tz_convert.1
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MBDB}
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-configure
@@ -54,7 +54,7 @@ PLIST_SUB+= WITH_ICAL=""
.endif
.if ${PORT_OPTIONS:MDBUS}
-LIB_DEPENDS+= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
+LIB_DEPENDS+= dbus-glib-1:${PORTSDIR}/devel/dbus-glib
CONFIGURE_ARGS+=--enable-dbus
PLIST_SUB+= DBUS=""
.else
@@ -63,7 +63,7 @@ PLIST_SUB+= DBUS="@comment "
.endif
.if ${PORT_OPTIONS:MNOTIFY}
-LIB_DEPENDS+= notify.4:${PORTSDIR}/devel/libnotify
+LIB_DEPENDS+= notify:${PORTSDIR}/devel/libnotify
CONFIGURE_ARGS+=--enable-libnotify
.else
CONFIGURE_ARGS+=--disable-libnotify
@@ -75,9 +75,6 @@ post-patch:
s|%%BDB_LIB_DIR%%|${BDB_LIB_DIR}|g ; \
s|%%BDB_LIB_NAME%%|${BDB_LIB_NAME}|g' ${WRKSRC}/configure
.endif
-.if empty(PORT_OPTIONS:MICAL)
- @${REINPLACE_CMD} -e 's|libical-|no-&|g' ${WRKSRC}/configure
-.endif
@${REINPLACE_CMD} -e 's|echo aout|echo elf|g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|(datadir)/orage/doc/C|(datadir)/doc/orage/C|' \
${WRKSRC}/doc/C/Makefile.in \
@@ -86,4 +83,4 @@ post-patch:
post-install:
@-update-desktop-database
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/deskutils/orage/distinfo b/deskutils/orage/distinfo
index 744b07dde4b4..e97835a7b1fe 100644
--- a/deskutils/orage/distinfo
+++ b/deskutils/orage/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xfce4/orage-4.8.3.tar.bz2) = 9a5805c8a70de0cae67ae1a6282463bbd059d6a4d080f93ffb13f92aaacdbf2e
-SIZE (xfce4/orage-4.8.3.tar.bz2) = 2438461
+SHA256 (xfce4/orage-4.8.4.tar.bz2) = b19df727da9da48b979e238ac7113c803976de80bd1e2dadf6d84b864956dfd5
+SIZE (xfce4/orage-4.8.4.tar.bz2) = 2516021
diff --git a/deskutils/orage/files/patch-src__event-list.c b/deskutils/orage/files/patch-src__event-list.c
new file mode 100644
index 000000000000..cd34a0290a63
--- /dev/null
+++ b/deskutils/orage/files/patch-src__event-list.c
@@ -0,0 +1,37 @@
+--- ./src/event-list.c.orig 2013-02-01 10:11:19.000000000 +0000
++++ ./src/event-list.c 2013-02-01 17:22:20.000000000 +0000
+@@ -373,9 +373,10 @@
+ guint len = 50;
+
+ stime = format_time(el, appt, par);
+- if (appt->alarmtime != 0)
+- if (appt->sound != NULL)
+- flags[0] = 'S';
++ if (appt->display_alarm_orage || appt->display_alarm_notify
++ || appt->sound_alarm || appt->procedure_alarm)
++ if (appt->alarm_persistent)
++ flags[0] = 'P';
+ else
+ flags[0] = 'A';
+ else
+@@ -391,8 +392,10 @@
+ flags[1] = 'M';
+ else if (appt->freq == XFICAL_FREQ_YEARLY)
+ flags[1] = 'Y';
++ else if (appt->freq == XFICAL_FREQ_HOURLY)
++ flags[1] = 'H';
+ else
+- flags[1] = 'n';
++ flags[1] = '?';
+
+ if (appt->availability != 0)
+ flags[2] = 'B';
+@@ -1320,7 +1323,7 @@
+ gtk_tree_view_append_column(GTK_TREE_VIEW(el->TreeView), col);
+ gtk_tree_view_column_set_visible(col, FALSE);
+
+- gtk_tooltips_set_tip(el->Tooltips, el->TreeView, _("Double click line to edit it.\n\nFlags in order:\n\t 1. Alarm: n=no alarm\n\t\t A=visual Alarm S=also Sound alarm\n\t 2. Recurrence: n=no recurrence\n\t\t D=Daily W=Weekly M=Monthly Y=Yearly\n\t 3. Type: f=free B=Busy\n\t 4. Located in file:\n\t\tO=Orage A=Archive F=Foreign\n\t 5. Appointment type:\n\t\tE=Event T=Todo J=Journal"), NULL);
++ gtk_tooltips_set_tip(el->Tooltips, el->TreeView, _("Double click line to edit it.\n\nFlags in order:\n\t 1. Alarm: n=no alarm\n\t\t A=Alarm is set P=Persistent alarm is set\n\t 2. Recurrence: n=no recurrence\n\t\t H=Hourly D=Daily W=Weekly M=Monthly Y=Yearly\n\t 3. Type: f=free B=Busy\n\t 4. Located in file:\n\t\tO=Orage A=Archive F=Foreign\n\t 5. Appointment type:\n\t\tE=Event T=Todo J=Journal"), NULL);
+
+ g_signal_connect(el->TreeView, "row-activated",
+ G_CALLBACK(editEvent), el);