aboutsummaryrefslogtreecommitdiff
path: root/deskutils/org-mode.el
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2007-02-18 21:13:32 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2007-02-18 21:13:32 +0000
commit3dfa9ac510777a06129276019e87f6a71c5dfd2a (patch)
treefa58cf33332d45871c1cb603b14d95be149adce1 /deskutils/org-mode.el
parentaed967f67ea080506e77e09c5249a7c791c34dc9 (diff)
downloadports-3dfa9ac510777a06129276019e87f6a71c5dfd2a.tar.gz
ports-3dfa9ac510777a06129276019e87f6a71c5dfd2a.zip
Org-mode is a mode for keeping notes, maintaining ToDo lists, and
doing project planning with a fast and effective plain-text system. Org-mode develops organizational tasks around NOTES files that contain information about projects as plain text. Org-mode is implemented on top of outline-mode, which makes it possible to keep the content of large files well structured. Visibility cycling and structure editing help to work with the tree. Tables are easily created with a built-in table editor. Org-mode supports ToDo items, deadlines, time stamps, and scheduling. It dynamically compiles entries into an agenda. Plain text URL-like links connect to websites, emails, Usenet messages, BBDB entries, and any files related to the projects. For printing and sharing of notes, an Org-mode file can be exported as a structured ASCII file, or as HTML. WWW: http://staff.science.uva.nl/~dominik/Tools/org/ PR: ports/109230 Submitted by: Kai Wang <kaiw27 at gmail.com>
Notes
Notes: svn path=/head/; revision=185474
Diffstat (limited to 'deskutils/org-mode.el')
-rw-r--r--deskutils/org-mode.el/Makefile75
-rw-r--r--deskutils/org-mode.el/distinfo3
-rw-r--r--deskutils/org-mode.el/files/patch-Makefile37
-rw-r--r--deskutils/org-mode.el/pkg-descr16
-rw-r--r--deskutils/org-mode.el/pkg-message6
-rw-r--r--deskutils/org-mode.el/pkg-plist14
6 files changed, 151 insertions, 0 deletions
diff --git a/deskutils/org-mode.el/Makefile b/deskutils/org-mode.el/Makefile
new file mode 100644
index 000000000000..03a8aa7feb04
--- /dev/null
+++ b/deskutils/org-mode.el/Makefile
@@ -0,0 +1,75 @@
+# New ports collection makefile for: org-mode.el
+# Date created: 2007-02-15
+# Whom: Kai Wang <kaiw27@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= org-mode.el
+PORTVERSION= 4.64
+CATEGORIES= deskutils elisp
+MASTER_SITES= http://staff.science.uva.nl/~dominik/Tools/org/ \
+ http://web.student.chalmers.se/~kaiw/FreeBSD/disfiles/
+PKGNAMESUFFIX= -${EMACS_PORT_NAME}
+DISTNAME= org-${PORTVERSION}
+
+MAINTAINER= kaiw27@gmail.com
+COMMENT= An Emacs mode for notes and project planning
+
+USE_EMACS= yes
+USE_GMAKE= yes
+EMACS_PORT_NAME?= emacs21
+
+INFO= org
+
+.if !defined(NOPORTDOCS)
+BUILD_DEPENDS+= texi2html:${PORTSDIR}/textproc/texi2html
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if (${EMACS_PORT_NAME} == "xemacs21") || \
+ (${EMACS_PORT_NAME} == "xemacs21-mule") || \
+ (${EMACS_PORT_NAME} == "xemacs-devel") || \
+ (${EMACS_PORT_NAME} == "xemacs-devel-mule") || \
+ (${EMACS_PORT_NAME} == "xemacs-mule-xft")
+PLIST_SUB+= XEMACS=""
+.else
+PLIST_SUB+= XEMACS="@comment "
+.endif
+
+post-patch:
+.if (${EMACS_PORT_NAME} == "xemacs21") || \
+ (${EMACS_PORT_NAME} == "xemacs21-mule") || \
+ (${EMACS_PORT_NAME} == "xemacs-devel") || \
+ (${EMACS_PORT_NAME} == "xemacs-devel-mule") || \
+ (${EMACS_PORT_NAME} == "xemacs-mule-xft")
+ ${REINPLACE_CMD} -Ee \
+ 's%^(EMACS=)emacs%\1xemacs%; \
+ s%^(lispdir =.*)/share/emacs%\1/lib/xemacs%' \
+ ${WRKSRC}/Makefile
+.endif
+
+pre-build:
+.if (${EMACS_PORT_NAME} == "xemacs21") || \
+ (${EMACS_PORT_NAME} == "xemacs21-mule") || \
+ (${EMACS_PORT_NAME} == "xemacs-devel") || \
+ (${EMACS_PORT_NAME} == "xemacs-devel-mule") || \
+ (${EMACS_PORT_NAME} == "xemacs-mule-xft")
+ cd ${WRKSRC} && ${GMAKE} PREFIX=${PREFIX} install-noutline
+.endif
+
+post-build:
+ ${MV} ${WRKSRC}/org ${WRKSRC}/org.info
+
+post-install:
+.if !defined(NOPORTDOCS)
+ cd ${WRKSRC} && ${GMAKE} org.html
+ ${MKDIR} ${DOCSDIR}
+.for i in org.html org.pdf orgcard.pdf
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+ ${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/deskutils/org-mode.el/distinfo b/deskutils/org-mode.el/distinfo
new file mode 100644
index 000000000000..fd94c5d35356
--- /dev/null
+++ b/deskutils/org-mode.el/distinfo
@@ -0,0 +1,3 @@
+MD5 (org-4.64.tar.gz) = cf553b44bdf1521bf0dab1ec27b4a4df
+SHA256 (org-4.64.tar.gz) = eafda30d3700f729958c530d176911134708d85fa3a44ad10865e87db9207764
+SIZE (org-4.64.tar.gz) = 907283
diff --git a/deskutils/org-mode.el/files/patch-Makefile b/deskutils/org-mode.el/files/patch-Makefile
new file mode 100644
index 000000000000..428b93c062b4
--- /dev/null
+++ b/deskutils/org-mode.el/files/patch-Makefile
@@ -0,0 +1,37 @@
+--- Makefile.orig Fri Feb 16 00:45:34 2007
++++ Makefile Fri Feb 16 00:56:08 2007
+@@ -14,13 +14,13 @@
+ EMACS=emacs
+
+ # Where local software is found
+-prefix=/usr/local
++PREFIX=/usr/local
+
+ # Where local lisp files go.
+-lispdir = $(prefix)/share/emacs/site-lisp
++lispdir = $(PREFIX)/share/emacs/site-lisp
+
+ # Where info files go.
+-infodir = $(prefix)/info
++infodir = $(PREFIX)/info
+
+ ##----------------------------------------------------------------------
+ ## YOU MAY NEED TO EDIT THESE
+@@ -59,7 +59,7 @@
+ ELCFILES = $(LISPFILES:.el=.elc)
+ DOCFILES = org.texi org.pdf org orgcard.tex orgcard.pdf
+ TEXIFILES = org.texi
+-INFOFILES = org
++INFOFILES = org.info
+ HTMLDIR = /home/dominik/public_html/Tools/org
+
+ .SUFFIXES: .el .elc .texi
+@@ -70,7 +70,7 @@
+
+ all: $(ELCFILES)
+
+-install: install-lisp
++install: install-lisp install-info
+
+ doc: org.html org.pdf orgcard.pdf
+
diff --git a/deskutils/org-mode.el/pkg-descr b/deskutils/org-mode.el/pkg-descr
new file mode 100644
index 000000000000..918afbe5ef4f
--- /dev/null
+++ b/deskutils/org-mode.el/pkg-descr
@@ -0,0 +1,16 @@
+Org-mode is a mode for keeping notes, maintaining ToDo lists, and
+doing project planning with a fast and effective plain-text system.
+
+Org-mode develops organizational tasks around NOTES files that contain
+information about projects as plain text. Org-mode is implemented on
+top of outline-mode, which makes it possible to keep the content of
+large files well structured. Visibility cycling and structure editing
+help to work with the tree. Tables are easily created with a built-in
+table editor. Org-mode supports ToDo items, deadlines, time stamps,
+and scheduling. It dynamically compiles entries into an agenda. Plain
+text URL-like links connect to websites, emails, Usenet messages, BBDB
+entries, and any files related to the projects. For printing and
+sharing of notes, an Org-mode file can be exported as a structured
+ASCII file, or as HTML.
+
+WWW: http://staff.science.uva.nl/~dominik/Tools/org/
diff --git a/deskutils/org-mode.el/pkg-message b/deskutils/org-mode.el/pkg-message
new file mode 100644
index 000000000000..79ed408a3fc2
--- /dev/null
+++ b/deskutils/org-mode.el/pkg-message
@@ -0,0 +1,6 @@
+********************************************************************
+* To use org-mode in Emacs/XEmacs, add the following line to your *
+* ~/.emacs: *
+* *
+* (require 'org-install) *
+********************************************************************
diff --git a/deskutils/org-mode.el/pkg-plist b/deskutils/org-mode.el/pkg-plist
new file mode 100644
index 000000000000..888b1b7e2b16
--- /dev/null
+++ b/deskutils/org-mode.el/pkg-plist
@@ -0,0 +1,14 @@
+%%PORTDOCS%%%%DOCSDIR%%/org.html
+%%PORTDOCS%%%%DOCSDIR%%/org.pdf
+%%PORTDOCS%%%%DOCSDIR%%/orgcard.pdf
+%%EMACS_SITE_LISPDIR%%/org-install.el
+%%EMACS_SITE_LISPDIR%%/org-install.elc
+%%EMACS_SITE_LISPDIR%%/org-mouse.el
+%%EMACS_SITE_LISPDIR%%/org-mouse.elc
+%%EMACS_SITE_LISPDIR%%/org-publish.el
+%%EMACS_SITE_LISPDIR%%/org-publish.elc
+%%EMACS_SITE_LISPDIR%%/org.el
+%%EMACS_SITE_LISPDIR%%/org.elc
+%%XEMACS%%%%EMACS_SITE_LISPDIR%%/noutline.el
+%%XEMACS%%%%EMACS_SITE_LISPDIR%%/noutline.elc
+%%PORTDOCS%%@dirrm %%DOCSDIR%%