aboutsummaryrefslogtreecommitdiff
path: root/deskutils/osmo
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2009-10-20 03:27:56 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2009-10-20 03:27:56 +0000
commitd86078091f4db325a8f848d821daaf4400b01145 (patch)
treeb83ff365e88950c3b92a0912df402cb0a6851b43 /deskutils/osmo
parentee35e789be15711b67d61c54af80bfd58ed680ca (diff)
downloadports-d86078091f4db325a8f848d821daaf4400b01145.tar.gz
ports-d86078091f4db325a8f848d821daaf4400b01145.zip
Osmo is a handy personal organizer, which includes calendar, tasks
manager, address book and notes modules. It is a GTK+ based tool which uses a plain XML database to store all personal data. WWW: http://clayo.org/osmo PR: 139261 Submitted by: Charlie Kester <corky1951@comcast.net>
Notes
Notes: svn path=/head/; revision=243074
Diffstat (limited to 'deskutils/osmo')
-rw-r--r--deskutils/osmo/Makefile44
-rw-r--r--deskutils/osmo/distinfo3
-rw-r--r--deskutils/osmo/pkg-descr5
-rw-r--r--deskutils/osmo/pkg-plist46
4 files changed, 98 insertions, 0 deletions
diff --git a/deskutils/osmo/Makefile b/deskutils/osmo/Makefile
new file mode 100644
index 000000000000..fa77485ccd15
--- /dev/null
+++ b/deskutils/osmo/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: osmo
+# Date created: 29 Sep 2009
+# Whom: Charlie Kester <corky1951#comcast.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= osmo
+PORTVERSION= 0.2.8
+CATEGORIES= deskutils
+MASTER_SITES= SF/${PORTNAME}-pim/${PORTNAME}-pim/${PORTNAME}-${PORTVERSION}/
+
+MAINTAINER= corky1951@comcast.net
+COMMENT= A personal organizer
+
+LIB_DEPENDS= xml2:${PORTSDIR}/textproc/libxml2 \
+ notify:${PORTSDIR}/devel/libnotify \
+ ical:${PORTSDIR}/devel/libical \
+ tar:${PORTSDIR}/devel/libtar \
+ gringotts:${PORTSDIR}/security/libgringotts
+
+USE_GNOME= gtk20
+USE_GETTEXT= yes
+INSTALLS_ICONS= yes
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib"
+
+USE_GMAKE= yes
+
+MAN1= osmo.1
+
+POFILES= ca cs de el es fi fr hu it ja lt nl pl pt \
+ ru sv tr uk zh_CN
+
+MSGFMT= ${LOCALBASE}/bin/msgfmt
+
+pre-install:
+# workaround to problem in po makefile
+.for p in ${POFILES}
+ ${MSGFMT} -c ${WRKSRC}/po/$p.po -o ${WRKSRC}/po/$p.mo
+.endfor
+
+.include <bsd.port.mk>
diff --git a/deskutils/osmo/distinfo b/deskutils/osmo/distinfo
new file mode 100644
index 000000000000..56550da86e65
--- /dev/null
+++ b/deskutils/osmo/distinfo
@@ -0,0 +1,3 @@
+MD5 (osmo-0.2.8.tar.gz) = 7fa83efd27cd3ecc54e73f0ec4e91d81
+SHA256 (osmo-0.2.8.tar.gz) = 6d2fe3672a7b6fbe334ed5f2d99bb036057c2584c1ce2b836782adeff6c6f816
+SIZE (osmo-0.2.8.tar.gz) = 787611
diff --git a/deskutils/osmo/pkg-descr b/deskutils/osmo/pkg-descr
new file mode 100644
index 000000000000..6e8103f73ab8
--- /dev/null
+++ b/deskutils/osmo/pkg-descr
@@ -0,0 +1,5 @@
+Osmo is a handy personal organizer, which includes calendar, tasks
+manager, address book and notes modules. It is a GTK+ based tool
+which uses a plain XML database to store all personal data.
+
+WWW: http://clayo.org/osmo
diff --git a/deskutils/osmo/pkg-plist b/deskutils/osmo/pkg-plist
new file mode 100644
index 000000000000..0bef2925277e
--- /dev/null
+++ b/deskutils/osmo/pkg-plist
@@ -0,0 +1,46 @@
+bin/osmo
+share/applications/osmo.desktop
+share/icons/hicolor/16x16/apps/osmo.png
+share/icons/hicolor/22x22/apps/osmo.png
+share/icons/hicolor/24x24/apps/osmo.png
+share/icons/hicolor/32x32/apps/osmo.png
+share/icons/hicolor/48x48/apps/osmo.png
+share/icons/hicolor/scalable/apps/osmo.svg
+share/locale/ca/LC_MESSAGES/osmo.mo
+share/locale/cs/LC_MESSAGES/osmo.mo
+share/locale/de/LC_MESSAGES/osmo.mo
+share/locale/el/LC_MESSAGES/osmo.mo
+share/locale/es/LC_MESSAGES/osmo.mo
+share/locale/fi/LC_MESSAGES/osmo.mo
+share/locale/fr/LC_MESSAGES/osmo.mo
+share/locale/hu/LC_MESSAGES/osmo.mo
+share/locale/it/LC_MESSAGES/osmo.mo
+share/locale/ja/LC_MESSAGES/osmo.mo
+share/locale/lt/LC_MESSAGES/osmo.mo
+share/locale/nl/LC_MESSAGES/osmo.mo
+share/locale/pl/LC_MESSAGES/osmo.mo
+share/locale/pt/LC_MESSAGES/osmo.mo
+share/locale/ru/LC_MESSAGES/osmo.mo
+share/locale/sv/LC_MESSAGES/osmo.mo
+share/locale/tr/LC_MESSAGES/osmo.mo
+share/locale/uk/LC_MESSAGES/osmo.mo
+share/locale/zh_CN/LC_MESSAGES/osmo.mo
+share/pixmaps/osmo.png
+share/sounds/osmo/alarm.wav
+@dirrm share/sounds/osmo
+@dirrmtry share/sounds
+@dirrmtry share/icons/hicolor/scalable/apps
+@dirrmtry share/icons/hicolor/scalable
+@dirrmtry share/icons/hicolor/48x48/apps
+@dirrmtry share/icons/hicolor/48x48
+@dirrmtry share/icons/hicolor/32x32/apps
+@dirrmtry share/icons/hicolor/32x32
+@dirrmtry share/icons/hicolor/24x24/apps
+@dirrmtry share/icons/hicolor/24x24
+@dirrmtry share/icons/hicolor/22x22/apps
+@dirrmtry share/icons/hicolor/22x22
+@dirrmtry share/icons/hicolor/16x16/apps
+@dirrmtry share/icons/hicolor/16x16
+@dirrmtry share/icons/hicolor
+@dirrmtry share/icons
+@dirrmtry share/applications