aboutsummaryrefslogtreecommitdiff
path: root/deskutils/phpgroupware
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2001-03-30 21:15:41 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2001-03-30 21:15:41 +0000
commit8ba8fb6af6fc3532fbc411c0b0b49d3b84c80b12 (patch)
tree70901db2cbe60c95ad6f41dd614e3dc90d5180fe /deskutils/phpgroupware
parentb129c1bfda26a00dd8fe584e685fcd3ba49c81a5 (diff)
downloadports-8ba8fb6af6fc3532fbc411c0b0b49d3b84c80b12.tar.gz
ports-8ba8fb6af6fc3532fbc411c0b0b49d3b84c80b12.zip
Add phpgw_projects and phpgw_inventory to RUN_DEPENDS, to get the full
phpgroupware suite. Fix permissions for phpgroupware's files directory (707 is needed to access user files). Don't complain if files directory still contains files at deinstall time.
Notes
Notes: svn path=/head/; revision=40605
Diffstat (limited to 'deskutils/phpgroupware')
-rw-r--r--deskutils/phpgroupware/Makefile6
-rw-r--r--deskutils/phpgroupware/pkg-plist9
2 files changed, 10 insertions, 5 deletions
diff --git a/deskutils/phpgroupware/Makefile b/deskutils/phpgroupware/Makefile
index 014919151558..a5010b5867b1 100644
--- a/deskutils/phpgroupware/Makefile
+++ b/deskutils/phpgroupware/Makefile
@@ -13,12 +13,14 @@ DISTNAME= phpGroupWare-${PORTVERSION}
MAINTAINER= olgeni@FreeBSD.org
-RUN_DEPENDS= ${LOCALBASE}/libexec/apache/libphp4.so:${PORTSDIR}/www/mod_php4
+RUN_DEPENDS= ${LOCALBASE}/libexec/apache/libphp4.so:${PORTSDIR}/www/mod_php4 \
+ ${LOCALBASE}/www/data/phpgroupware/projects/index.php:${PORTSDIR}/deskutils/phpgw_projects \
+ ${LOCALBASE}/www/data/phpgroupware/inv/index.php:${PORTSDIR}/deskutils/phpgw_inventory
NO_BUILD= yes
WRKSRC= ${WRKDIR}/phpgroupware
do-install:
- @${CP} -r ${WRKDIR}/phpgroupware ${PREFIX}/www/data/
+ @${CP} -r ${WRKSRC} ${PREFIX}/www/data/
.include <bsd.port.mk>
diff --git a/deskutils/phpgroupware/pkg-plist b/deskutils/phpgroupware/pkg-plist
index ab45b90a1949..a3bc2311b9ab 100644
--- a/deskutils/phpgroupware/pkg-plist
+++ b/deskutils/phpgroupware/pkg-plist
@@ -787,9 +787,6 @@ www/data/phpgroupware/transy/templates/verdilak/images/navbar.gif
@dirrm www/data/phpgroupware/manual/templates
@dirrm www/data/phpgroupware/manual/inc
@dirrm www/data/phpgroupware/manual
-@dirrm www/data/phpgroupware/files/users
-@dirrm www/data/phpgroupware/files/groups
-@dirrm www/data/phpgroupware/files
@dirrm www/data/phpgroupware/filemanager/templates/default/images
@dirrm www/data/phpgroupware/filemanager/templates/default
@dirrm www/data/phpgroupware/filemanager/templates
@@ -825,4 +822,10 @@ www/data/phpgroupware/transy/templates/verdilak/images/navbar.gif
@dirrm www/data/phpgroupware/addressbook/templates
@dirrm www/data/phpgroupware/addressbook/inc
@dirrm www/data/phpgroupware/addressbook
+@exec chmod 707 %D/www/data/phpgroupware/files
+@exec chmod 707 %D/www/data/phpgroupware/files/users
+@exec chmod 707 %D/www/data/phpgroupware/files/groups
+@unexec rmdir %D/www/data/phpgroupware/files/users 2>/dev/null || true
+@unexec rmdir %D/www/data/phpgroupware/files/groups 2>/dev/null || true
+@unexec rmdir %D/www/data/phpgroupware/files 2>/dev/null || true
@unexec rmdir %D/www/data/phpgroupware 2>/dev/null || true