aboutsummaryrefslogtreecommitdiff
path: root/deskutils/plasma-applet-panelspacer/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-10-12 09:23:58 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-10-12 09:23:58 +0000
commite87d80fc4ea07eaedcf4aebd74398b8462649537 (patch)
tree6beba806d101cb1b66b3db069ed025fd75f74c2f /deskutils/plasma-applet-panelspacer/Makefile
parent2973530931241386095a34a2bb8d99123446d748 (diff)
downloadports-e87d80fc4ea07eaedcf4aebd74398b8462649537.tar.gz
ports-e87d80fc4ea07eaedcf4aebd74398b8462649537.zip
Panel Spacer is a Plasma applet for KDE4 that lets you put some blank space
between the other applets located in a panel. You can set a minimum fixed size and/or allow the spacer to stretch if there is free space on the right. Optionally, you can display a thin separator line. WWW: http://www.kde-look.org/content/show.php?content=89304 PR: ports/127956 Submitted by: Jason E. Hale <bsdkaffee at gmail.com>
Notes
Notes: svn path=/head/; revision=221466
Diffstat (limited to 'deskutils/plasma-applet-panelspacer/Makefile')
-rw-r--r--deskutils/plasma-applet-panelspacer/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/deskutils/plasma-applet-panelspacer/Makefile b/deskutils/plasma-applet-panelspacer/Makefile
new file mode 100644
index 000000000000..b829aa97e00c
--- /dev/null
+++ b/deskutils/plasma-applet-panelspacer/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: plasma-applet-panelspacer
+# Date Created: 2008-10-03
+# Whom: Jason E. Hale <bsdkaffee@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= panelspacer
+PORTVERSION= 0.1
+CATEGORIES= deskutils kde
+MASTER_SITES= http://www.kde-apps.org/CONTENT/content-files/
+PKGNAMEPREFIX= plasma-applet-
+DISTNAME= 89304-${PORTNAME}${PORTVERSION}
+
+MAINTAINER= bsdkaffee@gmail.com
+COMMENT= Panel spacer plasma applet for KDE4
+
+USE_CMAKE= yes
+USE_KDE4= automoc4 kdeprefix workspace
+USE_QT_VER= 4
+QT_COMPONENTS= gui dbus network opengl svg webkit xml \
+ qmake_build moc_build rcc_build uic_build
+
+WRKSRC= ${WRKDIR}/plasmaspacer_${PORTVERSION}
+
+PLIST_FILES= lib/kde4/plasma_applet_panelspacer.so \
+ share/kde4/services/plasma-applet-panelspacer.desktop
+
+.include <bsd.port.mk>