aboutsummaryrefslogtreecommitdiff
path: root/deskutils/plasma-applet-yawp/files
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-03-09 22:45:57 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-03-09 22:45:57 +0000
commitd63a260f2e296e52edf9dbfb29ad56b7500b6964 (patch)
tree89cf493021a2931de46eab965571db902d8ee48e /deskutils/plasma-applet-yawp/files
parentef0aee74af727f162a452e960e9ad4b408f0e118 (diff)
downloadports-d63a260f2e296e52edf9dbfb29ad56b7500b6964.tar.gz
ports-d63a260f2e296e52edf9dbfb29ad56b7500b6964.zip
- Update to 0.3.2
PR: 144093 Submitted by: Jason E. Hale <bsdkaffee@gmail.com> (maintainer)
Notes
Notes: svn path=/head/; revision=250801
Diffstat (limited to 'deskutils/plasma-applet-yawp/files')
-rw-r--r--deskutils/plasma-applet-yawp/files/patch-applet__CMakeLists.txt26
-rw-r--r--deskutils/plasma-applet-yawp/files/patch-applet__weatherdataprocessor.cpp11
-rw-r--r--deskutils/plasma-applet-yawp/files/patch-ions__CMakeLists.txt20
-rw-r--r--deskutils/plasma-applet-yawp/files/patch-po__CMakeLists.txt15
4 files changed, 72 insertions, 0 deletions
diff --git a/deskutils/plasma-applet-yawp/files/patch-applet__CMakeLists.txt b/deskutils/plasma-applet-yawp/files/patch-applet__CMakeLists.txt
new file mode 100644
index 000000000000..6abb26abaf07
--- /dev/null
+++ b/deskutils/plasma-applet-yawp/files/patch-applet__CMakeLists.txt
@@ -0,0 +1,26 @@
+--- ./applet/CMakeLists.txt.orig 2009-12-06 15:08:29.000000000 -0500
++++ ./applet/CMakeLists.txt 2010-02-05 03:23:32.000000000 -0500
+@@ -54,23 +54,3 @@
+ DESTINATION ${DATA_INSTALL_DIR}/desktoptheme/default/widgets/
+ )
+
+-
+-## This is needed for the CPack package generator.
+-#
+-INSTALL(TARGETS plasma_yawp
+- LIBRARY DESTINATION "${YAWP_PACK_INSTALL_LIB_DIR}"
+- ARCHIVE DESTINATION "${YAWP_PACK_INSTALL_LIB_DIR}"
+- RUNTIME DESTINATION "${YAWP_PACK_INSTALL_LIB_DIR}"
+- COMPONENT Libraries
+- )
+-
+-INSTALL(FILES plasma_yawp.desktop
+- DESTINATION "${YAWP_PACK_SERVICES_DIR}"
+- COMPONENT ApplicationData
+- )
+-
+-STRING(REGEX REPLACE "/usr/" "" YAWP_PACK_DATA_DIR "${DATA_INSTALL_DIR}/desktoptheme/default/widgets/")
+-INSTALL(FILES yawp_theme15.svg
+- DESTINATION "${YAWP_PACK_DATA_DIR}"
+- COMPONENT ApplicationData
+- )
diff --git a/deskutils/plasma-applet-yawp/files/patch-applet__weatherdataprocessor.cpp b/deskutils/plasma-applet-yawp/files/patch-applet__weatherdataprocessor.cpp
new file mode 100644
index 000000000000..ce084e883839
--- /dev/null
+++ b/deskutils/plasma-applet-yawp/files/patch-applet__weatherdataprocessor.cpp
@@ -0,0 +1,11 @@
+--- ./applet/weatherdataprocessor.cpp.orig 2009-12-06 15:08:29.000000000 -0500
++++ ./applet/weatherdataprocessor.cpp 2010-02-05 03:23:32.000000000 -0500
+@@ -30,7 +30,7 @@
+
+ //--- KDE4 ---
+
+-#include <values.h>
++#include <float.h>
+ #if KDE_IS_VERSION(4,3,70)
+ #include <KUnitConversion/Value>
+ #endif
diff --git a/deskutils/plasma-applet-yawp/files/patch-ions__CMakeLists.txt b/deskutils/plasma-applet-yawp/files/patch-ions__CMakeLists.txt
new file mode 100644
index 000000000000..e37bbd57d16d
--- /dev/null
+++ b/deskutils/plasma-applet-yawp/files/patch-ions__CMakeLists.txt
@@ -0,0 +1,20 @@
+--- ./ions/CMakeLists.txt.orig 2010-02-05 03:23:46.000000000 -0500
++++ ./ions/CMakeLists.txt 2010-02-05 03:24:02.000000000 -0500
+@@ -38,17 +38,3 @@
+ install( TARGETS ion_google DESTINATION ${PLUGIN_INSTALL_DIR})
+ install( FILES ${GOOGLE_DESKTOP} DESTINATION ${SERVICES_INSTALL_DIR})
+
+-
+-## This is needed for the CPack package generator.
+-#
+-INSTALL(TARGETS ion_accuweather ion_google
+- LIBRARY DESTINATION "${YAWP_PACK_INSTALL_LIB_DIR}"
+- ARCHIVE DESTINATION "${YAWP_PACK_INSTALL_LIB_DIR}"
+- RUNTIME DESTINATION "${YAWP_PACK_INSTALL_LIB_DIR}"
+- COMPONENT Libraries
+- )
+-
+-INSTALL(FILES ${ACCUWEATHER_DESKTOP} ${GOOGLE_DESKTOP}
+- DESTINATION "${YAWP_PACK_SERVICES_DIR}"
+- COMPONENT ApplicationData
+- )
diff --git a/deskutils/plasma-applet-yawp/files/patch-po__CMakeLists.txt b/deskutils/plasma-applet-yawp/files/patch-po__CMakeLists.txt
new file mode 100644
index 000000000000..3d08d3c06bdc
--- /dev/null
+++ b/deskutils/plasma-applet-yawp/files/patch-po__CMakeLists.txt
@@ -0,0 +1,15 @@
+--- ./po/CMakeLists.txt.orig 2010-02-05 03:24:20.000000000 -0500
++++ ./po/CMakeLists.txt 2010-02-05 03:24:41.000000000 -0500
+@@ -27,12 +27,6 @@
+ RENAME plasma_applet_yawp.mo
+ )
+
+- INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/${_lang}.gmo
+- DESTINATION "${YAWP_PACK_LOCALE_DIR}/${_lang}/LC_MESSAGES/"
+- RENAME plasma_applet_${CMAKE_PROJECT_NAME}.mo
+- COMPONENT ApplicationData
+- )
+-
+ LIST(APPEND _gmoFiles ${_gmoFile})
+ ENDFOREACH(_current_PO_FILE)
+ ADD_CUSTOM_TARGET(pofiles ALL DEPENDS ${_gmoFiles})