aboutsummaryrefslogtreecommitdiff
path: root/deskutils/pypanel
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-10-29 17:17:05 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-10-29 17:17:05 +0000
commit6fc08c679046e31cc16b6e79cf2305aadb54836c (patch)
treeb70066218517681f7c07f72ed1a970fafeeb5e0f /deskutils/pypanel
parent7af82ae36432a3d6e7b72d9ac6814a7b4da21fe7 (diff)
downloadports-6fc08c679046e31cc16b6e79cf2305aadb54836c.tar.gz
ports-6fc08c679046e31cc16b6e79cf2305aadb54836c.zip
Add pypanel.
PyPanel is a lightweight panel/taskbar written in Python and C for X11 window managers. It can be easily customized to match any desktop theme or taste. PyPanel works with EWMH compliant WMs (Openbox, PekWM, FVWM, ...). Some of the customizable features include: * Transparency with shading/tinting * Panel dimensions, location and layout * Font type and colors with Xft and shadow support * Button events/actions * Clock and workspace name display * System Tray (Notification Area) * Autohiding * Application Launcher * Custom Application Icons WWW: http://pypanel.sourceforge.net/ PR: ports/87907 Submitted by: Florian Unglaub <flo@btw23.de>
Notes
Notes: svn path=/head/; revision=146675
Diffstat (limited to 'deskutils/pypanel')
-rw-r--r--deskutils/pypanel/Makefile52
-rw-r--r--deskutils/pypanel/distinfo2
-rw-r--r--deskutils/pypanel/pkg-descr17
-rw-r--r--deskutils/pypanel/pkg-plist7
4 files changed, 78 insertions, 0 deletions
diff --git a/deskutils/pypanel/Makefile b/deskutils/pypanel/Makefile
new file mode 100644
index 000000000000..4b16c6a87a5f
--- /dev/null
+++ b/deskutils/pypanel/Makefile
@@ -0,0 +1,52 @@
+# New ports collection makefile for: pypanel
+# Date created: 24 October 2005
+# Whom: Florian Unglaub
+#
+# $FreeBSD$
+#
+
+PORTNAME= pypanel
+PORTVERSION= 2.4
+CATEGORIES= deskutils
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
+MASTER_SITE_SUBDIR= pypanel
+DISTNAME= PyPanel-${PORTVERSION}
+
+MAINTAINER= u0@rootofallevil.net
+COMMENT= Desktop panel written in Python
+
+LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2 \
+ Xft.2:${PORTSDIR}/x11-fonts/libXft \
+ Imlib2.3:${PORTSDIR}/graphics/imlib2
+BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/Xlib/X.py:${PORTSDIR}/x11-toolkits/py-xlib
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/Xlib/X.py:${PORTSDIR}/x11-toolkits/py-xlib
+
+USE_X_PREFIX= yes
+USE_REINPLACE= yes
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+PORTDOCS= *
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|/usr/bin/freetype-config|${LOCALBASE}/bin/freetype-config|; \
+ s|/usr/bin/imlib2-config|${LOCALBASE}/bin/imlib2-config|; \
+ s|/usr/X11R6/include|${X11BASE}/include|; \
+ s|"COPYING", "README", ||' ${WRKSRC}/setup.py
+ @${REINPLACE_CMD} -e 's|sysconfig\.get_python_lib()|"${PREFIX}/share"|' \
+ ${WRKSRC}/setup.py ${WRKSRC}/pypanel
+ @${REINPLACE_CMD} -e \
+ 's|/usr/lib/libImlib2.so.1|${LOCALBASE}/lib/libImlib2.so|' \
+ ${WRKSRC}/setup.py ${WRKSRC}/ppmodule.c
+ @${REINPLACE_CMD} -e 's|/etc|${PREFIX}/etc|' ${WRKSRC}/pypanel
+ @${REINPLACE_CMD} -e 's|/usr/share/imlib2|${LOCALBASE}/share/imlib2|' \
+ ${WRKSRC}/pypanelrc
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/deskutils/pypanel/distinfo b/deskutils/pypanel/distinfo
new file mode 100644
index 000000000000..d3ddcfdef579
--- /dev/null
+++ b/deskutils/pypanel/distinfo
@@ -0,0 +1,2 @@
+MD5 (PyPanel-2.4.tar.gz) = f1f9a2ed80be72ab36e748833618daba
+SIZE PyPanel-2.4.tar.gz) = 29857
diff --git a/deskutils/pypanel/pkg-descr b/deskutils/pypanel/pkg-descr
new file mode 100644
index 000000000000..6e28f5beb431
--- /dev/null
+++ b/deskutils/pypanel/pkg-descr
@@ -0,0 +1,17 @@
+PyPanel is a lightweight panel/taskbar written in Python and C for X11 window
+managers. It can be easily customized to match any desktop theme or
+taste. PyPanel works with EWMH compliant WMs (Openbox, PekWM, FVWM, ...).
+
+Some of the customizable features include:
+
+ * Transparency with shading/tinting
+ * Panel dimensions, location and layout
+ * Font type and colors with Xft and shadow support
+ * Button events/actions
+ * Clock and workspace name display
+ * System Tray (Notification Area)
+ * Autohiding
+ * Application Launcher
+ * Custom Application Icons
+
+WWW: http://pypanel.sourceforge.net/
diff --git a/deskutils/pypanel/pkg-plist b/deskutils/pypanel/pkg-plist
new file mode 100644
index 000000000000..6f6850ca8d3b
--- /dev/null
+++ b/deskutils/pypanel/pkg-plist
@@ -0,0 +1,7 @@
+bin/pypanel
+%%DATADIR%%/ppicon.png
+%%DATADIR%%/pypanelrc
+%%PYTHON_SITELIBDIR%%/ppmodule.so
+@dirrm %%DATADIR%%
+@unexec rmdir %D/%%PYTHON_SITELIBDIR%% 2>/dev/null || true
+@unexec rmdir %D/%%PYTHON_LIBDIR%% 2>/dev/null || true