aboutsummaryrefslogtreecommitdiff
path: root/deskutils/qtm/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-07-16 14:30:43 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-07-16 14:30:43 +0000
commit5138a941d9b260dd28692ccbd1d5d42d1339e143 (patch)
tree84f56dd2a90a557c868ea187bf0a65d250c330c4 /deskutils/qtm/Makefile
parent1619b83fe198f93717cdf3921533d7e86c5341f0 (diff)
downloadports-5138a941d9b260dd28692ccbd1d5d42d1339e143.tar.gz
ports-5138a941d9b260dd28692ccbd1d5d42d1339e143.zip
QTM allows the user to compose, format and submit entries to MT and
Wordpress blogs (and possibly other content management systems using the same interfaces; your mileage may vary). It uses the standard Blogger, MetaWeblog and Movable Type APIs. It requires Qt 4.1. WWW: http://qtm.blogistan.co.uk/ PR: ports/113931 Submitted by: Yinghong.Liu <relaxbsd at gmail.com>
Notes
Notes: svn path=/head/; revision=195739
Diffstat (limited to 'deskutils/qtm/Makefile')
-rw-r--r--deskutils/qtm/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/deskutils/qtm/Makefile b/deskutils/qtm/Makefile
new file mode 100644
index 000000000000..a6931438715e
--- /dev/null
+++ b/deskutils/qtm/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: qtm
+# Date created: 22 Jun 2007
+# Whom: Yinghong.Liu <relaxbsd@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= qtm
+PORTVERSION= 0.5.3
+CATEGORIES= deskutils
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR=catkin
+
+MAINTAINER= relaxbsd@gmail.com
+COMMENT= Blog management application based on Qt 4
+
+USE_QT_VER= 4
+QT_COMPONENTS= gui network corelib qmake uic xml moc
+PLIST_FILES= bin/QTM
+
+PORTDOCS= COPYING Changelog INSTALL README
+
+DESKTOP_ENTRIES= "QTM" \
+ "Weblog management application" \
+ "" \
+ "QTM" \
+ "Application;Network;" \
+ "false"
+
+pre-build:
+ @cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${QMAKE} -unix QTM.pro
+
+post-install:
+ @${MKDIR} ${PREFIX}/share/applications
+ @${INSTALL_PROGRAM} ${WRKSRC}/QTM ${PREFIX}/bin/
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for doc in ${PORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>