aboutsummaryrefslogtreecommitdiff
path: root/deskutils/sciplore-mindmapping
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2010-12-26 20:22:03 +0000
committerMatthias Andree <mandree@FreeBSD.org>2010-12-26 20:22:03 +0000
commit7989a465c8a51f960f44808d5d3b93fa4689f646 (patch)
tree1571cdbe72d53f5328c556e52065717b9c70cb85 /deskutils/sciplore-mindmapping
parent50582edb47506c54bb5fc633d6f5fd10b8d3853d (diff)
downloadports-7989a465c8a51f960f44808d5d3b93fa4689f646.tar.gz
ports-7989a465c8a51f960f44808d5d3b93fa4689f646.zip
Make sure to use diablo Java (freebsd), bsdjava exhibits JAXB issues.
Bump portrevision (changed launcher script that exports JAVA_HOME).
Notes
Notes: svn path=/head/; revision=266935
Diffstat (limited to 'deskutils/sciplore-mindmapping')
-rw-r--r--deskutils/sciplore-mindmapping/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/deskutils/sciplore-mindmapping/Makefile b/deskutils/sciplore-mindmapping/Makefile
index 66b9ed6ce87d..eeec4a2c2ce6 100644
--- a/deskutils/sciplore-mindmapping/Makefile
+++ b/deskutils/sciplore-mindmapping/Makefile
@@ -7,6 +7,7 @@
PORTNAME= sciplore-mindmapping
PORTVERSION= 0.b013
+PORTREVISION= 1
CATEGORIES= deskutils java
MASTER_SITES= SF
MASTER_SITE_SUBDIR= splmm/beta13
@@ -21,6 +22,7 @@ LICENSE= GPLv2
USE_ZIP= yes
USE_JAVA= yes
+JAVA_VENDOR= freebsd
JAVA_VERSION= 1.6
NO_BUILD= yes
DATADIR= ${JAVASHAREDIR}/${PORTNAME}
@@ -29,6 +31,7 @@ WRKSRC= ${WRKDIR}
post-patch:
${REINPLACE_CMD} -e 's/readlink -mn/readlink -n/' \
+ -e 's,/etc/freemind,${DATADIR},' \
${WRKSRC}/SciploreMindMapping.sh
do-install:
@@ -41,7 +44,10 @@ do-install:
# installation, as online help via the program menus.
${MKDIR} ${DATADIR}
(cd ${WRKSRC} && ${COPYTREE_SHARE} \* ${DATADIR})
- ${CHMOD} a=rx ${DATADIR}/SciploreMindMapping.sh
- ${LN} -s ${DATADIR}/SciploreMindMapping.sh ${PREFIX}/bin/${PORTNAME}
+ ${PRINTF} '#!/bin/sh\nexport JAVA_HOME=%s\nexec %s\n' \
+ '${JAVA_HOME}' '${DATADIR}/SciploreMindMapping.sh' \
+ >${PREFIX}/bin/${PORTNAME}
+ ${CHMOD} a=rx ${DATADIR}/SciploreMindMapping.sh \
+ ${PREFIX}/bin/${PORTNAME}
.include <bsd.port.mk>