aboutsummaryrefslogtreecommitdiff
path: root/deskutils/semantik
diff options
context:
space:
mode:
authorMarcus von Appen <mva@FreeBSD.org>2013-12-14 14:57:24 +0000
committerMarcus von Appen <mva@FreeBSD.org>2013-12-14 14:57:24 +0000
commit463c5275f4bde3340c70a85dc727bda771939f7f (patch)
tree108103f71e35f0358121e88f0d229dabb9d4c37b /deskutils/semantik
parent50cfc58f27626b350f6c37ab57f39a9aa06aec0f (diff)
downloadports-463c5275f4bde3340c70a85dc727bda771939f7f.tar.gz
ports-463c5275f4bde3340c70a85dc727bda771939f7f.zip
- Fix the usage of 'python' to get rid of the implicit lang/python
dependency Reported by: exp-run (PR 184591) Approved by: portmgr (blanket)
Notes
Notes: svn path=/head/; revision=336452
Diffstat (limited to 'deskutils/semantik')
-rw-r--r--deskutils/semantik/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/deskutils/semantik/Makefile b/deskutils/semantik/Makefile
index eeb2c1bf9d3a..c95a428ba7e1 100644
--- a/deskutils/semantik/Makefile
+++ b/deskutils/semantik/Makefile
@@ -47,15 +47,15 @@ post-patch:
do-configure:
@cd ${WRKSRC}; \
- ${SETENV} ${CONFIGURE_ENV} ./waf configure --prefix=${PREFIX}
+ ${SETENV} ${CONFIGURE_ENV} ${PYTHON_CMD} waf configure --prefix=${PREFIX}
do-build:
@cd ${WRKSRC}; \
- ${SETENV} ${MAKE_ENV} ./waf build ${_MAKE_JOBS}
+ ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} waf build ${_MAKE_JOBS}
do-install:
@cd ${WRKSRC}; \
- ${SETENV} ${MAKE_ENV} ./waf install
+ ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} waf install
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
.include <bsd.port.mk>