aboutsummaryrefslogtreecommitdiff
path: root/deskutils/teapot
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-11-23 17:34:53 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-11-23 17:34:53 +0000
commit611fcfa204445df63abaed70c7e5d0d7fcceca98 (patch)
tree1e56c95e4e917989a2ddcb508755796baa371502 /deskutils/teapot
parent47366a8998c7ef3a1460d3c9d375f855ff1a0f69 (diff)
downloadports-611fcfa204445df63abaed70c7e5d0d7fcceca98.tar.gz
ports-611fcfa204445df63abaed70c7e5d0d7fcceca98.zip
upgrade to 1.04
PR: 32214 Submitted by: KATO Tsuguru <tkato@prontomail.com>
Notes
Notes: svn path=/head/; revision=50418
Diffstat (limited to 'deskutils/teapot')
-rw-r--r--deskutils/teapot/Makefile17
-rw-r--r--deskutils/teapot/distinfo2
-rw-r--r--deskutils/teapot/files/patch-aa37
-rw-r--r--deskutils/teapot/pkg-descr2
4 files changed, 12 insertions, 46 deletions
diff --git a/deskutils/teapot/Makefile b/deskutils/teapot/Makefile
index 010528fc7e00..3a94fea6a3cb 100644
--- a/deskutils/teapot/Makefile
+++ b/deskutils/teapot/Makefile
@@ -6,13 +6,14 @@
#
PORTNAME= teapot
-PORTVERSION= 1.03
-PORTREVISION= 2
+PORTVERSION= 1.04
CATEGORIES= deskutils
MASTER_SITES= http://www.moria.de/~michael/teapot/
MAINTAINER= ports@FreeBSD.org
+MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS} -I./.curses.h -DNO_POSIX_SOURCE" \
+ LDFLAGS="" LIBS="-lcurses -mytinfo -lm" MAKEDEPEND=""
ALL_TARGET= teapot
MAN1= teapot.1
@@ -21,20 +22,22 @@ EXAMPLES= examples/asqrt examples/asqrt.README examples/blink \
examples/life.README examples/sqrt examples/sqrt.README
PORTDOCS= doc/teapot.doc doc/teapot.html doc/teapot.ps
+EXAMPLESDIR= ${PREFIX}/share/examples/${PORTNAME}
+
post-build:
- @ cd ${WRKSRC}/doc && ${MAKE} teapot.doc teapot.html teapot.ps
+ @cd ${WRKSRC}/doc && ${MAKE} teapot.doc teapot.html teapot.ps
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/teapot ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/teapot.1.en ${MANPREFIX}/man/man1/teapot.1
.if !defined(NOPORTDOCS)
- @${MKDIR} ${PREFIX}/share/examples/teapot
+ @${MKDIR} ${EXAMPLESDIR}
.for file in ${EXAMPLES}
- ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/examples/teapot
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${EXAMPLESDIR}
.endfor
- @${MKDIR} ${PREFIX}/share/doc/teapot
+ @${MKDIR} ${DOCSDIR}
.for file in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/teapot
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
.endfor
.endif
diff --git a/deskutils/teapot/distinfo b/deskutils/teapot/distinfo
index 20d8266551eb..14eb65dc7624 100644
--- a/deskutils/teapot/distinfo
+++ b/deskutils/teapot/distinfo
@@ -1 +1 @@
-MD5 (teapot-1.03.tar.gz) = 6d5348e6d051ca6b55e24ea36730c182
+MD5 (teapot-1.04.tar.gz) = 39a962abfa2ffb8965e08b86b5d4d3be
diff --git a/deskutils/teapot/files/patch-aa b/deskutils/teapot/files/patch-aa
deleted file mode 100644
index 83898a86c791..000000000000
--- a/deskutils/teapot/files/patch-aa
+++ /dev/null
@@ -1,37 +0,0 @@
---- Makefile.orig Fri Mar 9 04:50:04 2001
-+++ Makefile Wed Mar 14 20:22:07 2001
-@@ -1,16 +1,16 @@
- #{{{script}}}#{{{ Linux, moria machines, gcc
--CFLAGS= -g -pipe -O2 -Wall -Wmissing-prototypes -Wstrict-prototypes -Wcast-qual -Wpointer-arith -Wcast-align -Wwrite-strings -Wmissing-declarations -Wnested-externs -pedantic -fno-common
-+#CFLAGS= -g -pipe -O2 -Wall -Wmissing-prototypes -Wstrict-prototypes -Wcast-qual -Wpointer-arith -Wcast-align -Wwrite-strings -Wmissing-declarations -Wnested-externs -pedantic -fno-common
- # The XDR library needs _BSD_SOURCE :(
- CPPFLAGS= -D_BSD_SOURCE
- #CPPFLAGS= -DTHE_ELECTRIC_FENCE
- #CPPFLAGS= -I/usr/dmalloc/include -DDMALLOC
--LDFLAGS= -g
-+#LDFLAGS= -g
- #LDFLAGS= -g -L/usr/efence/lib
- #LDFLAGS= -g -L/usr/dmalloc/lib
--LIBS= -lcurses -lm
-+#LIBS= -lcurses -lm
- #LIBS= -lcurses -lm -lefence
- #LIBS= -lcurses -lm -ldmalloc
--MAKEDEPEND= mkdep -d
-+#MAKEDEPEND= mkdep -d
- #}}}
- #{{{ Linux, Slackware/Redhat/Debian Distribution, gcc
- #CC= gcc
-@@ -22,10 +22,9 @@
- #MAKEDEPEND= gcc -MM
- #}}}
- #{{{ FreeBSD 2.x, gcc
--#CC= gcc
--#CFLAGS= -pipe -O2 -Wall -Wmissing-prototypes -Wstrict-prototypes -Wcast-qual -Wpointer-arith -Wcast-align -Wwrite-strings -Wmissing-declarations -Wnested-externs -pedantic -fno-common
--#CPPFLAGS= -I./.curses.h -DNO_POSIX_SOURCE
--#LIBS= -lncurses -lmytinfo -lm
-+CC?= gcc
-+CFLAGS+= -pedantic -fno-common -I./.curses.h -DNO_POSIX_SOURCE
-+LIBS= -lncurses -lmytinfo -lm
- #LDFLAGS=
- #MAKEDEPEND= gcc -MM
- #}}}
diff --git a/deskutils/teapot/pkg-descr b/deskutils/teapot/pkg-descr
index b4f5f6029dc2..a47ff533d08a 100644
--- a/deskutils/teapot/pkg-descr
+++ b/deskutils/teapot/pkg-descr
@@ -19,4 +19,4 @@ o It is still a small and simple program!
The following URLs tell you a little more about it:
-WWW: http://www.moria.de/~michael/teapot/teapot-en.html
+WWW: http://www.moria.de/~michael/teapot/